summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-10-09 19:04:55 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-10-09 19:04:55 +0000
commitbfb7ac16c66d3bc52f8ad50c64350633ec542cc5 (patch)
treeaa1f754573e4c4348aed62c885129bdf1620a9c6 /media-sound
parentStable on amd64 wrt bug #338414 (diff)
downloadhistorical-bfb7ac16c66d3bc52f8ad50c64350633ec542cc5.tar.gz
historical-bfb7ac16c66d3bc52f8ad50c64350633ec542cc5.tar.bz2
historical-bfb7ac16c66d3bc52f8ad50c64350633ec542cc5.zip
Initial commit. Fixes Bug #328305.
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/puddletag/ChangeLog10
-rw-r--r--media-sound/puddletag/metadata.xml13
-rw-r--r--media-sound/puddletag/puddletag-0.9.5.ebuild48
3 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/puddletag/ChangeLog b/media-sound/puddletag/ChangeLog
new file mode 100644
index 000000000000..a1377df59996
--- /dev/null
+++ b/media-sound/puddletag/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/puddletag
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/puddletag/ChangeLog,v 1.1 2010/10/09 19:04:55 billie Exp $
+
+*puddletag-0.9.5 (09 Oct 2010)
+
+ 09 Oct 2010; Daniel Pielmeier <billie@gentoo.org> +puddletag-0.9.5.ebuild,
+ +metadata.xml:
+ Initial commit. Fixes Bug #328305.
+
diff --git a/media-sound/puddletag/metadata.xml b/media-sound/puddletag/metadata.xml
new file mode 100644
index 000000000000..851c47dc906f
--- /dev/null
+++ b/media-sound/puddletag/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>billie@gentoo.org</email>
+ <name>Daniel Pielmeier</name>
+ </maintainer>
+ <use>
+ <flag name="cover"> Enables editing of FLAC cover art</flag>
+ <flag name="quodlibet">Enables editing a QuodLibet library</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-sound/puddletag/puddletag-0.9.5.ebuild b/media-sound/puddletag/puddletag-0.9.5.ebuild
new file mode 100644
index 000000000000..710387c1794b
--- /dev/null
+++ b/media-sound/puddletag/puddletag-0.9.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/puddletag/puddletag-0.9.5.ebuild,v 1.1 2010/10/09 19:04:55 billie Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+PYTHON_MODNAME=puddlestuff
+
+inherit distutils fdo-mime python
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://puddletag.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="cover quodlibet"
+
+DEPEND=""
+RDEPEND=">=dev-python/PyQt4-4.5
+ >=dev-python/pyparsing-1.4
+ >=media-libs/mutagen-1.17
+ >=dev-python/configobj-4.7.2
+ >=dev-python/python-musicbrainz-0.7.0
+ cover? ( >=dev-python/imaging-1.1.7 )
+ quodlibet? ( >=media-sound/quodlibet-2.2.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 .
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ distutils_pkg_postrm
+}