summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-09 00:02:06 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-09 00:02:06 +0000
commitfa845023c231f70a17414025cc5b7395839cdca7 (patch)
tree51a21cce0c3659cdfb8e58bf425376a69368703e /media-sound
parentDep fix (diff)
downloadhistorical-fa845023c231f70a17414025cc5b7395839cdca7.tar.gz
historical-fa845023c231f70a17414025cc5b7395839cdca7.tar.bz2
historical-fa845023c231f70a17414025cc5b7395839cdca7.zip
Added USE alsa
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sox/sox-12.17.1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-sound/sox/sox-12.17.1.ebuild b/media-sound/sox/sox-12.17.1.ebuild
index 6d5384648ee4..1523b7b6caa9 100644
--- a/media-sound/sox/sox-12.17.1.ebuild
+++ b/media-sound/sox/sox-12.17.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.17.1.ebuild,v 1.5 2001/05/09 00:01:07 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-12.17.1.ebuild,v 1.6 2001/05/09 00:02:06 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -12,17 +12,18 @@ HOMEPAGE="http://home.sprynet.com/~cgabwell/sox.html"
DEPEND="virtual/glibc"
src_compile() {
-
- cd ${S}
+ local myconf
+ if [ "`use alsa`" ] ; then
+ myconf="--with-alsa-dsp"
+ fi
try ./configure --prefix=/usr --host=${CHOST} \
- --enable-fast-ulaw --enable-fast-alaw --with-alsa-dsp
+ --enable-fast-ulaw --enable-fast-alaw $myconf
try make
}
src_install () {
- cd ${S}
into /usr
dobin sox
doman sox.1