summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-06 18:04:30 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-06 18:04:30 +0000
commit42a1a888bac6a4160905beb4e9f82c29dafdc69b (patch)
tree9cd837cf049b0407faff109899559838b62d7a76 /media-video/qc-usb
parentnew logitech quickcam driver (diff)
downloadhistorical-42a1a888bac6a4160905beb4e9f82c29dafdc69b.tar.gz
historical-42a1a888bac6a4160905beb4e9f82c29dafdc69b.tar.bz2
historical-42a1a888bac6a4160905beb4e9f82c29dafdc69b.zip
new logitech quickcam driver
Diffstat (limited to 'media-video/qc-usb')
-rw-r--r--media-video/qc-usb/Manifest3
-rw-r--r--media-video/qc-usb/files/digest-qc-usb-0.5.11
-rw-r--r--media-video/qc-usb/qc-usb-0.5.1.ebuild39
3 files changed, 42 insertions, 1 deletions
diff --git a/media-video/qc-usb/Manifest b/media-video/qc-usb/Manifest
index d993a7a84811..c6fe9e91d280 100644
--- a/media-video/qc-usb/Manifest
+++ b/media-video/qc-usb/Manifest
@@ -1,2 +1,3 @@
-MD5 8166cd1a868201a2346b6aa662e4a059 qc-usb-0.5.1.ebuild 933
+MD5 3ae6ff3b2489d6260a1b5ed1cf0f4861 qc-usb-0.5.1.ebuild 933
+MD5 e5b0e0997d0a09ba3b11b320a2feeae3 ChangeLog 371
MD5 5e9ae5fc1d46670c449484a27578bbf9 files/digest-qc-usb-0.5.1 64
diff --git a/media-video/qc-usb/files/digest-qc-usb-0.5.1 b/media-video/qc-usb/files/digest-qc-usb-0.5.1
new file mode 100644
index 000000000000..7a2cdb118c1c
--- /dev/null
+++ b/media-video/qc-usb/files/digest-qc-usb-0.5.1
@@ -0,0 +1 @@
+MD5 160c2805a1f4ad0092525b88801b279c qc-usb-0.5.1.tar.gz 113700
diff --git a/media-video/qc-usb/qc-usb-0.5.1.ebuild b/media-video/qc-usb/qc-usb-0.5.1.ebuild
new file mode 100644
index 000000000000..177a915aef59
--- /dev/null
+++ b/media-video/qc-usb/qc-usb-0.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qc-usb/qc-usb-0.5.1.ebuild,v 1.1 2003/07/06 18:04:16 liquidx Exp $
+
+IUSE=""
+DESCRIPTION="Logitech USB Quickcam Express Linux Driver Modules"
+HOMEPAGE="http://qce-ga.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qce-ga/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/linux-sources"
+
+pkg_setup() {
+ [ -z "$KV" ] && die "Couldn't detect kernel version. Does /usr/src/linux exist?"
+ return 0
+}
+
+src_compile() {
+ # namespace conflict in makefile
+ unset DEBUG
+ emake all || die
+}
+
+src_install () {
+ # install the driver in the right palce
+ insinto "/lib/modules/${KV}/misc"
+ doins quickcam.o
+ dosbin qcset
+ # install the READMEs and License
+ dodoc README License
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]; then
+ /sbin/update-modules
+ fi
+}