summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-11-29 14:22:40 +0000
committerMarinus Schraal <foser@gentoo.org>2004-11-29 14:22:40 +0000
commitdc53a612ccaac6687c3921204563c94774cbfb23 (patch)
tree4a2fd4ebae9a57b2ed068db1541eb74b7383b449 /media-video/totem/files
parentUpdated the ioctl32 patch to match what has gone into cvs ustream. We also n... (diff)
downloadhistorical-dc53a612ccaac6687c3921204563c94774cbfb23.tar.gz
historical-dc53a612ccaac6687c3921204563c94774cbfb23.tar.bz2
historical-dc53a612ccaac6687c3921204563c94774cbfb23.zip
fix the fix
Diffstat (limited to 'media-video/totem/files')
-rw-r--r--media-video/totem/files/totem-0.99.22-reorder_includes.patch13
-rw-r--r--media-video/totem/files/totem-0.99.22-x_includes.patch43
2 files changed, 43 insertions, 13 deletions
diff --git a/media-video/totem/files/totem-0.99.22-reorder_includes.patch b/media-video/totem/files/totem-0.99.22-reorder_includes.patch
deleted file mode 100644
index 9f6f3defb7bf..000000000000
--- a/media-video/totem/files/totem-0.99.22-reorder_includes.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur totem-0.99.22/src/video-utils.c totem-0.99.22.new/src/video-utils.c
---- totem-0.99.22/src/video-utils.c 2004-10-14 14:55:46.000000000 +0200
-+++ totem-0.99.22.new/src/video-utils.c 2004-11-21 01:08:54.553510768 +0100
-@@ -3,8 +3,8 @@
-
- #include "video-utils.h"
-
--#include <glib/gi18n.h>
- #include <libintl.h>
-+#include <glib/gi18n.h>
-
- #include <gdk/gdk.h>
- #include <gdk/gdkx.h>
diff --git a/media-video/totem/files/totem-0.99.22-x_includes.patch b/media-video/totem/files/totem-0.99.22-x_includes.patch
new file mode 100644
index 000000000000..7eaac066ad30
--- /dev/null
+++ b/media-video/totem/files/totem-0.99.22-x_includes.patch
@@ -0,0 +1,43 @@
+--- configure.in 2004/11/22 21:41:20 1.1
++++ configure.in 2004/11/22 22:04:49
+@@ -199,15 +199,21 @@ AC_SUBST(REMOTE_LIBS)
+
+ AC_PATH_X
+
+-CFLAGS="-I$x_includes $CFLAGS"
+-LIBS="-L$x_libraries $LIBS"
++if test x"$x_includes" != x"NONE" && test -n "$x_includes" ; then
++ X_INCLUDES=-L`echo $x_includes | sed -e "s/:/ -I/g"`
++fi
++if test x"$x_libraries" != x"NONE" && test -n "$x_libraries" ; then
++ X_LIBRARIES=-L`echo $x_libraries | sed -e "s/:/ -L/g"`
++fi
++CFLAGS="$X_INCLUDES $CFLAGS"
++LIBS="$X_LIBRARIES $LIBS"
+
+ XTEST_LIBS=""
+ AC_CHECK_LIB(Xtst, XTestFakeKeyEvent,
+- XTEST_LIBS="-lX11 -lXtst -L$x_libraries"
++ XTEST_LIBS="-lX11 -lXtst $X_LIBRARIES"
+ AC_DEFINE(HAVE_XTEST, 1, [defined if you have XTest library]),
+ ,
+- -L$x_libraries)
++ $X_LIBRARIES)
+ AC_SUBST(XTEST_LIBS)
+
+ have_randr=no
+@@ -217,12 +223,12 @@ AC_CHECK_LIB(Xrandr, XRRUpdateConfigurat
+ RANDR_LIBS="-lX11 -lXrandr -lXrender"
+ AC_DEFINE(HAVE_RANDR, 1, Have the Xrandr extension library),
+ :, [#include <X11/Xlib.h>])], : ,
+- -L$x_libraries -lXrandr -lXrender)
++ $X_LIBRARIES -lXrandr -lXrender)
+ AM_CONDITIONAL(HAVE_RANDR, [test $have_randr = yes])
+ AC_SUBST(RANDR_LIBS)
+
+ dnl Explicitely link against libX11 to avoid problems with crappy linkers
+-X_LIBS="-L$x_libraries -lX11"
++X_LIBS="$X_LIBRARIES -lX11"
+ AC_SUBST(X_LIBS)
+
+ dnl Multimedia keys