summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-10-29 16:53:43 +0000
committerTilman Klar <phoenix@gentoo.org>2002-10-29 16:53:43 +0000
commitee3a2013f472ac7753182bf71d1512e9c3c9dede (patch)
tree507c32c425fe12be6d83d5b9680c97f6ecf7ef70 /media-video/transcode
parentAdded a fix for compiling. See bug #8567 (diff)
downloadhistorical-ee3a2013f472ac7753182bf71d1512e9c3c9dede.tar.gz
historical-ee3a2013f472ac7753182bf71d1512e9c3c9dede.tar.bz2
historical-ee3a2013f472ac7753182bf71d1512e9c3c9dede.zip
Bumped to the new version (transcode-0.6.1)
Diffstat (limited to 'media-video/transcode')
-rw-r--r--media-video/transcode/ChangeLog11
-rw-r--r--media-video/transcode/files/digest-transcode-0.6.11
-rw-r--r--media-video/transcode/transcode-0.6.1.ebuild101
3 files changed, 112 insertions, 1 deletions
diff --git a/media-video/transcode/ChangeLog b/media-video/transcode/ChangeLog
index 0a840f8e69b9..804e45f8a957 100644
--- a/media-video/transcode/ChangeLog
+++ b/media-video/transcode/ChangeLog
@@ -1,10 +1,19 @@
# ChangeLog for media-video/transcode
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.14 2002/09/11 20:54:14 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/ChangeLog,v 1.15 2002/10/29 16:53:43 phoenix Exp $
+
+*transcode-0.6.1 (29 Oct 2002)
+
+ 29 Oct 2002; phoen][x <phoenix@gentoo.org> ChangeLog, transcode-0.6.1.ebuild,
+ files/digest-transcode-0.6.1 :
+
+ Bumped to new version and put it in the unstable profile. This closes bug #9351.
+ Thanks to Tony Clark <tclark@telia.com> for the submission.
*transcode-0.6.0 (28 Aug 2002)
11 Sep 2002; Mark Guertin <gerk@gentoo.org> :
+
set nasm as x86 only dependancy
28 Aug 2002; phoen][x <phoenix@gentoo.org> transcode-0.6.0.ebuild :
diff --git a/media-video/transcode/files/digest-transcode-0.6.1 b/media-video/transcode/files/digest-transcode-0.6.1
new file mode 100644
index 000000000000..941a6d2d4bac
--- /dev/null
+++ b/media-video/transcode/files/digest-transcode-0.6.1
@@ -0,0 +1 @@
+MD5 ac9a66cff7cab3e52b089723e4b77ca7 transcode-0.6.1.tgz 2272803
diff --git a/media-video/transcode/transcode-0.6.1.ebuild b/media-video/transcode/transcode-0.6.1.ebuild
new file mode 100644
index 000000000000..842ef67568e5
--- /dev/null
+++ b/media-video/transcode/transcode-0.6.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/transcode/transcode-0.6.1.ebuild,v 1.1 2002/10/29 16:53:43 phoenix Exp $
+
+IUSE="sdl mmx mpeg sse dvd encode X quicktime avi"
+
+inherit libtool
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="video stream processing tool"
+SRC_URI="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode/${MY_P}.tgz"
+HOMEPAGE="http://www.theorie.physik.uni-goettingen.de/~ostreich/transcode"
+
+# Note: transcode can use pretty much any media-related package ever written as
+# a plugin. An exhaustive dep list would make me add about 20-30 packages to
+# portage. perhaps another time :-)
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=media-libs/a52dec-0.7.3
+ >=media-libs/libdv-0.9.5
+ x86? ( dev-lang/nasm )
+ X? ( virtual/x11 )
+ avi? ( >=media-video/avifile-0.7.4 )
+ dvd? ( media-libs/libdvdread )
+ mpeg? ( media-libs/libmpeg3 )
+ encode? ( >=media-sound/lame-3.89 )
+ sdl? ( media-libs/libsdl )
+ quicktime? ( media-libs/quicktime4linux )
+ >=media-video/avifile-0.7.4
+ media-libs/libdvdread"
+# Dont want to build without these currently
+# avi? ( >=media-video/avifile-0.7.4 )
+# dvd? ( media-libs/libdvdread )"
+
+src_compile() {
+
+ # fix invalid paths in .la files of plugins
+ elibtoolize
+
+ local myconf=""
+
+ use mmx \
+ && myconf="${myconf} --enable-mmx"
+ use mmx || ( use 3dnow || use sse ) \
+ || myconf="${myconf} --disable-mmx"
+ # Dont disable mmx if 3dnow or sse are requested.
+
+ use sse \
+ && myconf="${myconf} --enable-sse" \
+ || myconf="${myconf} --disable-sse"
+
+# use avi \
+# && myconf="${myconf} --with-avifile-mods --enable-avifile6" \
+# || myconf="${myconf} --without-avifile-mods --disable-avifile6"
+#
+# use dvd \
+# && myconf="${myconf} --with-dvdread" \
+# || myconf="${myconf} --without-dvdread"
+#
+# Dont currently want to build without these
+ myconf="${myconf} --with-dvdread --with-avifile-mods --enable-avifile6"
+
+ use encode \
+ && myconf="${myconf} --with-lame" \
+ || myconf="${myconf} --without-lame"
+
+ use mpeg \
+ && myconf="${myconf} --with-libmpeg3" \
+ || myconf="${myconf} --without-libmpeg3"
+
+ use quicktime \
+ || myconf="${myconf} --without-qt --without-openqt"
+
+ use X \
+ && myconf="${myconf} --enable-x" \
+ || myconf="${myconf} --disable-x"
+
+ # Use the MPlayer libpostproc if present
+ [ -f ${ROOT}/usr/lib/libpostproc.a ] && \
+ [ -f ${ROOT}/usr/include/postprocess.h ] && \
+ myconf="${myconf} --with-libpostproc-builddir=${ROOT}/usr/lib"
+
+ econf ${myconf} || die
+
+ # Do not use emake !!
+ make all || die
+}
+
+src_install () {
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog README TODO
+}
+