summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-24 21:09:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-24 21:09:12 +0000
commiteb7ce590726c1415304f642263748ecfabbcbe2a (patch)
tree45afd4848ab5ae1d7283c1079262681191933335 /media-video
parentinitial ebuild (diff)
downloadhistorical-eb7ce590726c1415304f642263748ecfabbcbe2a.tar.gz
historical-eb7ce590726c1415304f642263748ecfabbcbe2a.tar.bz2
historical-eb7ce590726c1415304f642263748ecfabbcbe2a.zip
version bump
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/ChangeLog11
-rw-r--r--media-video/avifile/avifile-0.7.3.20020419.ebuild87
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.3.200204191
3 files changed, 98 insertions, 1 deletions
diff --git a/media-video/avifile/ChangeLog b/media-video/avifile/ChangeLog
index dfaa5eef138b..099a5dd926f5 100644
--- a/media-video/avifile/ChangeLog
+++ b/media-video/avifile/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/avifile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.9 2002/04/14 02:44:36 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/ChangeLog,v 1.10 2002/04/24 21:09:12 seemant Exp $
+
+avifile-0.7.3.20020419 (24 Apr 2002)
+
+ 24 Apr 2002; Seemant Kulleen <seemant@gentoo.org> avifile-0.7.3.20020419.ebuild
+ files/digest-avifile-0.7.3.20020419 :
+
+ Version bump to newest snapshot. This should work with the latest
+ divx4linux and now has ffmpeg compiled as default. And they have actually
+ named this thing consistent with the 0.6 series!
avifile-0.6.0.20011220-r2 (13 Apr 2002)
diff --git a/media-video/avifile/avifile-0.7.3.20020419.ebuild b/media-video/avifile/avifile-0.7.3.20020419.ebuild
new file mode 100644
index 000000000000..5d9784c60e1b
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.3.20020419.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.3.20020419.ebuild,v 1.1 2002/04/24 21:09:12 seemant Exp $
+
+MY_P=${P/.200/-200}
+MY_S=${P/avifile-/avifile}
+MY_S=${MY_S/.3.200/-200}
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="Library for AVI-Files"
+SRC_URI="http://avifile.sourceforge.net/${MY_P}.tgz"
+HOMEPAGE="http://avifile.sourceforge.net/"
+
+DEPEND=">=media-libs/divx4linux-20011025
+ media-libs/jpeg
+ media-libs/win32codecs
+ qt? ( x11-libs/qt )
+ nas? ( >=media-libs/nas-1.4.2 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ oggvorbis? ( media-libs/libvorbis )"
+
+
+src_compile() {
+
+ einfo "${S}"
+
+ local myconf
+ local kdepre
+
+ use mmx && myconf="--enable-x86opt"
+ use sse && myconf="--enable-x86opt"
+ use 3dnow && myconf="--enable-x86opt"
+
+ use qt \
+ && myconf="${myconf} --with-qt-dir=${QTDIR}" \
+ || myconf="${myconf} --disable-qt"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ use nas && LDFLAGS="-L/usr/X11R6/lib -lXt"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ use kde \
+ && ( \
+ myconf="${myconf} --enable-kde" \
+ && LDFLAGS="${LDFLAGS} -L${KDEDIR}/lib" \
+ && myconf="${myconf} --with-extra-libraries=${KDEDIR}" \
+ ) || (
+ myconf="${myconf} --disable-kde" \
+ && LDFLAGS="${LDFLAGS}"
+ )
+
+
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+ ./configure --prefix=/usr \
+ --host=${CHOST} \
+ --enable-quiet \
+ --disable-tsc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ make prefix=${D}/usr install || die
+
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
diff --git a/media-video/avifile/files/digest-avifile-0.7.3.20020419 b/media-video/avifile/files/digest-avifile-0.7.3.20020419
new file mode 100644
index 000000000000..093792c524e3
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.3.20020419
@@ -0,0 +1 @@
+MD5 a7a1084621ad2702280a9c8796f7850d avifile-0.7.3-20020419.tgz 2145961