summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-07-26 23:51:06 +0000
committerNed Ludd <solar@gentoo.org>2003-07-26 23:51:06 +0000
commitafa27b8455c18c4782b8767df2efc75bb00b1201 (patch)
tree003be5a5ca2d94880bb73d0bd9b8015f73761239 /net-analyzer/piwi
parentversion bump, upstream now provides proper versioning (diff)
downloadhistorical-afa27b8455c18c4782b8767df2efc75bb00b1201.tar.gz
historical-afa27b8455c18c4782b8767df2efc75bb00b1201.tar.bz2
historical-afa27b8455c18c4782b8767df2efc75bb00b1201.zip
version bump, upstream now provides proper versioning
Diffstat (limited to 'net-analyzer/piwi')
-rw-r--r--net-analyzer/piwi/Manifest4
-rw-r--r--net-analyzer/piwi/files/digest-piwi-0.8.0.200307261
-rw-r--r--net-analyzer/piwi/piwi-0.8.0.20030726.ebuild74
3 files changed, 77 insertions, 2 deletions
diff --git a/net-analyzer/piwi/Manifest b/net-analyzer/piwi/Manifest
index bb8fbfb02b57..fdb60f7567d9 100644
--- a/net-analyzer/piwi/Manifest
+++ b/net-analyzer/piwi/Manifest
@@ -1,7 +1,7 @@
MD5 b4334dffbd9c1402b7ce92254c046de2 piwi-0.0.20030717.ebuild 2464
MD5 f82e3555485d648cb1b6667cc797b175 metadata.xml 342
-MD5 b99608717d7e566ef7370164a26a0ccd ChangeLog 460
-MD5 ff45f419c800aaa5c95adfb63afc817c piwi-0.8.0.20030726.ebuild 2614
+MD5 7d3cb24debb7f236f90497b99f9aca6e ChangeLog 615
+MD5 3bcac8d8a3e28eb6b23a1dcb16a6c039 piwi-0.8.0.20030726.ebuild 2616
MD5 4e10c46e4399dbacec468d5433b76fb7 files/digest-piwi-0.0.20030717 70
MD5 672e6d82c13378329cafd34502915311 files/make_release.sh 493
MD5 0f60257dc317130371e243385dd07fe7 files/piwi-apache.conf 364
diff --git a/net-analyzer/piwi/files/digest-piwi-0.8.0.20030726 b/net-analyzer/piwi/files/digest-piwi-0.8.0.20030726
new file mode 100644
index 000000000000..ca8fa03ed768
--- /dev/null
+++ b/net-analyzer/piwi/files/digest-piwi-0.8.0.20030726
@@ -0,0 +1 @@
+MD5 9a0015f3acd24bf9b5146fc118390b31 piwi_v0.8.0.20030726.tar.gz 246364
diff --git a/net-analyzer/piwi/piwi-0.8.0.20030726.ebuild b/net-analyzer/piwi/piwi-0.8.0.20030726.ebuild
new file mode 100644
index 000000000000..dd4c35beff9a
--- /dev/null
+++ b/net-analyzer/piwi/piwi-0.8.0.20030726.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/piwi/piwi-0.8.0.20030726.ebuild,v 1.1 2003/07/26 23:51:00 solar Exp $
+
+DESCRIPTION="(Prelude|Perl) IDS Web Interface"
+HOMEPAGE="http://www.prelude-ids.org"
+
+# [LeRoutier] son, i'll keep this versionning scheme : x.y.z.t (x.y to
+# match the major of prelude, z is piwi
+SRC_URI="http://www.leroutier.net/Projects/PreludeIDS/${PN}_v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql postgres gd"
+DEPEND="
+ dev-lang/perl
+ dev-perl/DBI
+ dev-perl/Date-Calc
+ postgresql? ( dev-perl/DBD-Pg )
+ mysql? ( dev-perl/DBD-mysql )
+ gd? ( dev-perl/GDGraph dev-perl/Geo-IP )
+"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ into /home/httpd/htdocs/piwi || die
+ into /etc/piwi || die
+
+ # "install" the files into the destination
+ cp -aR ${S}/* ${D}/home/httpd/htdocs/piwi/ || die
+
+ # Fix permissions
+ # Opt not to use the ebuild functions fowners() and fperms()
+ # as they doesn't seem to work reqursively.
+ chown -R root:apache ${D}/home/httpd/htdocs/piwi/* || die
+ chown -R apache:apache ${D}/home/httpd/htdocs/piwi/generated || die
+ chmod -R o-rwx ${D}/home/httpd/htdocs/piwi/* || die
+
+ # Move files around and create symlinks to make sure configuration files
+ # are not being overwritten when you do upgrades...
+ mv ${D}/home/httpd/htdocs/piwi/generated/Filters ${D}/etc/piwi/Filters || die
+ dosym /etc/piwi/Filters /home/httpd/htdocs/piwi/generated/Filters
+
+ mv ${D}/home/httpd/htdocs/piwi/Profiles ${D}/etc/piwi/Profiles || die
+ dosym /etc/piwi/Profiles /home/httpd/htdocs/piwi/Profiles
+
+ mv ${D}/home/httpd/htdocs/piwi/Functions/config.pl ${D}/etc/piwi/config.pl || die
+ dosym /etc/piwi/config.pl /home/httpd/htdocs/piwi/Functions/config.pl
+
+ # Install configuration file for apache
+ dodoc ${FILESDIR}/piwi-apache.conf
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "To have Apache run PIWI, please do the following:"
+ einfo "1) Include the /usr/share/doc/${P}/piwi-apache.conf in your apache configuration"
+ einfo "2) Edit /etc/conf.d/apache or /etc/conf.d/apache2 and add \"-D PIWI\""
+ einfo "3) Edit /etc/piwi/config.pl to reflect your settings"
+ ewarn ""
+ ewarn "NOTE: If you do not perform these steps PIWI will _not_ work."
+ ewarn " You have been warned. Any bugs against this will be either:"
+ ewarn ""
+ ewarn " - directed to /dev/null"
+ ewarn " - resolved with a RTFM comment"
+ ewarn ""
+ ewarn "Consider yourself warned"
+ # Make sure that the user pay attention
+ echo -ne "\a"; sleep 0.25 ; echo -ne "\a"; sleep 0.25
+}