summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-29 17:19:04 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-29 17:19:04 +0000
commit23a9116f3f9dbed771ce674b30681f43bcbceca3 (patch)
tree1e8c469df726328170d151b9c99900123eb6da86 /net-analyzer
parentUpdate, FHS2.1 fixes (diff)
downloadhistorical-23a9116f3f9dbed771ce674b30681f43bcbceca3.tar.gz
historical-23a9116f3f9dbed771ce674b30681f43bcbceca3.tar.bz2
historical-23a9116f3f9dbed771ce674b30681f43bcbceca3.zip
New version with ssl and working ipv6 support
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/tcpdump/files/digest-tcpdump-3.6.11
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.5.2.ebuild4
-rw-r--r--net-analyzer/tcpdump/tcpdump-3.6.1.ebuild32
3 files changed, 34 insertions, 3 deletions
diff --git a/net-analyzer/tcpdump/files/digest-tcpdump-3.6.1 b/net-analyzer/tcpdump/files/digest-tcpdump-3.6.1
new file mode 100644
index 000000000000..6598a62bd4ff
--- /dev/null
+++ b/net-analyzer/tcpdump/files/digest-tcpdump-3.6.1
@@ -0,0 +1 @@
+MD5 0ad9ecdf83e260894467935e2e6efcd2 tcpdump-3.6.1.tar.gz
diff --git a/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild b/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
index f78ceaf81261..8edcab929827 100644
--- a/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild,v 1.4 2000/12/08 17:21:49 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.5.2.ebuild,v 1.5 2001/04/29 17:19:04 achim Exp $
P=tcpdump-3.5.2
A=${P}.tar.gz
@@ -16,13 +16,11 @@ DEPEND=">=sys-libs/glibc-2.1.3
>=net-libs/libpcap-0.5.2"
src_compile() {
- cd ${S}
try ./configure --host=${CHOST} --prefix=/usr --disable-ipv6
try make
}
src_install() {
- cd ${S}
into /usr
dobin tcpdump
doman tcpdump.1
diff --git a/net-analyzer/tcpdump/tcpdump-3.6.1.ebuild b/net-analyzer/tcpdump/tcpdump-3.6.1.ebuild
new file mode 100644
index 000000000000..4b9c86efe541
--- /dev/null
+++ b/net-analyzer/tcpdump/tcpdump-3.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-3.6.1.ebuild,v 1.1 2001/04/29 17:19:04 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Tool for network monitoring and data acquisition"
+SRC_URI="http://www.tcpdump.org/release/${A}
+ http://www.jp.tcpdump.org/release/${A}"
+HOMEPAGE="http://www.tcpdump.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ >=dev-libs/openssl-0.6.9
+ >=net-libs/libpcap-0.6.1"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr
+#--disable-ipv6
+ try make
+}
+
+src_install() {
+ into /usr
+ dobin tcpdump
+ doman tcpdump.1
+ dodoc README FILES VERSION CHANGES
+}
+
+
+