summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Holland <tigger@gentoo.org>2004-02-12 13:26:29 +0000
committerRob Holland <tigger@gentoo.org>2004-02-12 13:26:29 +0000
commit61f8ddbe9c00014e02bd0729f81c748defa01f40 (patch)
tree0381b8882b294cd8802295fbd0fb4fff4ebd42c3 /net-analyzer
parentfix location of config file (diff)
downloadhistorical-61f8ddbe9c00014e02bd0729f81c748defa01f40.tar.gz
historical-61f8ddbe9c00014e02bd0729f81c748defa01f40.tar.bz2
historical-61f8ddbe9c00014e02bd0729f81c748defa01f40.zip
new nagios-plugins ebuild with hopefully more sensible useflags/dependancies
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins/ChangeLog9
-rw-r--r--net-analyzer/nagios-plugins/Manifest4
-rw-r--r--net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1-r11
-rw-r--r--net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild68
4 files changed, 79 insertions, 3 deletions
diff --git a/net-analyzer/nagios-plugins/ChangeLog b/net-analyzer/nagios-plugins/ChangeLog
index 0319795685cf..ee9f3c8551a9 100644
--- a/net-analyzer/nagios-plugins/ChangeLog
+++ b/net-analyzer/nagios-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/nagios-plugins
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.17 2003/12/15 15:01:16 mholzer Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/ChangeLog,v 1.18 2004/02/12 13:26:29 tigger Exp $
+
+*nagios-plugins-1.3.1-r1 (12 Feb 2004)
+
+ 12 Feb 2004; rob holland <tigger@gentoo.org> nagios-plugins-1.3.1-r1.ebuild:
+ new nagios-plugins ebuild with hopefully more sensible useflags/dependancies
15 Dec 2003; Martin Holzer <mholzer@gentoo.org> nagios-plugins-1.3.1.ebuild:
x86 stable.
diff --git a/net-analyzer/nagios-plugins/Manifest b/net-analyzer/nagios-plugins/Manifest
index bddfaf470238..6b3f316c9092 100644
--- a/net-analyzer/nagios-plugins/Manifest
+++ b/net-analyzer/nagios-plugins/Manifest
@@ -1,4 +1,6 @@
+MD5 51a9ecba35e070973f503ba06d330bde nagios-plugins-1.3.1-r1.ebuild 2246
MD5 564e9853c43760226881e577a3ba5197 nagios-plugins-1.3.1.ebuild 1775
-MD5 ada80c6df6a72680a4f20a1b76e24793 ChangeLog 2765
+MD5 7bd0707d986288ba491872aa50eae78d ChangeLog 2963
MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1 72
MD5 acb0b2b914b27b67b9a33807b1e6838e files/install-opts-fix.diff 3168
+MD5 39af7074b023625d9a75730bd6932437 files/digest-nagios-plugins-1.3.1-r1 72
diff --git a/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1-r1 b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1-r1
new file mode 100644
index 000000000000..52ae36d236e9
--- /dev/null
+++ b/net-analyzer/nagios-plugins/files/digest-nagios-plugins-1.3.1-r1
@@ -0,0 +1 @@
+MD5 0078c9c8137694181a4cdf596fdbd74f nagios-plugins-1.3.1.tar.gz 532516
diff --git a/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..56d9b45c3fe5
--- /dev/null
+++ b/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins/nagios-plugins-1.3.1-r1.ebuild,v 1.1 2004/02/12 13:26:29 tigger Exp $
+
+inherit eutils
+
+DESCRIPTION="Nagios $PV plugins - Pack of plugins to make Nagios work properly"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagiosplug/${P}.tar.gz"
+RESTRICT="nomirror"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="ldap mysql postgres ssl samba snmp nagios-dns nagios-ntp nagios-ping nagios-ssh"
+
+DEPEND="ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.52-r1 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ ssl? ( >=dev-libs/openssl-0.9.6g )"
+
+RDEPEND=">=dev-lang/perl-5.6.1-r7
+ samba? ( >=net-fs/samba-2.2.5-r1 )
+ snmp? (
+ >=dev-perl/Net-SNMP-4.0.1-r1
+ >=net-analyzer/net-snmp-5.0.6
+ )
+ nagios-dns? ( >=net-dns/bind-tools-9.2.2_rc1 )
+ nagios-ntp? ( >=net-misc/ntp-4.1.1a )
+ nagios-ping? ( >=net-analyzer/fping-2.4_beta2-r1 )
+ nagios-ssh? ( >=net-misc/openssh-3.5_p1 )"
+
+S="${WORKDIR}/${P}"
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /dev/null nagios
+}
+
+src_compile() {
+ local myconf
+ use mysql && myconf="${myconf} --with-mysql" || myconf="${myconf} --without-mysql"
+ use postgres && myconf="${myconf} --with-pgsql" || myconf="${myconf} --without-pgsql"
+ use ssl && myconf="${myconf} --with-openssl" || myconf="${myconf} --without-openssl"
+
+ ./configure ${myconf} \
+ --host=${CHOST} \
+ --prefix=/usr/nagios \
+ --with-nagios-user=nagios \
+ --sysconfdir=/etc/nagios \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ make || die
+}
+
+src_install() {
+ dodoc AUTHORS CODING COPYING ChangeLog FAQ INSTALL LEGALNEWS README REQUIREMENTS ROADMAP Requirements
+ make DESTDIR=${D} install || die
+}
+
+pkg_preinst() {
+ chown -R nagios:nagios ${D}/usr/nagios/libexec || die "Failed Chown of ${D}/usr/nagios/libexec"
+}
+
+pkg_postinst() {
+ einfo "This ebuild has a number of USE flags which determines what nagios is able to monitor."
+ einfo "Depending on what you want to monitor with nagios, some or all of these USE"
+ einfo "flags need to be set for nagios to function correctly."
+}