summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-11-27 23:33:26 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-11-27 23:33:26 +0000
commit8f05364766b04c24f99b63113efbec460d602dd3 (patch)
tree243d60f45353b45fe41b4e6ba6e2b1ba1e97d263 /net-analyzer
parentAdded patch to make it works on amd64 and removed -amd64 keyword. (diff)
downloadhistorical-8f05364766b04c24f99b63113efbec460d602dd3.tar.gz
historical-8f05364766b04c24f99b63113efbec460d602dd3.tar.bz2
historical-8f05364766b04c24f99b63113efbec460d602dd3.zip
tcltk fix and cleanup
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog8
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.49.ebuild20
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.0.50.ebuild20
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild16
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild16
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild18
6 files changed, 57 insertions, 41 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index 9dfe1dc14124..540dc02691ef 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.96 2006/10/21 18:43:30 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.97 2006/11/27 23:33:26 jokey Exp $
+
+ 27 Nov 2006; Markus Ullmann <jokey@gentoo.org> rrdtool-1.0.49.ebuild,
+ rrdtool-1.0.50.ebuild, rrdtool-1.2.6-r1.ebuild, rrdtool-1.2.11-r2.ebuild,
+ -rrdtool-1.2.13.ebuild, -rrdtool-1.2.15.ebuild, -rrdtool-1.2.15-r1.ebuild,
+ rrdtool-1.2.15-r2.ebuild:
+ tcltk fix and cleanup
21 Oct 2006; Tobias Scherbaum <dertobi123@gentoo.org>
rrdtool-1.2.11-r2.ebuild:
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild
index a453a451153a..bf385d6bfeed 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild,v 1.8 2005/05/26 13:17:43 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.49.ebuild,v 1.9 2006/11/27 23:33:26 jokey Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -11,14 +11,14 @@ SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64"
-IUSE="perl tcltk"
+IUSE="perl tcl"
DEPEND="perl? ( dev-lang/perl )
sys-apps/gawk
>=media-libs/gd-1.8.3"
-RDEPEND="tcltk? ( dev-lang/tcl )"
+RDEPEND="tcl? ( dev-lang/tcl )"
-TCLVER=""
+TCL_VER=""
pkg_setup() {
if use perl ; then
@@ -43,9 +43,11 @@ src_compile() {
local myconf
myconf="${myconf} --datadir=/usr/share --enable-shared"
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/lib" \
- || myconf="${myconf} --without-tcllib"
+ if use tcl ; then
+ myconf="${myconf} --with-tcllib=/usr/lib"
+ else
+ myconf="${myconf} --without-tcllib"
+ fi
if use perl; then
econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
@@ -91,7 +93,7 @@ src_install() {
rm -Rf ${D}/usr/lib/perl
fi
- if use tcltk ; then
+ if use tcl ; then
# mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
# insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
# doins ${S}/tcl/tclrrd${PV}.so
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild
index 82ce1607c917..6f239c6a5c93 100644
--- a/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild,v 1.1 2005/04/27 12:30:37 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.50.ebuild,v 1.2 2006/11/27 23:33:26 jokey Exp $
inherit perl-module flag-o-matic gnuconfig eutils
@@ -11,14 +11,14 @@ SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/rrdtool-1.0.x/${
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
-IUSE="perl tcltk"
+IUSE="perl tcl"
DEPEND="perl? ( dev-lang/perl )
sys-apps/gawk
>=media-libs/gd-1.8.3"
-RDEPEND="tcltk? ( dev-lang/tcl )"
+RDEPEND="tcl? ( dev-lang/tcl )"
-TCLVER=""
+TCL_VER=""
pkg_setup() {
use perl && perl-module_pkg_setup
@@ -41,9 +41,11 @@ src_compile() {
local myconf
myconf="${myconf} --datadir=/usr/share --enable-shared"
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/lib" \
- || myconf="${myconf} --without-tcllib"
+ if use tcl ; then
+ myconf="${myconf} --with-tcllib=/usr/lib"
+ else
+ myconf="${myconf} --without-tcllib"
+ fi
if use perl; then
econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
@@ -89,7 +91,7 @@ src_install() {
rm -Rf ${D}/usr/lib/perl
fi
- if use tcltk ; then
+ if use tcl ; then
# mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
# insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
# doins ${S}/tcl/tclrrd${PV}.so
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild
index 540e03da4f4f..e5379e49a99d 100644
--- a/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild,v 1.8 2006/11/12 03:43:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.11-r2.ebuild,v 1.9 2006/11/27 23:33:26 jokey Exp $
inherit perl-module flag-o-matic gnuconfig eutils multilib
@@ -11,9 +11,9 @@ SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/${PN}/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha ~amd64 arm ~hppa ia64 ~mips ppc ppc64 sh ~sparc ~x86"
-IUSE="doc perl python tcltk"
+IUSE="doc perl python tcl"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
>=sys-libs/zlib-1.2.1
>=media-libs/freetype-2.1.5
>=media-libs/libart_lgpl-2.3.16
@@ -53,9 +53,11 @@ src_compile() {
local myconf
myconf="--datadir=/usr/share --enable-shared"
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/$(get_libdir)" \
- || myconf="${myconf} --without-tcllib"
+ if use tcl ; then
+ myconf="${myconf} --with-tcllib=/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-tcllib"
+ fi
use python || myconf="${myconf} --disable-python"
@@ -94,7 +96,7 @@ src_install() {
rm -Rf "${D}"/usr/lib/perl
fi
- if use tcltk ; then
+ if use tcl ; then
mv "${S}"/bindings/tcl/tclrrd.so "${S}"/bindings/tcl/tclrrd${PV}.so
insinto /usr/$(get_libdir)/tcl${TCL_VER}/tclrrd${PV}
doins "${S}"/bindings/tcl/tclrrd${PV}.so
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild
index 708918497490..8c135c13cc5b 100644
--- a/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild,v 1.2 2006/11/12 03:43:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.15-r2.ebuild,v 1.3 2006/11/27 23:33:26 jokey Exp $
inherit perl-module flag-o-matic gnuconfig eutils multilib autotools
@@ -11,9 +11,9 @@ SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/${PN}/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-IUSE="doc perl python rrdcgi tcltk uclibc"
+IUSE="doc perl python rrdcgi tcl uclibc"
-RDEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcl? ( dev-lang/tcl )
>=sys-libs/zlib-1.2.1
>=media-libs/freetype-2.1.5
>=media-libs/libart_lgpl-2.3.16
@@ -54,9 +54,11 @@ src_compile() {
local myconf
myconf="--datadir=/usr/share --enable-shared"
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/$(get_libdir)" \
- || myconf="${myconf} --without-tcllib"
+ if use tcl ; then
+ myconf="${myconf} --with-tcllib=/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-tcllib"
+ fi
use python || myconf="${myconf} --disable-python"
@@ -99,7 +101,7 @@ src_install() {
rm -Rf "${D}"/usr/lib/perl
fi
- if use tcltk ; then
+ if use tcl ; then
mv "${S}"/bindings/tcl/tclrrd.so "${S}"/bindings/tcl/tclrrd${PV}.so
insinto /usr/$(get_libdir)/tcl${TCL_VER}/tclrrd${PV}
doins "${S}"/bindings/tcl/tclrrd${PV}.so
diff --git a/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild
index d85833dc305a..35ae184cd4b3 100644
--- a/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild,v 1.13 2005/12/26 15:26:44 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.2.6-r1.ebuild,v 1.14 2006/11/27 23:33:26 jokey Exp $
inherit perl-module flag-o-matic gnuconfig eutils multilib
@@ -11,7 +11,7 @@ SRC_URI="http://people.ee.ethz.ch/~oetiker/webtools/${PN}/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
-IUSE="doc perl tcltk"
+IUSE="doc perl tcl"
DEPEND="perl? ( dev-lang/perl )
sys-apps/gawk
@@ -21,7 +21,7 @@ DEPEND="perl? ( dev-lang/perl )
>=media-libs/libpng-1.2.5
>=media-libs/gd-1.8.3
>=dev-libs/cgilib-0.5"
-RDEPEND="tcltk? ( dev-lang/tcl )"
+RDEPEND="tcl? ( dev-lang/tcl )"
TCLVER=""
@@ -47,9 +47,11 @@ src_compile() {
local myconf
myconf="--datadir=/usr/share --enable-shared"
- use tcltk \
- && myconf="${myconf} --with-tcllib=/usr/$(get_libdir)" \
- || myconf="${myconf} --without-tcllib"
+ if use tcl ; then
+ myconf="${myconf} --with-tcllib=/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-tcllib"
+ fi
if use perl ; then
econf ${myconf} --with-perl-options='PREFIX=/usr INSTALLDIRS=vendor DESTDIR=${D}' || die "econf failed"
@@ -89,7 +91,7 @@ src_install() {
rm -Rf ${D}/usr/lib/perl
fi
- if use tcltk ; then
+ if use tcl ; then
mv ${S}/bindings/tcl/tclrrd.so ${S}/bindings/tcl/tclrrd${PV}.so
insinto /usr/$(get_libdir)/tcl${TCL_VER}/tclrrd${PV}
doins ${S}/bindings/tcl/tclrrd${PV}.so