summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:22:32 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:22:32 +0000
commit98b60a090bebcd04d92e0959815cb3f0782cbc26 (patch)
tree6e7401fd08eefe4b5bf5d72323e9e770eb7cd15e /net-dialup/e2220pc
parentStable on x86 wrt bug #208032 (diff)
downloadhistorical-98b60a090bebcd04d92e0959815cb3f0782cbc26.tar.gz
historical-98b60a090bebcd04d92e0959815cb3f0782cbc26.tar.bz2
historical-98b60a090bebcd04d92e0959815cb3f0782cbc26.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
Package-Manager: portage-2.1.4
Diffstat (limited to 'net-dialup/e2220pc')
-rw-r--r--net-dialup/e2220pc/ChangeLog9
-rw-r--r--net-dialup/e2220pc/e2220pc-0.1-r1.ebuild53
-rw-r--r--net-dialup/e2220pc/files/digest-e2220pc-0.1-r13
-rw-r--r--net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff46
4 files changed, 110 insertions, 1 deletions
diff --git a/net-dialup/e2220pc/ChangeLog b/net-dialup/e2220pc/ChangeLog
index 0dcd5f2f98de..6c958f926e54 100644
--- a/net-dialup/e2220pc/ChangeLog
+++ b/net-dialup/e2220pc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/e2220pc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/ChangeLog,v 1.1 2008/01/06 01:25:30 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/ChangeLog,v 1.2 2008/01/30 01:19:27 sbriesen Exp $
+
+*e2220pc-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/e2220pc_kernel-2.6.24.diff, +e2220pc-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*e2220pc-0.1 (06 Jan 2008)
diff --git a/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild b/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild
new file mode 100644
index 000000000000..a5d060aefb8d
--- /dev/null
+++ b/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/e2220pc/e2220pc-0.1-r1.ebuild,v 1.1 2008/01/30 01:19:27 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Eumex 2220 PC"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack eumex*.tar.bz2
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1 b/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1
new file mode 100644
index 000000000000..175474777fe5
--- /dev/null
+++ b/net-dialup/e2220pc/files/digest-e2220pc-0.1-r1
@@ -0,0 +1,3 @@
+MD5 885ab096b4b7b6a3bad3826a2c53945e e2220pc-0.1-0.src.rpm 316445
+RMD160 9a469e7942256856a928e31802276f34d47fda96 e2220pc-0.1-0.src.rpm 316445
+SHA256 0ad115ae513f13cad002468924e983271e418f98e16b4762dd62b77030e00ae5 e2220pc-0.1-0.src.rpm 316445
diff --git a/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff b/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff
new file mode 100644
index 000000000000..6e42ce76f162
--- /dev/null
+++ b/net-dialup/e2220pc/files/e2220pc_kernel-2.6.24.diff
@@ -0,0 +1,46 @@
+--- src/driver.c.orig 2008-01-30 02:03:44.000000000 +0100
++++ src/driver.c 2008-01-30 02:03:44.000000000 +0100
+@@ -91,8 +91,12 @@
+ static DECLARE_WAIT_QUEUE_HEAD(sched_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(tx_wait);
+ static DECLARE_WAIT_QUEUE_HEAD(rx_wait);
++static DECLARE_COMPLETION(hotplug); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(notify); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
+ static DECLARE_MUTEX_LOCKED(notify);
++#endif
+
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/
+@@ -754,7 +758,7 @@
+ close_func = func;
+ close_data = data;
+
+- INIT_WORK (&closing_work, closing_worker);
++ INIT_WORK (&closing_work, (work_func_t)closing_worker);
+ schedule_work (&closing_work);
+ LOG("Worker scheduled.\n");
+ } /* start_closing_worker */
+@@ -1171,7 +1175,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&hotplug); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&hotplug);
++ #endif
+ return 0;
+ } /* scheduler */
+
+@@ -1206,7 +1213,10 @@
+ wake_up_interruptible (&wait);
+ }
+ LOG("Scheduler thread signalled, waiting...\n");
++ wait_for_completion(&hotplug); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&hotplug);
++ #endif
+ LOG("Scheduler thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;