summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-10-02 21:24:23 +0000
committerNed Ludd <solar@gentoo.org>2004-10-02 21:24:23 +0000
commit903f5f7eb45c481cdfe3fc4e6a04f63da061120a (patch)
tree722f5240a05d82e24d7dc84597029bd176127402 /net-dialup/mingetty
parentKeyword ~alpha, requested in bug 64485. (diff)
downloadhistorical-903f5f7eb45c481cdfe3fc4e6a04f63da061120a.tar.gz
historical-903f5f7eb45c481cdfe3fc4e6a04f63da061120a.tar.bz2
historical-903f5f7eb45c481cdfe3fc4e6a04f63da061120a.zip
replaced legacy interface sys_errlist[errno] with strerror(errno)
Diffstat (limited to 'net-dialup/mingetty')
-rw-r--r--net-dialup/mingetty/ChangeLog6
-rw-r--r--net-dialup/mingetty/Manifest15
-rw-r--r--net-dialup/mingetty/files/mingetty-1.00-strerror.patch52
-rw-r--r--net-dialup/mingetty/mingetty-1.00.3.ebuild3
4 files changed, 72 insertions, 4 deletions
diff --git a/net-dialup/mingetty/ChangeLog b/net-dialup/mingetty/ChangeLog
index c00aa7dcf730..8dbd10822bc5 100644
--- a/net-dialup/mingetty/ChangeLog
+++ b/net-dialup/mingetty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-dialup/mingetty
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/ChangeLog,v 1.18 2004/07/01 22:08:51 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/ChangeLog,v 1.19 2004/10/02 21:24:23 solar Exp $
+
+ 02 Oct 2004; <solar@gentoo.org> +files/mingetty-1.00-strerror.patch,
+ mingetty-1.00.3.ebuild:
+ replaced legacy interface sys_errlist[errno] with strerror(errno)
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
mingetty-1.00.3.ebuild:
diff --git a/net-dialup/mingetty/Manifest b/net-dialup/mingetty/Manifest
index e71fea7a60dd..539170438473 100644
--- a/net-dialup/mingetty/Manifest
+++ b/net-dialup/mingetty/Manifest
@@ -1,5 +1,16 @@
-MD5 53ce18f538a7eef5e7c82600a0bb1cbf ChangeLog 2415
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 1bfa8124cbb1a5150eb36896bb9b6bcf ChangeLog 2576
MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
-MD5 cd9f33d18e5f1c59dc680885090dbb47 mingetty-1.00.3.ebuild 864
+MD5 980e373ac1cc0d5ae974ce7bcd97e927 mingetty-1.00.3.ebuild 910
MD5 5f50d456f26044f81b45f8ca250ab5c6 files/digest-mingetty-1.00.3 67
MD5 2468fd4da2ffd9439faecf5eb7630d85 files/mingetty-1.00-autologin.patch 13742
+MD5 b45f8ff6a45dabcd3b6d8477912dbd12 files/mingetty-1.00-strerror.patch 1729
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.4 (GNU/Linux)
+
+iD8DBQFBXxxP94CCfB4KcwwRAkUyAJ9DnOSi3MeOk9HJk6sItRACLEKL5QCeJ2V1
+ONzLnAGEk7w8Sde4M0OFZsA=
+=I3c1
+-----END PGP SIGNATURE-----
diff --git a/net-dialup/mingetty/files/mingetty-1.00-strerror.patch b/net-dialup/mingetty/files/mingetty-1.00-strerror.patch
new file mode 100644
index 000000000000..a3ec9e136ef2
--- /dev/null
+++ b/net-dialup/mingetty/files/mingetty-1.00-strerror.patch
@@ -0,0 +1,52 @@
+--- mingetty-1.00/mingetty.c.orig 2004-10-02 21:13:08.000000000 +0000
++++ mingetty-1.00/mingetty.c 2004-10-02 21:13:52.000000000 +0000
+@@ -193,7 +193,7 @@
+ strcpy (buf, "/dev/");
+ strcat (buf, tty);
+ if (chown (buf, 0, 0) || chmod (buf, 0600))
+- error ("%s: %s", buf, sys_errlist[errno]);
++ error ("%s: %s", buf, strerror(errno));
+
+ sa.sa_handler = SIG_IGN;
+ sa.sa_flags = 0;
+@@ -208,7 +208,7 @@
+ */
+ if ((fd = open (buf, O_RDWR, 0)) < 0
+ || ioctl (fd, TIOCSCTTY, (void *)1) == -1)
+- error ("%s: cannot open tty: %s", buf, sys_errlist[errno]);
++ error ("%s: cannot open tty: %s", buf, strerror(errno));
+ if (!isatty (fd))
+ error ("%s: not a tty", buf);
+
+@@ -222,11 +222,11 @@
+
+ if (open (buf, O_RDWR, 0) != 0)
+ error ("%s: cannot open as standard input: %s", buf,
+- sys_errlist[errno]);
++ strerror(errno));
+
+ /* Set up standard output and standard error file descriptors. */
+ if (dup (0) != 1 || dup (0) != 2)
+- error ("%s: dup problem: %s", buf, sys_errlist[errno]);
++ error ("%s: dup problem: %s", buf, strerror(errno));
+
+ /* Write a reset string to the terminal. This is very linux-specific
+ and should be checked for other systems. */
+@@ -377,7 +377,7 @@
+ if (errno == EINTR || errno == EIO
+ || errno == ENOENT)
+ exit (0);
+- error ("%s: read: %s", tty, sys_errlist[errno]);
++ error ("%s: read: %s", tty, strerror(errno));
+ }
+ if (c == '\n' || c == '\r') {
+ *bp = 0;
+@@ -517,7 +517,7 @@
+ while ((logname = get_logname ()) == 0) ;
+ execl (_PATH_LOGIN, _PATH_LOGIN, "--", logname, NULL);
+ }
+- error ("%s: can't exec " _PATH_LOGIN ": %s", tty, sys_errlist[errno]);
++ error ("%s: can't exec " _PATH_LOGIN ": %s", tty, strerror(errno));
+ exit (0);
+ }
+
diff --git a/net-dialup/mingetty/mingetty-1.00.3.ebuild b/net-dialup/mingetty/mingetty-1.00.3.ebuild
index b24f5c804208..97c4ccfc2890 100644
--- a/net-dialup/mingetty/mingetty-1.00.3.ebuild
+++ b/net-dialup/mingetty/mingetty-1.00.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/mingetty-1.00.3.ebuild,v 1.18 2004/07/14 23:02:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/mingetty/mingetty-1.00.3.ebuild,v 1.19 2004/10/02 21:24:23 solar Exp $
inherit rpm eutils
@@ -21,6 +21,7 @@ RDEPEND="virtual/libc"
src_unpack() {
rpm_src_unpack
epatch ${FILESDIR}/mingetty-1.00-autologin.patch
+ epatch ${FILESDIR}/mingetty-1.00-strerror.patch
}
src_compile() {