summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-12-15 17:22:11 +0000
committerTilman Klar <phoenix@gentoo.org>2002-12-15 17:22:11 +0000
commitda7b75f62f8559c5d2a78bc878ffda958d2be905 (patch)
tree564e379a2d1d087c178678d7a918ca3f1614f7b9 /net-dialup/ppp
parentReleasing java-config with lots of bug-fixes and new features. (diff)
downloadhistorical-da7b75f62f8559c5d2a78bc878ffda958d2be905.tar.gz
historical-da7b75f62f8559c5d2a78bc878ffda958d2be905.tar.bz2
historical-da7b75f62f8559c5d2a78bc878ffda958d2be905.zip
Fixed bug #12002. Check the ChangeLog.
Diffstat (limited to 'net-dialup/ppp')
-rw-r--r--net-dialup/ppp/ChangeLog11
-rw-r--r--net-dialup/ppp/files/digest-ppp-2.4.1-r121
-rw-r--r--net-dialup/ppp/ppp-2.4.1-r12.ebuild131
3 files changed, 142 insertions, 1 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 6fd2ec87da33..a50bb1c82ddf 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,9 +1,18 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.14 2002/12/13 10:59:50 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.15 2002/12/15 17:22:11 phoenix Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*ppp-2.4.1-r12 (15 Dec 2002)
+
+ 15 Dec 2002; phoen][x <phoenix@gentoo.org> ppp-2.4.1-r12.ebuild, ChangeLog,
+ files/digest-ppp-2.4.1-r12 :
+ Fixed a pretty severe bug: /etc/modules.d/ppp was set +x - that caused
+ a strange behaviour with update-modules. See bug #12002 for more details.
+ Fixed the LICENSE setting: GPL -> GPL-2.
+ Revision bump to force portage to update ppp.
+
*ppp-2.4.1-r11 (28 Aug 2002)
13 Nov 2002; Hannes Mehnert <hannes@gentoo.org> ppp-2.4.1-r11.ebuild :
diff --git a/net-dialup/ppp/files/digest-ppp-2.4.1-r12 b/net-dialup/ppp/files/digest-ppp-2.4.1-r12
new file mode 100644
index 000000000000..b3c7b1676065
--- /dev/null
+++ b/net-dialup/ppp/files/digest-ppp-2.4.1-r12
@@ -0,0 +1 @@
+MD5 7f655448fbb6bebcede7a515fbcd481e ppp-2.4.1-pppoe4.tgz 556218
diff --git a/net-dialup/ppp/ppp-2.4.1-r12.ebuild b/net-dialup/ppp/ppp-2.4.1-r12.ebuild
new file mode 100644
index 000000000000..9de8ff9b67ae
--- /dev/null
+++ b/net-dialup/ppp/ppp-2.4.1-r12.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.1-r12.ebuild,v 1.1 2002/12/15 17:22:11 phoenix Exp $
+
+IUSE="crypt ipv6"
+S=${WORKDIR}/${P}.pppoe4
+DESCRIPTION="Point-to-point protocol - patched for pppoe"
+SRC_URI="mirror://gentoo/${P}-pppoe4.tgz"
+HOMEPAGE="http://www.samba.org/ppp"
+
+DEPEND="virtual/glibc"
+PROVIDE="virtual/pppd"
+
+SLOT="0"
+LICENSE="BSD GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+src_compile() {
+
+ use crypt && {
+ zcat ${FILESDIR}/ppp-2.4.1-openssl-0.9.6-mppe-patch.gz | patch -p1
+ patch -p1 < ${FILESDIR}/ppp-2.4.1-MSCHAPv2-fix.patch
+ }
+
+ patch -p0 < ${FILESDIR}/${P}-r10.patch
+
+ ./configure --prefix=/usr || die
+
+ #fix Makefiles to compile optimized
+ cd pppd
+ mv Makefile Makefile.orig
+ if([ `use ipv6` ]) then
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ -e "s/#HAVE_INET6/HAVE_INET6/" \
+ -e "s/# CBCP_SUPPORT/CBCP_SUPPORT/" Makefile.orig > Makefile
+ else
+ sed -e "s:COPTS = -O2 -pipe -Wall -g:COPTS = ${CFLAGS}:" \
+ -e "s/LIBS =/LIBS = -lcrypt/" \
+ -e "s/# CBCP_SUPPORT/CBCP_SUPPORT/" Makefile.orig > Makefile
+ fi
+
+ cd plugins
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g -O2:CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd pppoe
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS\t= -g :CFLAGS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../../../pppstats
+ mv Makefile Makefile.orig
+ sed -e "s:COPTS= -O:COPTS = ${CFLAGS}:" \
+ Makefile.orig > Makefile
+ cd ../chat
+ mv Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ cd ../pppdump
+ mv Makefile Makefile.orig
+ sed -e "s:CFLAGS= -O:CFLAGS= ${CFLAGS}:" Makefile.orig > Makefile
+ cd ..
+
+ export CC=gcc
+
+ emake || die
+}
+
+src_install() {
+ for y in chat pppd pppdump pppstats
+ do
+ doman ${y}/${y}.8
+ dosbin ${y}/${y}
+ done
+
+ chmod u+s-w ${D}/usr/sbin/pppd
+ chown root:daemon ${D}/usr/sbin/pppstats
+
+ dodir /etc/ppp/peers
+ insinto /etc/ppp
+ insopts -m0600
+ doins etc.ppp/pap-secrets etc.ppp/chap-secrets
+ insopts -m0644
+ doins etc.ppp/options
+ insopts -m0755
+ doins ${FILESDIR}/ip-up
+
+ dolib.so pppd/plugins/minconn.so
+ dolib.so pppd/plugins/passprompt.so
+ dolib.so pppd/plugins/pppoe/pppoe.so
+ dodir /usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ mv ${D}/usr/lib/*.so ${D}/usr/lib/pppd/$(awk -F '"' '/VERSION/ {print $2}' pppd/patchlevel.h)
+ insinto /etc/modules.d
+ insopts -m0644
+ newins ${FILESDIR}/modules.ppp ppp
+
+ dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+ dohtml ${FILESDIR}/pppoe.html
+
+# This will have to be updated to work with the new net.ppp0
+# # Added a couple scripts to simplify dialing up
+# # borrowed from debian, man they got some nice little apps :-)
+# dosbin ${FILESDIR}/pon
+# dosbin ${FILESDIR}/poff
+# doman ${FILESDIR}/pon.1
+}
+
+pkg_postinst() {
+ if [ ! -e ${ROOT}dev/.devfsd ]
+ then
+ if [ ! -e ${ROOT}dev/ppp ]; then
+ mknod ${ROOT}dev/ppp c 108 0
+ fi
+ fi
+ if [ "$ROOT" = "/" ]
+ then
+ /sbin/update-modules
+ fi
+ einfo "to enable kernel-pppoe read html/pppoe.html in the doc-directory"
+}
+
+pkg_preinst() {
+ ### Fix those broken flags (755 -> 644)
+ ### This is needed for updates from ppp-2.4.1-r11 to ppp-2.4.1-r12
+ if [ -e ${ROOT}/etc/modules.d/ppp ] ; then
+ FLAGS="`stat -c %a /etc/modules.d/ppp`"
+ echo ${FLAGS}
+ if [ ${FLAGS} == "755" ] ; then
+ chmod 644 ${ROOT}/etc/modules.d/ppp
+ fi
+ fi
+}