summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-04-12 07:00:30 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-04-12 07:00:30 +0000
commit2393672c488e4fa21a92b0684c1bfb328c41ff52 (patch)
treefa62c5b893754fa64f4bd4319ced91885bc6e722 /net-firewall/ipsec-tools
parentclean older ebuilds (diff)
downloadhistorical-2393672c488e4fa21a92b0684c1bfb328c41ff52.tar.gz
historical-2393672c488e4fa21a92b0684c1bfb328c41ff52.tar.bz2
historical-2393672c488e4fa21a92b0684c1bfb328c41ff52.zip
Changed the initialization scripts to flush the tables when racoon is stopped; closes bug #47089.
Diffstat (limited to 'net-firewall/ipsec-tools')
-rw-r--r--net-firewall/ipsec-tools/ChangeLog7
-rw-r--r--net-firewall/ipsec-tools/Manifest8
-rw-r--r--net-firewall/ipsec-tools/files/racoon.conf.d12
-rw-r--r--net-firewall/ipsec-tools/files/racoon.init.d6
4 files changed, 25 insertions, 8 deletions
diff --git a/net-firewall/ipsec-tools/ChangeLog b/net-firewall/ipsec-tools/ChangeLog
index e2aa5562fc86..c81a55341119 100644
--- a/net-firewall/ipsec-tools/ChangeLog
+++ b/net-firewall/ipsec-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipsec-tools
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.5 2004/04/10 03:56:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/ChangeLog,v 1.6 2004/04/12 07:00:30 plasmaroo Exp $
+
+ 12 Apr 2004; <plasmaroo@gentoo.org> files/racoon.conf.d,
+ files/racoon.init.d:
+ Changed the initialization scripts to flush the tables when racoon is
+ stopped - closes bug #47089.
09 Apr 2004; Jason Wever <weeve@gentoo.org> ipsec-tools-0.2.5.ebuild:
It only takes a ~sparc, to get an ipsec tunnel going...
diff --git a/net-firewall/ipsec-tools/Manifest b/net-firewall/ipsec-tools/Manifest
index edae2b2e3e2d..7879ff1b21ba 100644
--- a/net-firewall/ipsec-tools/Manifest
+++ b/net-firewall/ipsec-tools/Manifest
@@ -1,7 +1,7 @@
-MD5 fa92bee1e892f57a279e95c6baf4d703 ChangeLog 1437
-MD5 da8064030afba404a8c539b2d1e5575f ipsec-tools-0.2.5.ebuild 1485
+MD5 e3a81571ebc92dedf569599f6f5e273a ChangeLog 1628
MD5 8b0f876da8fa70f6ebcbaf281e5720d6 metadata.xml 224
+MD5 da8064030afba404a8c539b2d1e5575f ipsec-tools-0.2.5.ebuild 1485
+MD5 c54a3db5957ba34202bb14f9c29ed0d6 files/racoon.conf.d 631
MD5 6ed9fbfd1bce8915be1e87a159802c46 files/digest-ipsec-tools-0.2.5 69
MD5 84cffb83a2579976f872a29d42767714 files/ipsec.conf.sample 260
-MD5 880e14fe000918f6a94070c38a33d6fe files/racoon.conf.d 479
-MD5 9e8ef9cfd93b58e9eb6a634bde681601 files/racoon.init.d 1146
+MD5 793f3285a75dcef3570a53c5e35cacd4 files/racoon.init.d 1282
diff --git a/net-firewall/ipsec-tools/files/racoon.conf.d b/net-firewall/ipsec-tools/files/racoon.conf.d
index 8d2f2c3483b1..9ab7b085d60a 100644
--- a/net-firewall/ipsec-tools/files/racoon.conf.d
+++ b/net-firewall/ipsec-tools/files/racoon.conf.d
@@ -1,13 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/files/racoon.conf.d,v 1.1 2003/12/16 18:04:33 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipsec-tools/files/racoon.conf.d,v 1.2 2004/04/12 07:00:30 plasmaroo Exp $
# Config file for /etc/init.d/racoon
-# see man pages for racoon or run `racoon --help`
-# for valid cmdline options
+# See the manual pages for racoon or run `racoon --help`
+# for valid command-line options
+
RACOON_OPTS="-4"
RACOON_CONF="/etc/racoon/racoon.conf"
RACOON_PSK_FILE="/etc/racoon/psk.txt"
SETKEY_CONF="/etc/ipsec.conf"
+
+# Comment or remove the following if you don't want the policy tables
+# to be flushed when racoon is stopped.
+
+RACOON_RESET_TABLES="true"
diff --git a/net-firewall/ipsec-tools/files/racoon.init.d b/net-firewall/ipsec-tools/files/racoon.init.d
index 53ee6d00cbaf..ea0a05eb3320 100644
--- a/net-firewall/ipsec-tools/files/racoon.init.d
+++ b/net-firewall/ipsec-tools/files/racoon.init.d
@@ -49,4 +49,10 @@ stop() {
ebegin "Stopping racoon"
kill `cat /var/run/racoon.pid`
eend $?
+ if [ -n "${RACOON_RESET_TABLES}" ]; then
+ ebegin "Flushing policy entries"
+ /usr/sbin/setkey -F
+ /usr/sbin/setkey -FP
+ eend $?
+ fi
}