summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-07-09 15:54:35 +0000
committerPeter Volkov <pva@gentoo.org>2009-07-09 15:54:35 +0000
commit7398e249e9bf1dbaf2e31745fd9915e5318edd4e (patch)
treed8dff3546d53a98541cb5b8830f4602f94af95e1 /net-firewall/itval/itval-1.1.ebuild
parent--disable-chroot is now --without-chroot, bug #277001 thank Conrad Kostecki f... (diff)
downloadhistorical-7398e249e9bf1dbaf2e31745fd9915e5318edd4e.tar.gz
historical-7398e249e9bf1dbaf2e31745fd9915e5318edd4e.tar.bz2
historical-7398e249e9bf1dbaf2e31745fd9915e5318edd4e.zip
Fixed suspect flex/bison dependencies, bug #221337 and #221603 thank Diego E. 'Flameeyes' Pettenò for report. Fix build with gcc-4.4, bug #273900 thank Victor Ostorga for the patch.
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'net-firewall/itval/itval-1.1.ebuild')
-rw-r--r--net-firewall/itval/itval-1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-firewall/itval/itval-1.1.ebuild b/net-firewall/itval/itval-1.1.ebuild
new file mode 100644
index 000000000000..8c9ebfa45b25
--- /dev/null
+++ b/net-firewall/itval/itval-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/itval/itval-1.1.ebuild,v 1.1 2009/07/09 15:54:35 pva Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Iptables policy testing and validation tool"
+HOMEPAGE="http://itval.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/ITVal-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+S=${WORKDIR}/ITVal-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}/itval-1.1-gcc44.patch"
+}
+
+src_install(){
+ make DESTDIR="${D}" install || die "make install failed"
+ doman man/ITVal.n || die
+ dodoc README ChangeLog RELEASE AUTHORS
+}