summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-30 19:56:46 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-30 19:56:46 +0000
commitccaca3a15e22f753e6394e5e70812cabfeb4078f (patch)
treec8b2dc4457cdfbe267008d9f9902c858338be6b6 /net-firewall/shorewall-shell
parentSparc stable, Bug #244956. (diff)
downloadhistorical-ccaca3a15e22f753e6394e5e70812cabfeb4078f.tar.gz
historical-ccaca3a15e22f753e6394e5e70812cabfeb4078f.tar.bz2
historical-ccaca3a15e22f753e6394e5e70812cabfeb4078f.zip
Version bump, bug #240596, thank Vieri for all the work.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-openvz.git-35f41f1 i686
Diffstat (limited to 'net-firewall/shorewall-shell')
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.2.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 51710a679be4..01200d910874 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.18 2008/10/05 11:02:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.19 2008/10/30 19:48:14 pva Exp $
+
+*shorewall-shell-4.2.0 (30 Oct 2008)
+
+ 30 Oct 2008; Peter Volkov <pva@gentoo.org> +shorewall-shell-4.2.0.ebuild:
+ Version bump, bug #240596, thank Vieri for all the work.
05 Oct 2008; Peter Volkov <pva@gentoo.org> -shorewall-shell-4.0.3.ebuild,
-shorewall-shell-4.0.8.ebuild, -shorewall-shell-4.0.9.ebuild,
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.2.0.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.2.0.ebuild
new file mode 100644
index 000000000000..c77c4234e396
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.2.0.ebuild,v 1.1 2008/10/30 19:48:14 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_PN="${PN/-shell/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}