summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2013-05-20 09:06:02 +0000
committerFabio Erculiani <lxnay@gentoo.org>2013-05-20 09:06:02 +0000
commita1ad2b53315e363ecdb3ef2648e05532c16ecfb7 (patch)
tree2c3e28e3c0ee346caf0a5f8a2973c77bfd1d6943 /net-firewall/ufw/ufw-0.33-r2.ebuild
parentadd systemd support to both 2.2 and 2.4 branches on behalf of the systemd tea... (diff)
downloadhistorical-a1ad2b53315e363ecdb3ef2648e05532c16ecfb7.tar.gz
historical-a1ad2b53315e363ecdb3ef2648e05532c16ecfb7.tar.bz2
historical-a1ad2b53315e363ecdb3ef2648e05532c16ecfb7.zip
add systemd unit on behalf of the systemd team, fix bug #466562
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 Manifest-Sign-Key: 0xADC916E5
Diffstat (limited to 'net-firewall/ufw/ufw-0.33-r2.ebuild')
-rw-r--r--net-firewall/ufw/ufw-0.33-r2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-firewall/ufw/ufw-0.33-r2.ebuild b/net-firewall/ufw/ufw-0.33-r2.ebuild
index 74b187cf3f56..6a768533ce0e 100644
--- a/net-firewall/ufw/ufw-0.33-r2.ebuild
+++ b/net-firewall/ufw/ufw-0.33-r2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.33-r2.ebuild,v 1.1 2012/12/06 09:00:53 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ufw/ufw-0.33-r2.ebuild,v 1.2 2013/05/20 09:05:50 lxnay Exp $
EAPI=4
PYTHON_DEPEND="2:2.6 3:3.1"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="2.5 *-jython"
-inherit versionator bash-completion-r1 eutils linux-info distutils
+inherit versionator bash-completion-r1 eutils linux-info distutils systemd
MY_PV_12=$(get_version_component_range 1-2)
DESCRIPTION="A program used to manage a netfilter firewall"
@@ -133,6 +133,7 @@ src_prepare() {
src_install() {
newconfd "${FILESDIR}"/ufw.confd ufw
newinitd "${FILESDIR}"/ufw-2.initd ufw
+ systemd_dounit "${FILESDIR}/ufw.service"
exeinto /usr/share/${PN}
doexe tests/check-requirements