summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-10-16 15:54:19 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-10-16 15:54:19 +0000
commit37129f88d1a7bd70478e009aabc92731670d88e7 (patch)
tree9ab4c194c924e568b95cdc193ff6c86adf0adf48 /net-fs/am-utils
parentnew version that compiles on amd64 (gdbm compile fix patch) (diff)
downloadhistorical-37129f88d1a7bd70478e009aabc92731670d88e7.tar.gz
historical-37129f88d1a7bd70478e009aabc92731670d88e7.tar.bz2
historical-37129f88d1a7bd70478e009aabc92731670d88e7.zip
new version that compiles on amd64 (gdbm compile fix patch)
Diffstat (limited to 'net-fs/am-utils')
-rw-r--r--net-fs/am-utils/Manifest6
-rw-r--r--net-fs/am-utils/am-utils-6.0.9-r1.ebuild46
-rw-r--r--net-fs/am-utils/am-utils-6.0.9.ebuild10
-rw-r--r--net-fs/am-utils/files/am-utils-gdbm.patch48
-rw-r--r--net-fs/am-utils/files/digest-am-utils-6.0.9-r11
5 files changed, 106 insertions, 5 deletions
diff --git a/net-fs/am-utils/Manifest b/net-fs/am-utils/Manifest
index 076c2ad2ced1..7040fdcfc06f 100644
--- a/net-fs/am-utils/Manifest
+++ b/net-fs/am-utils/Manifest
@@ -1,6 +1,6 @@
-MD5 a1ac16d77bc9b4a901153580ce6bf9a5 am-utils-6.0.9-r1.ebuild 1029
-MD5 71c9bf51cbf9e095df50f1c4e5dfcaa7 am-utils-6.0.9.ebuild 1028
-MD5 5d8f0a1d15d863c7e3070e6f0147ba30 ChangeLog 755
+MD5 1eb81954d1b16061bcc250817f3354a7 am-utils-6.0.9-r1.ebuild 1032
+MD5 bc3da0d4cdea023c22923616ab0d6c53 am-utils-6.0.9.ebuild 1028
+MD5 744d07f47a44d0e030b466a7fe9a8427 ChangeLog 755
MD5 711232de603b2f30af85608b0ba43ca7 files/am-utils-gdbm.patch 1578
MD5 a1fdc04f98d4c0a4970581af4144926f files/amd.rc 552
MD5 f08163d2626b71a6c983fc1d0b9383ab files/amd.net 160
diff --git a/net-fs/am-utils/am-utils-6.0.9-r1.ebuild b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
new file mode 100644
index 000000000000..24110ea712d0
--- /dev/null
+++ b/net-fs/am-utils/am-utils-6.0.9-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9-r1.ebuild,v 1.1 2003/10/16 15:54:15 drobbins Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="amd automounter and utilities"
+HOMEPAGE="http://www.am-utils.org"
+SRC_URI="ftp://ftp.am-utils.org/pub/am-utils/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat ${FILESDIR}/am-utils-gdbm.patch | patch -p1 || die
+}
+
+src_compile() {
+ local myconf
+
+ use ldap \
+ && myconf="${myconf} --without-ldap" \
+ || myconf="${myconf} --with-ldap"
+
+ myconf="${myconf} --sysconfdir=/etc/amd"
+
+ cd ${S}
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ cp ${FILESDIR}/amd.conf ${D}/etc/amd
+ cp ${FILESDIR}/amd.net ${D}/etc/amd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/amd.rc amd
+}
diff --git a/net-fs/am-utils/am-utils-6.0.9.ebuild b/net-fs/am-utils/am-utils-6.0.9.ebuild
index ae17f0cc8b61..fc0d35030dc4 100644
--- a/net-fs/am-utils/am-utils-6.0.9.ebuild
+++ b/net-fs/am-utils/am-utils-6.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9.ebuild,v 1.5 2003/09/08 07:59:55 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/am-utils/am-utils-6.0.9.ebuild,v 1.6 2003/10/16 15:54:15 drobbins Exp $
IUSE="ldap"
@@ -14,7 +14,13 @@ DEPEND="virtual/glibc
SLOT="0"
LICENSE="BSD"
-KEYWORDS="x86"
+KEYWORDS="x86 amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cat ${FILESDIR}/am-utils-gdbm.patch | patch -p1 || die
+}
src_compile() {
local myconf
diff --git a/net-fs/am-utils/files/am-utils-gdbm.patch b/net-fs/am-utils/files/am-utils-gdbm.patch
new file mode 100644
index 000000000000..e3f9f2431ad8
--- /dev/null
+++ b/net-fs/am-utils/files/am-utils-gdbm.patch
@@ -0,0 +1,48 @@
+--- am-utils-6.0.8/include/am_defs.h.sopwith 2002-12-11 16:18:36.000000000 -0500
++++ am-utils-6.0.8/include/am_defs.h 2002-12-11 16:20:14.000000000 -0500
+@@ -327,19 +327,20 @@
+ */
+ #ifdef HAVE_NDBM_H
+ # include <ndbm.h>
+-# ifndef DATUM
++# define HAVE_NDBM
++#elif defined(HAVE_GDBM_NDBM_H)
++# include <gdbm/ndbm.h>
++# define HAVE_NDBM
++#elif defined(HAVE_DB1_NDBM_H)
++# include <db1/ndbm.h>
++# define HAVE_NDBM
++
++#endif
++
++#if !defined(DATUM) && defined(HAVE_NDBM)
+ /* ensure that struct datum is not included again from <rpcsvc/yp_prot.h> */
+ # define DATUM
+ # endif /* not DATUM */
+-#else /* not HAVE_NDBM_H */
+-# ifdef HAVE_DB1_NDBM_H
+-# include <db1/ndbm.h>
+-# ifndef DATUM
+-/* ensure that struct datum is not included again from <rpcsvc/yp_prot.h> */
+-# define DATUM
+-# endif /* not DATUM */
+-# endif /* HAVE_DB1_NDBM_H */
+-#endif /* HAVE_NDBM_H */
+
+ /*
+ * Actions to take if <net/errno.h> exists.
+--- am-utils-6.0.8/configure.in.sopwith 2002-12-11 16:15:35.000000000 -0500
++++ am-utils-6.0.8/configure.in 2002-12-11 16:18:09.000000000 -0500
+@@ -231,10 +231,8 @@
+ dnl some systems replaced old ndbm.h include with GNU ndbm.h, which requires
+ dnl libgdbm for dbm_pagfno, so check for this.
+ AC_MSG_CHECKING(for GNU ndbm.h)
+-AC_TRY_LINK([#include <ndbm.h>], [
+-DBM *db;
+-dbm_pagfno(db);
+-], AC_MSG_RESULT(no), AC_CHECK_LIB(gdbm, dbm_pagfno))
++AC_CHECK_HEADERS(ndbm.h gdbm/ndbm.h)
++AC_CHECK_LIB(gdbm, dbm_pagfno)
+ dnl ======================================================================
+
+ dnl ######################################################################
diff --git a/net-fs/am-utils/files/digest-am-utils-6.0.9-r1 b/net-fs/am-utils/files/digest-am-utils-6.0.9-r1
new file mode 100644
index 000000000000..1c7c1b77e2ce
--- /dev/null
+++ b/net-fs/am-utils/files/digest-am-utils-6.0.9-r1
@@ -0,0 +1 @@
+MD5 1e288b8485c09a126e2bea4029602265 am-utils-6.0.9.tar.gz 1471542