summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-07-16 23:22:03 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-07-16 23:22:03 +0000
commit2bb64ed2d36bab52edc1b25660eaf299a7ca59f2 (patch)
tree2cedf1a8cd458eab7f6fd1f144dba6f4aa6d16e1 /net-fs
parentbump x11-plugins/wmbattery revision for versions 1.2.1 and 2.19, fixing its p... (diff)
downloadhistorical-2bb64ed2d36bab52edc1b25660eaf299a7ca59f2.tar.gz
historical-2bb64ed2d36bab52edc1b25660eaf299a7ca59f2.tar.bz2
historical-2bb64ed2d36bab52edc1b25660eaf299a7ca59f2.zip
Scripts enhanced thanks to Maurice van der Pot <griffon26@kfk4ever.com>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/coda/ChangeLog7
-rw-r--r--net-fs/coda/Manifest14
-rw-r--r--net-fs/coda/files/auth213
-rw-r--r--net-fs/coda/files/coda-update18
-rw-r--r--net-fs/coda/files/codasrv17
-rw-r--r--net-fs/coda/files/venus13
6 files changed, 48 insertions, 34 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
index 7f35a96653cf..89c35b107910 100644
--- a/net-fs/coda/ChangeLog
+++ b/net-fs/coda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/coda
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.6 2004/06/24 22:42:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.7 2004/07/16 23:22:03 dragonheart Exp $
+
+ 17 Jul 2004; Daniel Black <dragonheart@gentoo.org> files/auth2,
+ files/coda-update, files/codasrv, files/venus:
+ Scripts enhanced thanks to Maurice van der Pot <griffon26@kfk4ever.com> in bug
+ #26132
12 May 2004; David Holm <dholm@gentoo.org> coda-6.0.6.ebuild:
Added to ~ppc.
diff --git a/net-fs/coda/Manifest b/net-fs/coda/Manifest
index 8267d563a0e1..7b49e52c54e2 100644
--- a/net-fs/coda/Manifest
+++ b/net-fs/coda/Manifest
@@ -1,12 +1,12 @@
MD5 5bbb57c76f0cf851a9c3a1b9d955493d coda-6.0.3.ebuild 2969
-MD5 1c6dd8cd026083d4d4c5a42c39d6bcf6 ChangeLog 1223
MD5 1b45d9e2da0f37197bb054ea7da892ce metadata.xml 360
+MD5 51e995132a9e8a39df66eaa9a7e606e0 ChangeLog 1432
MD5 a069d20d74c89546ecd73c7a00f14c8f coda-6.0.6.ebuild 2991
-MD5 ff0041a17fcc173f319e56d0645bd739 files/codasrv 806
-MD5 c574f7f2e3d8d7fbeff65c5a0707764f files/auth2 960
-MD5 6376d6d4e43074de8c5a7447ddd08475 files/venus 675
-MD5 f17ca8660b5ee127de9d36a910fbd537 files/coda-update 1137
-MD5 464a8cd91e3af12266c0570034388221 files/coda-6.0.6-gcc3.4.patch 1984
-MD5 d21e4e5142a0266459b5ad8b39e3e707 files/coda-6.0.3-iowr.patch 607
+MD5 3b744271da3f14625cb9b0f141f58f65 files/venus 527
+MD5 3ab8a053dd466061c7d2a41de76eda6f files/codasrv 1086
+MD5 63676a42a490eb9d6283db5dd4f94ac8 files/coda-update 1418
+MD5 fae8350994155eb6bf9f22be8162ecdb files/auth2 1149
MD5 d08316a08429d573d30dbc9924707206 files/digest-coda-6.0.3 63
+MD5 d21e4e5142a0266459b5ad8b39e3e707 files/coda-6.0.3-iowr.patch 607
MD5 eb72604e9995f1f6c1fbcb84edfee3fb files/digest-coda-6.0.6 63
+MD5 464a8cd91e3af12266c0570034388221 files/coda-6.0.6-gcc3.4.patch 1984
diff --git a/net-fs/coda/files/auth2 b/net-fs/coda/files/auth2
index f7654074e82f..4c9f800835da 100644
--- a/net-fs/coda/files/auth2
+++ b/net-fs/coda/files/auth2
@@ -1,21 +1,26 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/auth2,v 1.2 2004/07/14 23:33:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/auth2,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
depend() {
need net
}
checkconfig() {
- if [ ! -e /var/lib/vice/hostname ] ; then
- eerror "Please set up vice before starting the service..."
+ if [ ! -e /etc/coda/server.conf ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
+ eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
+ if [ ! -e $vicedir/hostname ] ; then
+ eerror "Please run vice-setup before starting the service..."
return 1
fi
}
we_are_scm() {
- if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
return 0
else
return 1
diff --git a/net-fs/coda/files/coda-update b/net-fs/coda/files/coda-update
index fec27837f616..c059f96a26cb 100644
--- a/net-fs/coda/files/coda-update
+++ b/net-fs/coda/files/coda-update
@@ -1,14 +1,14 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/coda-update,v 1.2 2004/07/14 23:33:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/coda-update,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
depend() {
need net auth2
}
we_are_scm() {
- if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
return 0
else
return 1
@@ -16,10 +16,16 @@ we_are_scm() {
}
checkconfig() {
- if [ ! -e /var/lib/vice/hostname ] ; then
- eerror "Please set up coda before starting the service..."
- return 1
- fi
+
+ if [ ! -e /etc/coda/server.conf ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
+ eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
+ if [ ! -e $vicedir/hostname ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
}
start() {
diff --git a/net-fs/coda/files/codasrv b/net-fs/coda/files/codasrv
index e74826b21358..1fcc3bcae791 100644
--- a/net-fs/coda/files/codasrv
+++ b/net-fs/coda/files/codasrv
@@ -1,21 +1,26 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/codasrv,v 1.2 2004/07/14 23:33:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/codasrv,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
depend() {
need net coda-update auth2
}
checkconfig() {
- if [ ! -e /var/lib/vice/hostname ] ; then
- eerror "Please set up vice before starting the service..."
- return 1
- fi
+ if [ ! -e /etc/coda/server.conf ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
+ eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
+ if [ ! -e $vicedir/hostname ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
}
we_are_scm() {
- if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
return 0
else
return 1
diff --git a/net-fs/coda/files/venus b/net-fs/coda/files/venus
index 021cbfe4b034..0a6dbf05ee02 100644
--- a/net-fs/coda/files/venus
+++ b/net-fs/coda/files/venus
@@ -1,17 +1,10 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/venus,v 1.2 2004/07/14 23:33:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/venus,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
depend() {
- need net codasrv
-}
-
-checkconfig() {
- if [ ! -e /var/lib/vice/hostname ] ; then
- eerror "Please set up vice before starting the service..."
- return 1
- fi
+ need net
}
start() {
@@ -25,6 +18,6 @@ start() {
stop() {
ebegin "Stopping venus"
start-stop-daemon --stop --quiet --exec /usr/sbin/venus
- umount -l /mnt/coda &>/dev/null
+ umount -l coda &>/dev/null
eend $?
}