summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-08-17 17:35:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-08-17 17:35:05 +0000
commit59725f5cad4ae38edab514c403239871032da14f (patch)
tree5948a3017e5ed96d8e22f7ac50e26c6b10df2c52 /net-fs
parentVersion bump (diff)
downloadhistorical-59725f5cad4ae38edab514c403239871032da14f.tar.gz
historical-59725f5cad4ae38edab514c403239871032da14f.tar.bz2
historical-59725f5cad4ae38edab514c403239871032da14f.zip
Bump to 3.3.7
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba-client/ChangeLog8
-rw-r--r--net-fs/samba-client/samba-client-3.3.7.ebuild196
-rw-r--r--net-fs/samba-libs/ChangeLog7
-rw-r--r--net-fs/samba-libs/samba-libs-3.3.7.ebuild174
-rw-r--r--net-fs/samba-server/ChangeLog8
-rw-r--r--net-fs/samba-server/samba-server-3.3.7.ebuild215
-rw-r--r--net-fs/samba/ChangeLog7
-rw-r--r--net-fs/samba/samba-3.3.7.ebuild17
8 files changed, 628 insertions, 4 deletions
diff --git a/net-fs/samba-client/ChangeLog b/net-fs/samba-client/ChangeLog
index 2416dc93200c..59eae9edfe25 100644
--- a/net-fs/samba-client/ChangeLog
+++ b/net-fs/samba-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/samba-client
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-client/ChangeLog,v 1.1 2009/06/26 20:22:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-client/ChangeLog,v 1.2 2009/08/17 17:34:23 patrick Exp $
+
+*samba-client-3.3.7 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org>
+ +samba-client-3.3.7.ebuild:
+ Bump to 3.3.7
*samba-client-3.3.6 (26 Jun 2009)
diff --git a/net-fs/samba-client/samba-client-3.3.7.ebuild b/net-fs/samba-client/samba-client-3.3.7.ebuild
new file mode 100644
index 000000000000..8c277dd187cb
--- /dev/null
+++ b/net-fs/samba-client/samba-client-3.3.7.ebuild
@@ -0,0 +1,196 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-client/samba-client-3.3.7.ebuild,v 1.1 2009/08/17 17:34:23 patrick Exp $
+
+EAPI="2"
+
+inherit pam confutils versionator multilib eutils toolchain-funcs
+
+MY_P="samba-${PV}"
+
+DESCRIPTION="Libraries from Samba"
+HOMEPAGE="http://www.samba.org/"
+SRC_URI="mirror://samba/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ads aio avahi caps cluster cups debug ldap minimal syslog winbind zeroconf"
+
+DEPEND="!<net-fs/samba-3.3
+ !net-fs/mount-cifs
+ ads? ( virtual/krb5 sys-fs/e2fsprogs
+ net-fs/samba-libs[ads] sys-apps/keyutils )
+ !minimal? (
+ dev-libs/popt
+ dev-libs/iniparser
+ virtual/libiconv
+ zeroconf? ( || ( net-dns/avahi[mdnsresponder-compat] net-misc/mDNSResponder ) )
+ caps? ( sys-libs/libcap )
+ cups? ( net-print/cups )
+ ldap? ( net-nds/openldap )
+ syslog? ( virtual/logger )
+ net-fs/samba-libs[caps?,cups?,ldap?,syslog?,winbind?]
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/source"
+
+# TODO:
+# - enable iPrint on Prefix/OSX and Darwin?
+# - selftest-prefix? selftest?
+
+RESTRICT="test"
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+BINPROGS="bin/smbclient bin/net bin/smbget bin/smbtree bin/nmblookup bin/smbpasswd bin/rpcclient bin/smbcacls bin/smbcquotas bin/ntlm_auth"
+
+pkg_setup() {
+ confutils_use_depend_all ads ldap
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/3.3.4-missing_includes.patch" \
+ "${FILESDIR}/3.3.3-fix-as-needed.patch"
+
+ sed -i \
+ -e 's|"lib32" ||' \
+ -e 's|if test -d "$i/$l" ;|if test -d "$i/$l" -o -L "$i/$l";|' \
+ configure || die "sed failed"
+
+ sed -i \
+ -e 's|@LIBTALLOC_SHARED@||g' \
+ -e 's|@LIBTDB_SHARED@||g' \
+ -e 's|@LIBWBCLIENT_SHARED@||g' \
+ -e 's|@LIBNETAPI_SHARED@||g' \
+ -e 's|$(REG_SMBCONF_OBJ) @LIBNETAPI_STATIC@ $(LIBNET_OBJ)|$(REG_SMBCONF_OBJ) @LIBNETAPI_LIBS@ $(LIBNET_OBJ)|' \
+ Makefile.in || die "sed failed"
+
+ # Upstream doesn't want us to link certain things dynamically, but those binaries here seem to work
+ sed -i \
+ -e '/^LINK_LIBNETAPI/d' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ local myconf
+
+ # Filter out -fPIE
+ [[ ${CHOST} == *-*bsd* ]] && myconf="${myconf} --disable-pie"
+ use hppa && myconf="${myconf} --disable-pie"
+
+ # Upstream refuses to make this configurable
+ export ac_cv_header_sys_capability_h=no
+ if ! use minimal ; then
+ use caps && export ac_cv_header_sys_capability_h=yes
+ fi
+
+ if ! use minimal || use ads; then
+ # Notes:
+ # - FAM is a plugin for the server
+ # - DNS-SD is only used in client/server code
+ # - AFS is a pw-auth-method and only used in client/server code
+ # - AFSACL is a server module
+ # - automount is only needed in conjunction with NIS and we don't have that
+ # anymore
+ # - quota-support is only needed in server-code
+ # - acl-support is only used in server-code
+ # - --without-dce-dfs and --without-nisplus-home can't be passed to configure but are disabled by default
+ # - current DNS/SD support in the client is via the mdnsresponder-compat api in avahi
+ econf ${myconf} \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable debug developer) \
+ --enable-largefile \
+ --enable-socket-wrapper \
+ --enable-nss-wrapper \
+ --disable-swat \
+ $(use_enable debug dmalloc) \
+ $(use minimal && echo "--disable-cups" || echo "$(use_enable cups)") \
+ --disable-iprint \
+ --disable-fam \
+ --enable-shared-libs \
+ $(use minimal && echo "--disable-dnssd" || echo "$(use_enable avahi dnssd)") \
+ --disable-avahi \
+ --with-fhs \
+ --with-privatedir=/var/lib/samba/private \
+ --with-rootsbindir=/var/cache/samba \
+ --with-lockdir=/var/cache/samba \
+ --with-swatdir=/usr/share/doc/${PF}/swat \
+ --with-configdir=/etc/samba \
+ --with-logfilebase=/var/log/samba \
+ --with-pammodulesdir=$(getpam_mod_dir) \
+ --without-afs \
+ --without-fake-kaserver \
+ --without-vfs-afsacl \
+ $(use minimal && echo "--without-ldap" || echo "$(use_with ldap)") \
+ $(use minimal && echo "--without-ads" || echo "$(use_with ads)") \
+ $(use minimal && echo "--without-krb5" || echo "$(use_with ads krb5 /usr)") \
+ $(use minimal && echo "--without-dnsupdate" || echo "$(use_with ads dnsupdate)") \
+ --without-automount \
+ --without-cifsmount \
+ --without-cifsupcall \
+ --without-pam \
+ --without-pam_smbpass \
+ $(use minimal && echo "--without-syslog" || echo "$(use_with syslog)") \
+ --without-quotas \
+ --without-sys-quotas \
+ --without-utmp \
+ --with-lib{talloc,tdb,netapi,smbclient,smbsharemodes} \
+ --without-libaddns \
+ $(use minimal && echo "--without-ctdb" || echo "$(use_with cluster ctdb /usr)") \
+ $(use minimal && echo "--without-cluster" || echo "$(use_with cluster cluster-support)") \
+ --without-acl-support \
+ $(use minimal && echo "--without-aio-support" || echo "$(use_with aio aio-support)") \
+ --with-sendfile-support \
+ $(use minimal && echo "--without-winbind" || echo "$(use_with winbind)") \
+ --without-included-popt \
+ --without-included-iniparser
+ fi
+}
+
+src_compile() {
+ mkdir bin
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o bin/mount.cifs client/{mount.cifs,mtab}.c || die "building mount.cifs failed"
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o bin/umount.cifs client/{umount.cifs,mtab}.c || die "building umount.cifs failed"
+
+ if use ads ; then
+ emake bin/cifs.upcall || die "emake cifs.upcall failed"
+ fi
+
+ if ! use minimal ; then
+ emake ${BINPROGS} || die "emake binprogs failed"
+ if use cups ; then
+ emake bin/smbspool || die "emake smbspool failed"
+ fi
+ fi
+}
+
+src_install() {
+ into /
+ dosbin bin/mount.cifs bin/umount.cifs || die "u/mount.cifs not around"
+ doman ../docs/manpages/{u,}mount.cifs.8
+ dohtml ../docs/htmldocs/manpages/{u,}mount.cifs.8.html
+
+ into /usr
+ if use ads ; then
+ dosbin bin/cifs.upcall || die "cifs.upcall not around"
+ doman ../docs/manpages/cifs.upcall.8
+ doman ../docs/htmldocs/cifs.upcall.8.html
+ fi
+
+ if ! use minimal ; then
+ dobin ${BINPROGS} || die "not all bins around"
+ for prog in ${BINPROGS} ; do
+ doman ../docs/manpages/${prog/bin\/}*
+ dohtml ../docs/htmldocs/${prog/bin\/}*.html
+ done
+
+ if use cups ; then
+ dobin bin/smbspool || die "smbspool not around"
+ doman ../docs/manpages/smbspool.8
+ dohtml ../docs/htmldocs/smbspool.8.html
+ dosym /usr/bin/smbspool $(cups-config --serverbin)/backend/smb
+ fi
+ fi
+}
diff --git a/net-fs/samba-libs/ChangeLog b/net-fs/samba-libs/ChangeLog
index 5e442ebb7c6c..a8dfae684249 100644
--- a/net-fs/samba-libs/ChangeLog
+++ b/net-fs/samba-libs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba-libs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-libs/ChangeLog,v 1.1 2009/06/26 20:19:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-libs/ChangeLog,v 1.2 2009/08/17 17:34:43 patrick Exp $
+
+*samba-libs-3.3.7 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org> +samba-libs-3.3.7.ebuild:
+ Bump to 3.3.7
*samba-libs-3.3.6 (26 Jun 2009)
diff --git a/net-fs/samba-libs/samba-libs-3.3.7.ebuild b/net-fs/samba-libs/samba-libs-3.3.7.ebuild
new file mode 100644
index 000000000000..2c5407d30dcc
--- /dev/null
+++ b/net-fs/samba-libs/samba-libs-3.3.7.ebuild
@@ -0,0 +1,174 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-libs/samba-libs-3.3.7.ebuild,v 1.1 2009/08/17 17:34:43 patrick Exp $
+
+EAPI="2"
+
+inherit pam confutils versionator multilib
+
+MY_P="samba-${PV}"
+
+DESCRIPTION="Libraries from Samba"
+HOMEPAGE="http://www.samba.org/"
+SRC_URI="mirror://samba/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ads aio caps cluster cups debug examples ldap pam syslog winbind"
+
+DEPEND="dev-libs/popt
+ virtual/libiconv
+ ads? ( virtual/krb5 sys-fs/e2fsprogs )
+ caps? ( sys-libs/libcap )
+ cluster? ( dev-db/ctdb )
+ cups? ( net-print/cups )
+ ldap? ( net-nds/openldap )
+ pam? ( virtual/pam
+ winbind? ( dev-libs/iniparser ) )
+ syslog? ( virtual/logger )
+ !<net-fs/samba-3.3"
+RDEPEND="${DEPEND}"
+
+# Disable tests since we don't want to build that much here
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}/source"
+
+# TODO:
+# - enable iPrint on Prefix/OSX and Darwin?
+# - selftest-prefix? selftest?
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+pkg_setup() {
+ confutils_use_depend_all ads ldap
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|"lib32" ||' \
+ -e 's|if test -d "$i/$l" ;|if test -d "$i/$l" -o -L "$i/$l";|' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ local myconf
+
+ # Filter out -fPIE
+ [[ ${CHOST} == *-*bsd* ]] && myconf="${myconf} --disable-pie"
+ use hppa && myconf="${myconf} --disable-pie"
+
+ # Upstream refuses to make this configurable
+ use caps && export ac_cv_header_sys_capability_h=yes || export ac_cv_header_sys_capability_h=no
+
+ # Notes:
+ # - FAM is a plugin for the server
+ # - DNS-SD is only used in client/server code
+ # - AFS is a pw-auth-method and only used in client/server code
+ # - AFSACL is a server module
+ # - automount is only needed in conjunction with NIS and we don't have that
+ # anymore
+ # - quota-support is only needed in server-code
+ # - acl-support is only used in server-code
+ # - --without-dce-dfs and --without-nisplus-home can't be passed to configure but are disabled by default
+ econf ${myconf} \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable debug developer) \
+ --enable-largefile \
+ --enable-socket-wrapper \
+ --enable-nss-wrapper \
+ --disable-swat \
+ $(use_enable debug dmalloc) \
+ $(use_enable cups) \
+ --disable-iprint \
+ --disable-fam \
+ --enable-shared-libs \
+ --disable-dnssd \
+ --disable-avahi \
+ --with-fhs \
+ --with-privatedir=/var/lib/samba/private \
+ --with-rootsbindir=/var/cache/samba \
+ --with-lockdir=/var/cache/samba \
+ --with-swatdir=/usr/share/doc/${PF}/swat \
+ --with-configdir=/etc/samba \
+ --with-logfilebase=/var/log/samba \
+ --with-pammodulesdir=$(getpam_mod_dir) \
+ --without-afs \
+ --without-fake-kaserver \
+ --without-vfs-afsacl \
+ $(use_with ldap) \
+ $(use_with ads) \
+ $(use_with ads krb5 /usr) \
+ $(use_with ads dnsupdate) \
+ --without-automount \
+ --without-cifsmount \
+ --without-cifsupcall \
+ $(use_with pam) \
+ $(use_with pam pam_smbpass) \
+ $(use_with syslog) \
+ --without-quotas \
+ --without-sys-quotas \
+ --without-utmp \
+ --with-lib{talloc,tdb,netapi,smbclient,smbsharemodes} \
+ --without-libaddns \
+ $(use_with cluster ctdb /usr) \
+ $(use_with cluster cluster-support) \
+ --without-acl-support \
+ $(use_with aio aio-support) \
+ --with-sendfile-support \
+ $(use_with winbind) \
+ --without-included-popt \
+ --without-included-iniparser
+}
+
+src_compile() {
+ emake libs pam_modules nss_modules || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" installlibs || die "emake installlibs failed"
+ if use pam ; then
+ emake DESTDIR="${D}" installpammodules || die "emake installpammodules failed"
+ fi
+
+ # Remove empty installation directories
+ rmdir \
+ "${D}/usr/$(get_libdir)/samba" \
+ "${D}/usr"/{sbin,bin} \
+ "${D}/usr/share"/{man,locale,} \
+ "${D}/var"/{run,lib/samba/private,lib/samba,lib,cache/samba,cache,} \
+ || die "tried to remove non-empty dirs, this seems like a bug in the ebuild"
+
+ # Nsswitch extensions. Make link for wins and winbind resolvers
+ if use winbind ; then
+ dolib.so nsswitch/libnss_wins.so
+ dosym libnss_wins.so /usr/$(get_libdir)/libnss_wins.so.2
+ dolib.so nsswitch/libnss_winbind.so
+ dosym libnss_winbind.so /usr/$(get_libdir)/libnss_winbind.so.2
+ fi
+
+ if use pam ; then
+ if use winbind ; then
+ newpamd "${CONFDIR}/system-auth-winbind.pam" system-auth-winbind
+ doman ../docs/manpages/pam_winbind.7
+ dohtml ../docs/htmldocs/manpages/pam_winbind.7.html
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r ../examples/pam_winbind
+ fi
+ fi
+
+ newpamd "${CONFDIR}/samba.pam" samba
+ dodoc pam_smbpass/README
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r ../examples/libsmbclient
+
+ use winbind && doins -r ../examples/nss
+ fi
+
+}
diff --git a/net-fs/samba-server/ChangeLog b/net-fs/samba-server/ChangeLog
index 777e33fd18f7..33a289d977c4 100644
--- a/net-fs/samba-server/ChangeLog
+++ b/net-fs/samba-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/samba-server
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-server/ChangeLog,v 1.1 2009/06/26 20:23:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-server/ChangeLog,v 1.2 2009/08/17 17:35:05 patrick Exp $
+
+*samba-server-3.3.7 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org>
+ +samba-server-3.3.7.ebuild:
+ Bump to 3.3.7
*samba-server-3.3.6 (26 Jun 2009)
diff --git a/net-fs/samba-server/samba-server-3.3.7.ebuild b/net-fs/samba-server/samba-server-3.3.7.ebuild
new file mode 100644
index 000000000000..d2c392cc3a11
--- /dev/null
+++ b/net-fs/samba-server/samba-server-3.3.7.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-server/samba-server-3.3.7.ebuild,v 1.1 2009/08/17 17:35:05 patrick Exp $
+
+EAPI="2"
+
+inherit pam confutils versionator multilib
+
+MY_P="samba-${PV}"
+
+DESCRIPTION="Libraries from Samba"
+HOMEPAGE="http://www.samba.org/"
+SRC_URI="mirror://samba/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl ads aio avahi caps cluster cups debug doc examples fam ldap quota swat syslog winbind zeroconf"
+
+# currently a bit broken
+RESTRICT="test"
+
+DEPEND="!<net-fs/samba-3.3
+ ads? ( virtual/krb5 sys-fs/e2fsprogs net-fs/samba-libs[ads] )
+ dev-libs/popt
+ virtual/libiconv
+ avahi? ( net-dns/avahi )
+ zeroconf? ( !avahi? ( || ( net-dns/avahi[mdnsresponder-compat] net-misc/mDNSResponder ) ) )
+ caps? ( sys-libs/libcap )
+ cups? ( net-print/cups )
+ ldap? ( net-nds/openldap )
+ syslog? ( virtual/logger )
+ net-fs/samba-libs[caps?,cluster?,cups?,ldap?,syslog?,winbind?]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/source"
+
+# TODO:
+# - enable iPrint on Prefix/OSX and Darwin?
+# - selftest-prefix? selftest?
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+SBINPROGS="bin/smbd bin/nmbd"
+BINPROGS="bin/testparm bin/smbstatus bin/smbcontrol bin/tdbbackup bin/pdbedit
+ bin/tdbdump bin/tdbtool bin/profiles bin/sharesec
+ bin/eventlogadm bin/ldbedit bin/ldbsearch bin/ldbadd bin/ldbdel bin/ldbmodify bin/ldbrename"
+
+pkg_setup() {
+ confutils_use_depend_all ads ldap
+}
+
+src_prepare() {
+ sed -i \
+ -e 's|"lib32" ||' \
+ -e 's|if test -d "$i/$l" ;|if test -d "$i/$l" -o -L "$i/$l";|' \
+ configure || die "sed failed"
+
+ sed -i \
+ -e 's|@LIBTALLOC_SHARED@||g' \
+ -e 's|@LIBTDB_SHARED@||g' \
+ -e 's|@LIBWBCLIENT_SHARED@||g' \
+ -e 's|@LIBNETAPI_SHARED@||g' \
+ -e 's|$(REG_SMBCONF_OBJ) @LIBNETAPI_STATIC@ $(LIBNET_OBJ)|$(REG_SMBCONF_OBJ) @LIBNETAPI_LIBS@ $(LIBNET_OBJ)|' \
+ Makefile.in || die "sed failed"
+
+ # Upstream doesn't want us to link certain things dynamically, but those binaries here seem to work
+ sed -i \
+ -e '/^LINK_LIBNETAPI/d' \
+ configure || die "sed failed"
+}
+
+src_configure() {
+ local myconf
+
+ # Filter out -fPIE
+ [[ ${CHOST} == *-*bsd* ]] && myconf="${myconf} --disable-pie"
+ use hppa && myconf="${myconf} --disable-pie"
+
+ # Upstream refuses to make this configurable
+ export ac_cv_header_sys_capability_h=no
+ use caps && export ac_cv_header_sys_capability_h=yes
+
+ local dnssd="--disable-dnssd"
+ use zeroconf && ! use avahi && dnssd="--enable-dnssd"
+
+ # Notes:
+ # - FAM is a plugin for the server
+ # - DNS-SD is only used in client/server code
+ # - AFS is a pw-auth-method and only used in client/server code
+ # - AFSACL is a server module
+ # - automount is only needed in conjunction with NIS and we don't have that
+ # anymore
+ # - quota-support is only needed in server-code
+ # - acl-support is only used in server-code
+ # - --without-dce-dfs and --without-nisplus-home can't be passed to configure but are disabled by default
+ econf ${myconf} \
+ --with-piddir=/var/run/samba \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable debug developer) \
+ --enable-largefile \
+ --enable-socket-wrapper \
+ --enable-nss-wrapper \
+ $(use_enable swat) \
+ $(use_enable debug dmalloc) \
+ $(use_enable cups) \
+ --disable-iprint \
+ $(use_enable fam) \
+ --enable-shared-libs \
+ ${dnssd} \
+ $(use_enable avahi) \
+ --with-fhs \
+ --with-privatedir=/var/lib/samba/private \
+ --with-rootsbindir=/var/cache/samba \
+ --with-lockdir=/var/cache/samba \
+ --with-swatdir=/usr/share/doc/${PF}/swat \
+ --with-configdir=/etc/samba \
+ --with-logfilebase=/var/log/samba \
+ --with-pammodulesdir=$(getpam_mod_dir) \
+ --without-afs \
+ --without-fake-kaserver \
+ --without-vfs-afsacl \
+ $(use_with ldap) \
+ $(use_with ads) \
+ $(use_with ads krb5 /usr) \
+ $(use_with ads dnsupdate) \
+ --without-automount \
+ --without-cifsmount \
+ --without-cifsupcall \
+ --without-pam \
+ --without-pam_smbpass \
+ $(use_with syslog) \
+ $(use_with quota quotas) \
+ $(use_with quota sys-quotas) \
+ --without-utmp \
+ --with-lib{talloc,tdb,netapi,smbclient,smbsharemodes} \
+ --without-libaddns \
+ $(use_with cluster ctdb /usr) \
+ $(use_with cluster cluster-support) \
+ $(use_with acl acl-support) \
+ $(use_with aio aio-support) \
+ --with-sendfile-support \
+ $(use_with winbind)
+
+ use swat && SBINPROGS="${SBINPROGS} bin/swat"
+ use winbind && SBINPROGS="${SBINPROGS} bin/winbindd"
+ use ads && use winbind && SBIN_PROGS="${SBINPROGS} bin/winbind_krb5_locator"
+
+ use winbind && BINPROGS="${BINPROGS} bin/wbinfo"
+}
+
+src_compile() {
+ emake ${SBINPROGS} || die "building server binaries failed"
+ emake modules || die "building modules failed"
+ emake ${BINPROGS} || die "building binaries failed"
+}
+
+src_install() {
+ dosbin ${SBINPROGS} || die "installing server binaries failed"
+
+ emake DESTDIR="${D}" installmodules || die "installing modules failed"
+
+ dobin ${BINPROGS} || die "installing binaries failed"
+
+ for prog in ${BINPROGS} ${SBINPROGS} ; do
+ doman ../docs/manpages/${prog/bin\/}*
+ done
+
+ doman ../docs/manpages/vfs* ../docs/manpages/samba.7 ../docs/manpages/smb.conf.5
+
+ diropts -m0700
+ keepdir /var/lib/samba/private
+
+ diropts -m1777
+ keepdir /var/spool/samba
+
+ diropts -m0755
+ keepdir /var/{cache,log}/samba
+ keepdir /var/lib/samba/{netlogon,profiles}
+ keepdir /var/lib/samba/printers/{W32X86,WIN40,W32ALPHA,W32MIPS,W32PPC,X64,IA64,COLOR}
+ keepdir /usr/$(get_libdir)/samba/{auth,pdb,rpc,idmap,nss_info,gpext}
+
+ newconfd "${CONFDIR}/samba.confd" samba
+ newinitd "${CONFDIR}/samba.initd" samba
+
+ insinto /etc/samba
+ doins "${CONFDIR}"/{smbusers,lmhosts,smb.conf.default}
+
+ insinto /usr/"$(get_libdir)"/samba
+ doins codepages/{valid.dat,upcase.dat,lowcase.dat}
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins ../examples/LDAP/samba.schema
+ fi
+
+ if use swat ; then
+ insinto /etc/xinetd.d
+ newins "${CONFDIR}/swat.xinetd" swat
+ fi
+
+ dodoc ../MAINTAINERS ../README* ../Roadmap ../WHATSNEW.txt ../docs/THANKS
+
+ if use doc ; then
+ dohtml -r ../docs/htmldocs/*
+ dodoc ../docs/*.pdf
+ fi
+
+ if use examples ; then
+ cd ../examples
+ insinto /usr/share/doc/${PF}/examples
+ doins -r \
+ auth autofs dce-dfs LDAP logon misc pdb perfcounter \
+ printer-accounting printing scripts tridge validchars VFS
+ fi
+}
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index a2bd668d89d1..1426bfa559f1 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.364 2009/08/17 17:08:00 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.365 2009/08/17 17:34:01 patrick Exp $
+
+*samba-3.3.7 (17 Aug 2009)
+
+ 17 Aug 2009; Patrick Lauer <patrick@gentoo.org> +samba-3.3.7.ebuild:
+ Bump to 3.3.7
*samba-3.2.13-r3 (17 Aug 2009)
diff --git a/net-fs/samba/samba-3.3.7.ebuild b/net-fs/samba/samba-3.3.7.ebuild
new file mode 100644
index 000000000000..b6832ac8ae83
--- /dev/null
+++ b/net-fs/samba/samba-3.3.7.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.3.7.ebuild,v 1.1 2009/08/17 17:34:01 patrick Exp $
+
+EAPI="2"
+
+DESCRIPTION="Meta package for samba-{libs,client,server}"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+client +server"
+
+DEPEND=""
+RDEPEND="~net-fs/samba-libs-${PV}
+ client? ( ~net-fs/samba-client-${PV} )
+ server? ( ~net-fs/samba-server-${PV} )"