summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-24 00:04:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-24 00:04:23 +0000
commit6c622ac729a8acedb7770203130483de30e0114e (patch)
tree1c907b3a4861d45dd54b2cd635841766454bfea3 /net-fs
parentdont set EXTRA_EMAKE (diff)
downloadhistorical-6c622ac729a8acedb7770203130483de30e0114e.tar.gz
historical-6c622ac729a8acedb7770203130483de30e0114e.tar.bz2
historical-6c622ac729a8acedb7770203130483de30e0114e.zip
dont set EXTRA_EMAKE
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/sfs/Manifest16
-rw-r--r--net-fs/sfs/sfs-0.7.2.ebuild43
2 files changed, 31 insertions, 28 deletions
diff --git a/net-fs/sfs/Manifest b/net-fs/sfs/Manifest
index 060a1fa9b30d..16dba892d4ba 100644
--- a/net-fs/sfs/Manifest
+++ b/net-fs/sfs/Manifest
@@ -1,7 +1,17 @@
-MD5 cd170696745cf35e5f8eb7e25bddaea9 sfs-0.7.2.ebuild 2240
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 4d2e24b91d4143c0ad5617788baed8c9 ChangeLog 1059
+MD5 4319ad5bff978888b8f1ba646b3500dd sfs-0.7.2.ebuild 1992
MD5 02b6a4f338d3ffcbb4199c06168d4708 metadata.xml 255
+MD5 577ce14c65c9362770201f0539b18419 files/digest-sfs-0.7.2 62
MD5 552da0c94c1441c082125c5dfc99f863 files/sfscd 491
-MD5 d57d6347e4a2c9a143eaa72df2b64d97 files/sfssd 702
MD5 70eec8c63f81fc56660d6d36e61f68bf files/sfsrwsd_config 561
-MD5 577ce14c65c9362770201f0539b18419 files/digest-sfs-0.7.2 62
+MD5 d57d6347e4a2c9a143eaa72df2b64d97 files/sfssd 702
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBU2STHTu7gpaalycRAnfdAJoDLqyZ3qv65CMcpTZDo98a4je5pgCfVLI/
+nbheHkuOHkHeDvXgcKj1VQ4=
+=B7DT
+-----END PGP SIGNATURE-----
diff --git a/net-fs/sfs/sfs-0.7.2.ebuild b/net-fs/sfs/sfs-0.7.2.ebuild
index f9da73c035fc..6f2f79a54d85 100644
--- a/net-fs/sfs/sfs-0.7.2.ebuild
+++ b/net-fs/sfs/sfs-0.7.2.ebuild
@@ -1,25 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/sfs-0.7.2.ebuild,v 1.11 2004/07/14 23:54:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/sfs/sfs-0.7.2.ebuild,v 1.12 2004/09/24 00:04:23 vapier Exp $
inherit eutils
-DESCRIPTION="SFS (Self-certifying File System) client and server daemons"
+DESCRIPTION="Self-certifying File System client and server daemons"
HOMEPAGE="http://www.fs.net/"
SRC_URI="http://www.fs.net/sfs/@new-york.lcs.mit.edu,u83s4uk49nt8rmp4uwmt2exvz6d3cavh/pub/sfswww/dist/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
-IUSE="ssl"
KEYWORDS="x86"
+IUSE="ssl"
DEPEND="virtual/libc
- >=dev-libs/gmp-4.1
- >=net-fs/nfs-utils-0.3.3
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-
-RDEPEND="$DEPEND
- >=net-nds/portmap-5b-r6"
+ >=dev-libs/gmp-4.1
+ >=net-fs/nfs-utils-0.3.3
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+RDEPEND="${DEPEND}
+ >=net-nds/portmap-5b-r6"
pkg_setup() {
# checking for NFS support *seems* like a good idea, but since
@@ -40,26 +39,24 @@ src_unpack() {
}
src_compile() {
- if use ssl; then
- EXTRA_ECONF="${EXTRA_ECONF} --with-openssl=/usr"
- else
- EXTRA_ECONF="${EXTRA_ECONF} --without-openssl"
- fi
- EXTRA_ECONF="${EXTRA_ECONF} --with-gmp=/usr --with-gnuld --prefix=/"
-
- econf || die "econf failed"
+ econf \
+ `use_with ssl openssl /usr` \
+ --with-gmp=/usr \
+ --with-gnuld \
+ --prefix=/ \
+ || die "econf failed"
# won't parallel build w/o baby-sitting
- EXTRA_EMAKE="${EXTRA_EMAKE} -j1" emake || die
+ emake -j1 || die
}
src_install() {
- einstall prefix=${D}/
+ einstall prefix=${D}/ || die
insinto /etc/sfs/
doins ${FILESDIR}/sfsrwsd_config
- dodoc AUTHORS COPYING ChangeLog NEWS \
+ dodoc AUTHORS ChangeLog NEWS \
README README.0.7-upgrade \
STANDARDS TODO
@@ -80,10 +77,6 @@ pkg_postinst() {
einfo "Both the client and server require kernel support"
einfo " for NFS version 3 in order to operate properly."
einfo ""
-
- # Running depscan since we introduced some new init scripts
- /etc/init.d/depscan.sh
- return 0
}
pkg_config() {