summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-01-31 21:54:37 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-01-31 21:54:37 +0000
commit98c1b352e59341f31305cd73d3b01813fe96eb2c (patch)
treea40a8c995d739c9af7cce245a743ff32b70425aa /net-fs
parentChange SRC_URI to use mirror://sourceforge. (diff)
downloadhistorical-98c1b352e59341f31305cd73d3b01813fe96eb2c.tar.gz
historical-98c1b352e59341f31305cd73d3b01813fe96eb2c.tar.bz2
historical-98c1b352e59341f31305cd73d3b01813fe96eb2c.zip
new version. x86 masked
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs/ChangeLog7
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.81
-rw-r--r--net-fs/openafs/openafs-1.2.8.ebuild101
3 files changed, 108 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 2cedb60c47b4..246a3c9c8eeb 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.15 2003/01/03 22:05:40 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.16 2003/01/31 21:54:37 rphillips Exp $
03 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> files/afs.rc.rc6 :
Fix bug #5634.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
+*openafs-1.2.8 (31 Jan 2003)
+
+ 31 Jan 2003; Ryan Phillips <rphillips@gentoo.org> openafs-1.2.8.ebuild :
+ new version
+
*openafs-1.2.6-r1 (1 Oct 2002)
31 Dec 2002; Ryan Phillips <rphillips@gentoo.org> openafs-1.2.6-r1.ebuild :
diff --git a/net-fs/openafs/files/digest-openafs-1.2.8 b/net-fs/openafs/files/digest-openafs-1.2.8
new file mode 100644
index 000000000000..846615006980
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.8
@@ -0,0 +1 @@
+MD5 501b777caba385c0223f21f6cf7f2fa4 openafs-1.2.8-src.tar.gz 12603280
diff --git a/net-fs/openafs/openafs-1.2.8.ebuild b/net-fs/openafs/openafs-1.2.8.ebuild
new file mode 100644
index 000000000000..cab5f8a245f8
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.8.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.1.1.ebuild,v 1.3 2001/08/31 03:23:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://www.openafs.org/dl/openafs/${PV}/openafs-${PV}-src.tar.gz"
+HOMEPAGE="http://www.openafs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="~x86 -ppc -sparc "
+SANDBOX_DISABLED="1"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/config
+ cp Makefile.in Makefile.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.in.old > Makefile.in
+ rm Makefile.in.old
+}
+
+src_compile() {
+ ./configure \
+ --with-afs-sysname=i386_linux24 \
+ --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+
+ dodir /etc/env.d
+ echo 'CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws"' > ${D}/etc/env.d/01${PN}
+ echo 'PATH=/usr/afsws/bin:/etc/afs/afsws' >> ${D}/etc/env.d/01${PN}
+ echo 'ROOTPATH=/usr/afsws/bin:/etc/afs/afsws:/usr/afs/bin' >> ${D}/etc/env.d/01${PN}
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}