summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
committerRoy Marples <uberlord@gentoo.org>2005-10-05 17:27:33 +0000
commit766ad858ad77bb2a51b0dba6c8ae7a41efbb884b (patch)
tree574618772c35895c03e3e4f62e1b6e5960334f7e /net-ftp
parentalpha-sources no longer exist wrt bug #107940 (diff)
downloadhistorical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.tar.gz
historical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.tar.bz2
historical-766ad858ad77bb2a51b0dba6c8ae7a41efbb884b.zip
Use "egethome ftp" instead of greping and cuting /etc/passwd.
This allows us to work on other platforms with a minimum of fuss. Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpbase/ChangeLog6
-rw-r--r--net-ftp/ftpbase/Manifest8
-rw-r--r--net-ftp/ftpbase/ftpbase-0.00.ebuild6
3 files changed, 12 insertions, 8 deletions
diff --git a/net-ftp/ftpbase/ChangeLog b/net-ftp/ftpbase/ChangeLog
index 1e78ed4edcbc..5cc0929bf53f 100644
--- a/net-ftp/ftpbase/ChangeLog
+++ b/net-ftp/ftpbase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-ftp/ftpbase
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.9 2005/10/02 23:01:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ChangeLog,v 1.10 2005/10/05 17:27:33 uberlord Exp $
+
+ 05 Oct 2005; Roy Marples <uberlord@gentoo.org> ftpbase-0.00.ebuild:
+ Use "egethome ftp" instead of greping and cuting /etc/passwd.
+ This allows us to work on other platforms with a minimum of fuss.
02 Oct 2005; MATSUU Takuto <matsuu@gentoo.org> ftpbase-0.00.ebuild:
Stable on sh.
diff --git a/net-ftp/ftpbase/Manifest b/net-ftp/ftpbase/Manifest
index 090b4e834cba..70807389c761 100644
--- a/net-ftp/ftpbase/Manifest
+++ b/net-ftp/ftpbase/Manifest
@@ -1,7 +1,7 @@
-MD5 c72baec58288dd9cff10d137def45400 ftpbase-0.00.ebuild 2442
-MD5 d10d8b67d85ef2badc0d9acf6a32c97e ChangeLog 1499
+MD5 f0a3353a62fd60ef2a14f9aa6c0b15ac ChangeLog 1705
+MD5 1e5344b37b02008f08173928774ca16b ftpbase-0.00.ebuild 2416
MD5 f545d2bcdb5641a7863b64be435382e2 metadata.xml 285
-MD5 bd59faca8d7138ac67e99d94507b04f9 files/ftpusers 407
-MD5 9e7d64873559cebdc60ee1d0d7845ce7 files/ftp-pamd-include 747
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-ftpbase-0.00 0
MD5 7be20c7c1b62bb7e65994bd7a686695e files/ftp-pamd 807
+MD5 9e7d64873559cebdc60ee1d0d7845ce7 files/ftp-pamd-include 747
+MD5 bd59faca8d7138ac67e99d94507b04f9 files/ftpusers 407
diff --git a/net-ftp/ftpbase/ftpbase-0.00.ebuild b/net-ftp/ftpbase/ftpbase-0.00.ebuild
index 512dbb40987e..0390ce7b59b1 100644
--- a/net-ftp/ftpbase/ftpbase-0.00.ebuild
+++ b/net-ftp/ftpbase/ftpbase-0.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.11 2005/10/02 23:01:56 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpbase/ftpbase-0.00.ebuild,v 1.12 2005/10/05 17:27:33 uberlord Exp $
inherit eutils pam
@@ -83,11 +83,11 @@ pkg_postinst() {
# Install manually using install -d until bug #9849 is solved.
# This means that the home directory will not be removed when we uninstall
# if it's empty.
- local homedir="${ROOT}$( egetent passwd ftp | cut -d: -f6 )"
+ local homedir=$( egethome ftp )
if [[ ! -d ${homedir} ]]; then
einfo "Creating home directory for ftp user"
einfo " ${homedir}"
install -d "${homedir}" \
- || ewarn " can't create ${homedir}"
+ || ewarn " can't create ${homedir}"
fi
}