summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-09-05 16:16:03 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-09-05 16:16:03 +0000
commit2ae011ff2e95a1b2edd837457c0d5416ac4ba1e3 (patch)
tree2914fb04bf3526cd05a8619714cfd079684aa355 /net-im/linphone
parentAdded callback functionality to -r11 (diff)
downloadhistorical-2ae011ff2e95a1b2edd837457c0d5416ac4ba1e3.tar.gz
historical-2ae011ff2e95a1b2edd837457c0d5416ac4ba1e3.tar.bz2
historical-2ae011ff2e95a1b2edd837457c0d5416ac4ba1e3.zip
repoman fixes (mostly cleanups of old ebuilds with pspell stuff in them)
and linphone relocation to net-im.
Diffstat (limited to 'net-im/linphone')
-rw-r--r--net-im/linphone/ChangeLog9
-rw-r--r--net-im/linphone/files/digest-linphone-0.9.01
-rw-r--r--net-im/linphone/linphone-0.9.0.ebuild65
3 files changed, 75 insertions, 0 deletions
diff --git a/net-im/linphone/ChangeLog b/net-im/linphone/ChangeLog
new file mode 100644
index 000000000000..92715c3006e1
--- /dev/null
+++ b/net-im/linphone/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/linphone
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.1 2002/09/05 16:16:03 drobbins Exp $
+
+*linphone-0.9.0 (05 Sep 2002)
+
+ 05 Sep 2002; Daniel Robbins <drobbins@gentoo.org> This ebuild was created by
+ gaarde (Paul Belt) or someone else using his account. Looks ok, so moving to
+ its proper place in net-im (was in net-dialup before.)
diff --git a/net-im/linphone/files/digest-linphone-0.9.0 b/net-im/linphone/files/digest-linphone-0.9.0
new file mode 100644
index 000000000000..0a9d56343a92
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.9.0
@@ -0,0 +1 @@
+MD5 696986d6fd133efda2cee98fe7230513 linphone-0.9.0.tar.gz 1845011
diff --git a/net-im/linphone/linphone-0.9.0.ebuild b/net-im/linphone/linphone-0.9.0.ebuild
new file mode 100644
index 000000000000..e0d7271c19fe
--- /dev/null
+++ b/net-im/linphone/linphone-0.9.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/linphone-0.9.0.ebuild,v 1.1 2002/09/05 16:16:03 drobbins Exp $
+
+# AUTHOR: Paul Belt <gaarde@gentoo.org>
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface. It let you make two-party calls over IP networks such as the Internet. It uses the IETF protocols SIP (Session Initiation Protocol) and RTP (Realtime Transport Protocol) to make calls, so it should be able to communicate with other SIP-based Web phones. With several codecs available, it can be used with high speed connections as well as 28k modems."
+
+# In french
+# if use french; then \
+# HOMEPAGE="http://www.linphone.org/" \
+# elsif use english; then \
+# HOMEPAGE="http://www.linphone.org/?lang=us"
+# fi
+
+# In english
+HOMEPAGE="http://www.linphone.org/?lang=us"
+
+SRC_URI="http://www.linphone.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="1"
+
+KEYWORDS="x86"
+
+RDEPEND="=net-libs/libosip-0.8.8
+ =gnome-base/gnome-panel-1.4.1
+ alsa? ( >media-sound/alsa-driver-0.5 )
+ xv? ( dev-lang/nasm )
+ dev-libs/glib"
+
+DEPEND="${RDEPEND}"
+
+src_compile() {
+
+ if use pic; \
+ then EXTRA_FLAGS="${EXTRA_FLAGS} --with-pic"; \
+ else EXTRA_FLAGS="${EXTRA_FLAGS} --without-pic"; fi
+
+ if use alsa; \
+ then EXTRA_FLAGS="${EXTRA_FLAGS} --enable-alsa"; \
+ else EXTRA_FLAGS="${EXTRA_FLAGS} --disable-alsa"; fi
+
+# Not functional at the moment
+# if use xv; \
+# then EXTRA_FLAGS="${EXTRA_FLAGS} --enable-video"; \
+# else EXTRA_FLAGS="${EXTRA_FLAGS} --disable-video"; fi
+
+ if use nls; \
+ then EXTRA_FLAGS="${EXTRA_FLAGS} --enable-nls"; \
+ else EXTRA_FLAGS="${EXTRA_FLAGS} --disable-nls"; fi
+
+ if use gtk && use doc; \
+ then EXTRA_FLAGS="${EXTRA_FLAGS} --enable-gtk-doc"; \
+ else EXTRA_FLAGS="${EXTRA_FLAGS} --disable-gtk-doc"; fi
+
+ econf || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}