summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2004-09-04 16:37:23 +0000
committerGustavo Felisberto <humpback@gentoo.org>2004-09-04 16:37:23 +0000
commitb7ebac5c80253b3d554ee2b3427adc98ae1eedb0 (patch)
treeff9699f2da9c0f3c8d20dd7d8b1062f06a1c11f2 /net-im/skype
parentfix manifest (diff)
downloadhistorical-b7ebac5c80253b3d554ee2b3427adc98ae1eedb0.tar.gz
historical-b7ebac5c80253b3d554ee2b3427adc98ae1eedb0.tar.bz2
historical-b7ebac5c80253b3d554ee2b3427adc98ae1eedb0.zip
Version bump with small fix
Diffstat (limited to 'net-im/skype')
-rw-r--r--net-im/skype/ChangeLog12
-rw-r--r--net-im/skype/files/digest-skype-0.91.0.122
-rw-r--r--net-im/skype/skype-0.91.0.12.ebuild82
3 files changed, 95 insertions, 1 deletions
diff --git a/net-im/skype/ChangeLog b/net-im/skype/ChangeLog
index 9a4101728b22..a33ce6470927 100644
--- a/net-im/skype/ChangeLog
+++ b/net-im/skype/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-im/skype
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.13 2004/08/23 18:10:50 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/ChangeLog,v 1.14 2004/09/04 16:37:23 humpback Exp $
+
+*skype-0.91.0.12 (04 Sep 2004)
+
+ 04 Sep 2004; Gustavo Felisberto <humpback@gentoo.org>;
+ +skype-0.91.0.12.ebuild:
+ Adding version 0.91.0.12, skype keeps changing the name of the directory where
+ it unpacks stuff. This closes bug 62807, thanks to Jurek Bartuszek for taking
+ this bump to our attention. On a side note, people have been asking when this
+ will be marked stable, my answer right now is that it will go stable when
+ skype stops making new versions every 15 days.
23 Aug 2004; Gustavo Felisberto <humpback@gentoo.org>;
skype-0.91.0.3.ebuild:
diff --git a/net-im/skype/files/digest-skype-0.91.0.12 b/net-im/skype/files/digest-skype-0.91.0.12
new file mode 100644
index 000000000000..30dddbb24f4f
--- /dev/null
+++ b/net-im/skype/files/digest-skype-0.91.0.12
@@ -0,0 +1,2 @@
+MD5 1cb31f95ecf3521615e4ceb1b3841b65 skype_ver-0_91_0_12.tar.bz2 4067122
+MD5 c7a52492e07124e851ba397d30b3285a skype_ver-0_91_0_12-staticQT.tar.bz2 6435574
diff --git a/net-im/skype/skype-0.91.0.12.ebuild b/net-im/skype/skype-0.91.0.12.ebuild
new file mode 100644
index 000000000000..ff0c431034b8
--- /dev/null
+++ b/net-im/skype/skype-0.91.0.12.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-0.91.0.12.ebuild,v 1.1 2004/09/04 16:37:23 humpback Exp $
+
+inherit eutils
+
+
+#If you want to know when this package will be marked stable please see the Changelog
+SVER=${PV//./_}
+RESTRICT="nomirror"
+DESCRIPTION="${PN} is a P2P-VoiceIP client."
+HOMEPAGE="http://www.${PN}.com/"
+SRC_URI="
+ qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}.tar.bz2 )
+ !qt? ( http://download.skype.com/linux/${PN}_ver-${SVER}-staticQT.tar.bz2 )"
+LICENSE="skype-eula"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="qt arts esd"
+DEPEND="qt? ( >=x11-libs/qt-3.2 )
+ >=sys-libs/glibc-2.2.5"
+S="${WORKDIR}/${PN}_ver-${SVER}"
+
+src_unpack() {
+ if use !qt;
+ then
+ unpack ${PN}_ver-${SVER}-staticQT.tar.bz2
+ cd ${WORKDIR}
+ mv ${S}-staticQT ${S}
+ cd ${S}
+ else
+ unpack ${PN}_ver-${SVER}.tar.bz2
+ cd ${S}
+ fi
+}
+
+src_install() {
+ ## Install the wrapper script
+ if ( use arts || use esd );
+ then
+ mv skype skype.bin
+ cp ${FILESDIR}/sDaemonWrapper skype
+ fi
+
+ dodir /opt/skype
+ exeopts -m0755
+ exeinto /opt/skype
+ doexe skype
+ ( use arts || use esd ) && doexe skype.bin
+ #It seems skype wants the wave in /usr/share/skype
+ #http://forum.skype.com/bb/viewtopic.php?t=4145
+ insinto /usr/share/skype
+ doins call_in.wav
+ insinto /usr/share/skype/lang
+ doins *.qm
+ insinto /opt/skype
+ make_desktop_entry skype "Skype VoIP" ../icons/hicolor/48x48/apps/skype.png
+ for SIZE in 16 24 32 48
+ do
+ mkdir ${S}/icons/${SIZE}
+ cp ${S}/icons/${PN}_${SIZE}_32.png ${S}/icons/${SIZE}/${PN}.png
+ dodir /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
+ insinto /usr/share/icons/hicolor/${SIZE}x${SIZE}/apps
+ doins ${S}/icons/${SIZE}/${PN}.png
+ done
+ ( use arts || use esd ) && fowners root:audio /opt/skype/skype.bin
+ fowners root:audio /opt/skype/skype
+ dodir /usr/bin/
+ dosym /opt/skype/skype /usr/bin/skype
+}
+
+pkg_postinst() {
+ einfo "Have a look at ${PORTDIR}/licenses/${LICENSE} before running this software"
+ einfo "If you have sound problems please visit: "
+ einfo "http://forum.skype.com/bb/viewtopic.php?t=4489"
+ if ( use arts );
+ then
+ ewarn "Dont forget to configure your arts to work in Full-Duplex mode"
+ ewarn "Open controlcenter, go to \"Sound & Multimedia\"->\"Sound System\""
+ ewarn "On the \"Hardware\" tab, check the box next to \"Full duplex\"."
+ fi
+}