summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-01-19 13:06:06 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-01-19 13:06:06 +0000
commit425ef0300a68d1eb8da445f7ba67e0fbfb862a61 (patch)
treebb09cabdc3e1edf6676334b657ccdad0e30147e2 /net-im
parentNew ebuild. Closes bug #4282. (diff)
downloadhistorical-425ef0300a68d1eb8da445f7ba67e0fbfb862a61.tar.gz
historical-425ef0300a68d1eb8da445f7ba67e0fbfb862a61.tar.bz2
historical-425ef0300a68d1eb8da445f7ba67e0fbfb862a61.zip
beta version ov imcom (1.30beta2) + fix for a xml-handling error
Diffstat (limited to 'net-im')
-rw-r--r--net-im/imcom/files/JabberHandler.py.patch4
-rw-r--r--net-im/imcom/files/digest-imcom-1.30_beta21
-rw-r--r--net-im/imcom/files/digest-imcom-1.30_beta2-r11
-rw-r--r--net-im/imcom/imcom-1.30_beta2-r1.ebuild38
-rw-r--r--net-im/imcom/imcom-1.30_beta2.ebuild32
5 files changed, 76 insertions, 0 deletions
diff --git a/net-im/imcom/files/JabberHandler.py.patch b/net-im/imcom/files/JabberHandler.py.patch
new file mode 100644
index 000000000000..f8d28c41ae9f
--- /dev/null
+++ b/net-im/imcom/files/JabberHandler.py.patch
@@ -0,0 +1,4 @@
+835c835
+< if(hasattr(gt,"text") and len(gt.text) > 0):
+---
+> if(hasattr(gt,"text") and gt.text != None and len(gt.text) > 0):
diff --git a/net-im/imcom/files/digest-imcom-1.30_beta2 b/net-im/imcom/files/digest-imcom-1.30_beta2
new file mode 100644
index 000000000000..94ac4b2d26aa
--- /dev/null
+++ b/net-im/imcom/files/digest-imcom-1.30_beta2
@@ -0,0 +1 @@
+MD5 f09395c05705ac34d65c12f29ffe82e8 imcom-1.30beta2.tar.gz 268509
diff --git a/net-im/imcom/files/digest-imcom-1.30_beta2-r1 b/net-im/imcom/files/digest-imcom-1.30_beta2-r1
new file mode 100644
index 000000000000..94ac4b2d26aa
--- /dev/null
+++ b/net-im/imcom/files/digest-imcom-1.30_beta2-r1
@@ -0,0 +1 @@
+MD5 f09395c05705ac34d65c12f29ffe82e8 imcom-1.30beta2.tar.gz 268509
diff --git a/net-im/imcom/imcom-1.30_beta2-r1.ebuild b/net-im/imcom/imcom-1.30_beta2-r1.ebuild
new file mode 100644
index 000000000000..7a1e90bdea95
--- /dev/null
+++ b/net-im/imcom/imcom-1.30_beta2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/imcom-1.30_beta2-r1.ebuild,v 1.1 2003/01/19 13:06:06 lordvan Exp $
+
+S=${WORKDIR}/${PN}-1.30beta2
+#SRC_URI="http://imcom.floobin.cx/files/${P}.tar.gz"
+SRC_URI="http://nafai.dyndns.org/files/imcom-betas/${PN}-1.30beta2.tar.gz"
+HOMEPAGE="http://imcom.floobin.cx"
+DESCRIPTION="Python commandline Jabber Client"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/PyXML-0.7"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # patch for 1.30beta2 (most likely fixed in later versions)
+ patch -p1 JabberHandler.py < ${FILESDIR}/JabberHandler.py.patch
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/imcom
+ dodoc AutoStatus.API CONTRIBUTORS LICENSE README* TODO WHATSNEW
+ dodoc docs/*
+ cp *.py ${D}/usr/share/imcom
+ mv imcom imcom.orig
+ sed -e 's:/usr/local/share:/usr/share:' imcom.orig | cat > imcom
+ chmod 755 imcom
+ dobin imcom
+
+}
diff --git a/net-im/imcom/imcom-1.30_beta2.ebuild b/net-im/imcom/imcom-1.30_beta2.ebuild
new file mode 100644
index 000000000000..95583310399f
--- /dev/null
+++ b/net-im/imcom/imcom-1.30_beta2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/imcom/imcom-1.30_beta2.ebuild,v 1.1 2003/01/19 13:06:06 lordvan Exp $
+
+S=${WORKDIR}/${PN}-1.30beta2
+#SRC_URI="http://imcom.floobin.cx/files/${P}.tar.gz"
+SRC_URI="http://nafai.dyndns.org/files/imcom-betas/${PN}-1.30beta2.tar.gz"
+HOMEPAGE="http://imcom.floobin.cx"
+DESCRIPTION="Python commandline Jabber Client"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/PyXML-0.7"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+src_install() {
+
+ dodir /usr/bin
+ dodir /usr/share/imcom
+ dodoc AutoStatus.API CONTRIBUTORS LICENSE README* TODO WHATSNEW
+ dodoc docs/*
+ cp *.py ${D}/usr/share/imcom
+ mv imcom imcom.orig
+ sed -e 's:/usr/local/share:/usr/share:' imcom.orig | cat > imcom
+ chmod 755 imcom
+ dobin imcom
+
+}