summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-01-10 13:34:03 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-01-10 13:34:03 +0000
commitda017d859739bccc009ef822034ec68227177b3c (patch)
treebe30af10b83c3d715e035460d5032684071dc71b /net-im
parentlimit old mask on bochs to 1.4.1, so i can work on an ebuild for 2.0.1 (diff)
downloadhistorical-da017d859739bccc009ef822034ec68227177b3c.tar.gz
historical-da017d859739bccc009ef822034ec68227177b3c.tar.bz2
historical-da017d859739bccc009ef822034ec68227177b3c.zip
version bump
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/ChangeLog7
-rw-r--r--net-im/licq/files/digest-licq-1.2.31
-rw-r--r--net-im/licq/licq-1.2.3.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index 9776225bb6c8..ec306e08c9ba 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.8 2002/12/27 04:16:05 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.9 2003/01/10 13:34:03 hannes Exp $
+*licq-1.2.3 (10 Jan 2003)
+
+ 10 Jan 2003; Hannes Mehnert <hannes@gentoo.org> licq-1.2.3.ebuild:
+ version bump, compiles fine with qt-3.1 and gcc-3.2.1 without patching
+ source, fixes bug #13493
*licq-1.2.0a-r3 (26 Dec 2002)
diff --git a/net-im/licq/files/digest-licq-1.2.3 b/net-im/licq/files/digest-licq-1.2.3
new file mode 100644
index 000000000000..691e5a956ee9
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.3
@@ -0,0 +1 @@
+MD5 57b00f580515e6a51e401ca50e197ce9 licq-1.2.3.tar.bz2 2875064
diff --git a/net-im/licq/licq-1.2.3.ebuild b/net-im/licq/licq-1.2.3.ebuild
new file mode 100644
index 000000000000..9be32eaf990a
--- /dev/null
+++ b/net-im/licq/licq-1.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.3.ebuild,v 1.1 2003/01/10 13:34:03 hannes Exp $
+
+IUSE="ssl socks5 qt kde"
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="~x86"
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui
+ make DESTDIR=${D} install || die
+ fi
+
+}