summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 03:30:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 03:30:47 +0000
commit111dbef23a8081e2c4d1b877ad710c7121f8d210 (patch)
tree80c5dcbf1e6663df28ed726a5e6a7375f322baea /net-irc/kvirc
parentcleanup $DEBUG -> use debug (diff)
downloadhistorical-111dbef23a8081e2c4d1b877ad710c7121f8d210.tar.gz
historical-111dbef23a8081e2c4d1b877ad710c7121f8d210.tar.bz2
historical-111dbef23a8081e2c4d1b877ad710c7121f8d210.zip
cleanup
Diffstat (limited to 'net-irc/kvirc')
-rw-r--r--net-irc/kvirc/files/digest-kvirc-3.0.0_beta11
-rw-r--r--net-irc/kvirc/files/digest-kvirc-3.0.0_beta21
-rw-r--r--net-irc/kvirc/kvirc-2.1.1-r1.ebuild51
-rw-r--r--net-irc/kvirc/kvirc-3.0.0_beta1.ebuild70
-rw-r--r--net-irc/kvirc/kvirc-3.0.0_beta2.ebuild73
5 files changed, 23 insertions, 173 deletions
diff --git a/net-irc/kvirc/files/digest-kvirc-3.0.0_beta1 b/net-irc/kvirc/files/digest-kvirc-3.0.0_beta1
deleted file mode 100644
index b07a4606c155..000000000000
--- a/net-irc/kvirc/files/digest-kvirc-3.0.0_beta1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7fde2ff00014b7e7fdc32d1b4f5040ad kvirc-3.0.0-beta1.tar.gz 2565299
diff --git a/net-irc/kvirc/files/digest-kvirc-3.0.0_beta2 b/net-irc/kvirc/files/digest-kvirc-3.0.0_beta2
deleted file mode 100644
index f177e39f2761..000000000000
--- a/net-irc/kvirc/files/digest-kvirc-3.0.0_beta2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 53960975a2002f9b03845f640f0d85d4 kvirc-3.0.0-beta2.tar.gz 2815485
diff --git a/net-irc/kvirc/kvirc-2.1.1-r1.ebuild b/net-irc/kvirc/kvirc-2.1.1-r1.ebuild
index 983ae22d7ccb..a0f881e51def 100644
--- a/net-irc/kvirc/kvirc-2.1.1-r1.ebuild
+++ b/net-irc/kvirc/kvirc-2.1.1-r1.ebuild
@@ -1,45 +1,40 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-2.1.1-r1.ebuild,v 1.11 2003/02/13 14:15:39 vapier Exp $
-use kde &&
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-2.1.1-r1.ebuild,v 1.12 2003/08/03 03:30:47 vapier Exp $
+
use kde && inherit kde-base
-S=${WORKDIR}/${P}
DESCRIPTION="A IRC Client for KDE"
+HOMEPAGE="http://www.kvirc.net/"
SRC_URI="ftp://ftp.kvirc.net/kvirc/2.1.1/source/${P}.tar.bz2"
-HOMEPAGE="http://www.kvirc.net"
-
-DEPEND="$DEPEND virtual/glibc
- =x11-libs/qt-2.3*"
-use kde && need-kde 2.1
-
-SLOT="2"
LICENSE="kvirc"
+SLOT="2"
KEYWORDS="x86"
-src_unpack() {
- cd ${WORKDIR}
- unpack ${A}
-}
+DEPEND="virtual/glibc
+ =x11-libs/qt-2.3*"
+use kde && need-kde 2.1
src_compile() {
- use kde && myconf="${myconf} --with-kde-support"
-
- use kde && kde_src_compile myconf
- ./configure --mandir=/usr/share/man --infodir=/usr/share/info \
- --host=${CHOST} ${myconf} --prefix=/usr || die
-
- make kvirc || die
+ use kde && myconf="${myconf} --with-kde-support"
+ use kde && kde_src_compile myconf
+
+ ./configure \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} \
+ --prefix=/usr || die
+ make kvirc || die
}
-src_install () {
- make install DESTDIR=${D} || die
- make docs DESTDIR=${D} || die
+src_install() {
+ make install DESTDIR=${D} || die
+ make docs DESTDIR=${D} || die
- rm -rf ${D}/${KDEDIR}/man
- doman data/man/kvirc.1
+ rm -rf ${D}/${KDEDIR}/man
+ doman data/man/kvirc.1
- dodoc ChangeLog INSTALL README TODO
-
+ dodoc ChangeLog INSTALL README TODO
}
diff --git a/net-irc/kvirc/kvirc-3.0.0_beta1.ebuild b/net-irc/kvirc/kvirc-3.0.0_beta1.ebuild
deleted file mode 100644
index 19384a7dbbbf..000000000000
--- a/net-irc/kvirc/kvirc-3.0.0_beta1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta1.ebuild,v 1.9 2003/02/13 14:15:45 vapier Exp $
-
-IUSE="kde esd ipv6"
-inherit kde-base
-
-MYP=${P//_/-}
-MYPV=${PV//_/-}
-S=${WORKDIR}/${MYP}
-DESCRIPTION="An advanced IRC Client"
-SRC_URI="ftp://ftp.kvirc.net/kvirc/${MYPV}/source/${MYP}.tar.gz"
-HOMEPAGE="http://www.kvirc.net"
-
-SLOT="3"
-LICENSE="kvirc"
-KEYWORDS="x86"
-
-use kde && need-kde 3 || need-qt 3
-
-newdepend "esd? ( media-sound/esound )"
-# ssl? ( dev-libs/openssl )"
-use kde || newdepend "arts? ( kde-base/arts )"
-
-[ -n "$DEBUG" ] && myconf="$myconf --with-debug-symbols"
-[ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
-use ipv6 && myconf="$myconf --with-ipv6-support" \
- || myconf="$myconf --without-ipv6-support"
-# arts support without kde support isn't liked by the configure script
-# possibly it could be made to work but i didn't want to spend time on it
-use kde && myconf="$myconf --with-kde-support --with-arts-support" \
- || myconf="$myconf --without-kde-support --without-arts-support"
-use esd && myconf="$myconf --with-esd-support" \
- || myconf="$myconf --without-esd-support"
-# no use flag as yet, and a hard dep is rather pointless
-#use audiofile && myconf="$myconf --with-arts-support" \
-# || myconf="$myconf --without-arts-support"
-# doesn't compile
-#use ssl && myconf="$myconf --with-ssl-support" \
-# || myconf="$myconf --without-ssl-support"
-
-# use aa even when kde support is disabled
-myconf="$myconf --with-aa-fonts"
-
-src_compile() {
-
- use kde && kde_src_compile myconf
-
- # always install into /usr regardless of kde support
- # kvirc doesn't have a kde-like installed file structure anyway
- myconf="$myconf --prefix=/usr -v"
-
- # make sure we disable kde support as the configure script can auto-enable
- # it when it isn't wanted
- use kde || export KDEDIR=""
-
- kde_src_compile configure make
-
-}
-
-src_install () {
-
- make install DESTDIR=${D} || die
- make docs DESTDIR=${D} || die
-
- dodoc ChangeLog INSTALL README TODO
-
-}
-
-
diff --git a/net-irc/kvirc/kvirc-3.0.0_beta2.ebuild b/net-irc/kvirc/kvirc-3.0.0_beta2.ebuild
deleted file mode 100644
index 45deaa1249f1..000000000000
--- a/net-irc/kvirc/kvirc-3.0.0_beta2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-3.0.0_beta2.ebuild,v 1.3 2003/04/30 18:36:48 caleb Exp $
-IUSE="kde esd ipv6 ssl"
-inherit kde-base
-
-MYP=${P//_/-}
-MYPV=${PV//_/-}
-S=${WORKDIR}/${MYP}
-DESCRIPTION="An advanced IRC Client"
-SRC_URI="ftp://ftp.kvirc.net/kvirc/${MYPV}/source/${MYP}.tar.gz"
-HOMEPAGE="http://www.kvirc.net"
-
-SLOT="3"
-LICENSE="kvirc"
-KEYWORDS="~x86"
-
-use kde && need-kde 3 || need-qt 3
-
-newdepend "esd? ( media-sound/esound )
- ssl? ( dev-libs/openssl )
- oss? ( media-libs/audiofile )"
-use kde || newdepend "arts? ( kde-base/arts )"
-
-[ -n "$DEBUG" ] && myconf="$myconf --with-debug-symbols"
-[ "$ARCH" == "x86" ] && myconf="$myconf --with-ix86-asm"
-#use ipv6 && myconf="$myconf --with-ipv6-support" \
-use ipv6 || myconf="$myconf --without-ipv6-support"
-# arts support without kde support isn't liked by the configure script
-# possibly it could be made to work but i didn't want to spend time on it
-# also, explicitly passing --with-kde-support seems to break configure's logic, so just
-# let it autodetect in that case
-#use kde && myconf="$myconf --with-kde-support --with-arts-support" \
-use kde || myconf="$myconf --without-kde-support --without-arts-support"
-#use esd && myconf="$myconf --with-esd-support" \
-use esd || myconf="$myconf --without-esd-support"
-use oss && myconf="$myconf --with-af--support" \
- || myconf="$myconf --without-af-support"
-#use ssl && myconf="$myconf --with-ssl-support" \
-use ssl || myconf="$myconf --without-ssl-support"
-
-# use aa even when kde support is disabled; disable local 8bit character set conversion, doesn't compile
-myconf="$myconf --with-aa-fonts"
-
-src_compile() {
-
- use kde && kde_src_compile myconf
-
- # always install into /usr regardless of kde support
- # kvirc doesn't have a kde-like installed file structure anyway
- myconf="$myconf --prefix=/usr -v"
-
- # make sure we disable kde support as the configure script can auto-enable
- # it when it isn't wanted
- use kde || export KDEDIR=""
-
- need-automake 1.5
- need-autoconf 2.5
-
- kde_src_compile configure make
-
-}
-
-src_install () {
-
- make install DESTDIR=${D} || die
- make docs DESTDIR=${D} || die
-
- dodoc ChangeLog INSTALL README TODO
-
-}
-
-