summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-01 04:47:09 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-01 04:47:09 +0000
commit44e1a423c54001fb956e2a62c69a7921a4e2bb6f (patch)
tree94117230636862fd811cd952a88f3c62d482bba7 /net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
parentAdded dependency on dev-tcltk/tls. (diff)
downloadhistorical-44e1a423c54001fb956e2a62c69a7921a4e2bb6f.tar.gz
historical-44e1a423c54001fb956e2a62c69a7921a4e2bb6f.tar.bz2
historical-44e1a423c54001fb956e2a62c69a7921a4e2bb6f.zip
initial ebuild
Diffstat (limited to 'net-irc/unrealircd/unrealircd-3.1.5.1.ebuild')
-rw-r--r--net-irc/unrealircd/unrealircd-3.1.5.1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild b/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
new file mode 100644
index 000000000000..7bad67187e5c
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/unrealircd/unrealircd-3.1.5.1.ebuild,v 1.1 2003/02/01 04:47:09 vapier Exp $
+
+inherit eutils
+
+MY_P="Unreal${PV}"
+DESCRIPTION="aimed to be an advanced, not an easy IRCd"
+HOMEPAGE="http://www.unrealircd.com/"
+SRC_URI="http://www.gower.net/unrealircd/${MY_P}-Valek.tar.gz
+ ftp://unreal.secure-tech.net/${MY_P}-Valek.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="openssl"
+
+DEPEND="virtual/glibc
+ openssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A} && cd ${S}
+ rm -f .CHANGES.NEW .RELEASE.NOTES
+ epatch ${FILESDIR}/${P}-Config.patch
+
+ cp Config{,.orig}
+ sed -e "s:GENTOO_CFLAGS:${CFLAGS}:" \
+ Config.orig > Config
+}
+
+src_compile() {
+ ./Config || die "configure failed"
+ make || die "compiling failed"
+}
+
+src_install() {
+ newbin src/ircd unrealircd || die
+ newbin makeconf unrealircd-makeconf || die
+ newbin src/chkconf unrealircd-chkconf || die
+
+ insinto /etc/unrealircd
+ doins badwords.*.conf
+ insinto /etc/unrealircd/networks
+ doins networks/{template.network,unrealircd.conf}
+
+ dodoc doc/* Changes Donation Unreal.nfo dynconf ircdcron/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/unrealircd.rc unrealircd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/unrealircd.confd unrealircd
+}
+
+pkg_postinst() {
+ einfo "UnrealIRCD will not run until you do a few things ..."
+ echo
+ einfo "Setup /etc/unrealircd/unrealircd.conf"
+ einfo " see /etc/unrealircd/template.network for more info"
+ einfo "Setup /etc/unrealircd/ircd.conf"
+ einfo " see /usr/share/doc/${PF}/example.conf.gz for more info"
+ echo
+ einfo "You can find example cron scripts here:"
+ einfo " /usr/share/doc/${PF}/ircd.cron"
+ einfo " /usr/share/doc/${PF}/ircdchk"
+ einfo "You can also use /etc/init.d/unrealircd to start at boot"
+}