summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-06-28 08:34:16 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-06-28 08:34:16 +0000
commit9642ec807f0ad7619eeb6bbd78522b1d6d92d2d7 (patch)
tree8645d07f895407d6bc050f958eabb2e9257e2ef2 /net-irc/xchat-otr/xchat-otr-0.3.ebuild
parentx86 stable wrt bug #278177 (diff)
downloadhistorical-9642ec807f0ad7619eeb6bbd78522b1d6d92d2d7.tar.gz
historical-9642ec807f0ad7619eeb6bbd78522b1d6d92d2d7.tar.bz2
historical-9642ec807f0ad7619eeb6bbd78522b1d6d92d2d7.zip
Initial commit.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'net-irc/xchat-otr/xchat-otr-0.3.ebuild')
-rw-r--r--net-irc/xchat-otr/xchat-otr-0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-irc/xchat-otr/xchat-otr-0.3.ebuild b/net-irc/xchat-otr/xchat-otr-0.3.ebuild
new file mode 100644
index 000000000000..7d25321dd019
--- /dev/null
+++ b/net-irc/xchat-otr/xchat-otr-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat-otr/xchat-otr-0.3.ebuild,v 1.1 2010/06/28 08:34:16 polynomial-c Exp $
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Off-The-Record messaging (OTR) for xchat"
+HOMEPAGE="http://irssi-otr.tuxfamily.org"
+
+# This should probably be exported by cmake-utils as a variable
+CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
+mycmakeargs="-DDOCDIR=/usr/share/doc/${PF}"
+
+SRC_URI="ftp://download.tuxfamily.org/irssiotr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="net-libs/libotr
+ net-irc/xchat
+ dev-libs/glib
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error"
+
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.7
+ dev-util/pkgconfig
+ dev-lang/python"
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/share/doc/${PF}/LICENSE
+ prepalldocs
+}