summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-03-29 12:31:32 +0000
committerChuck Short <zul@gentoo.org>2004-03-29 12:31:32 +0000
commit4c1607d29ed216566f42c2b7b9cc62c55a0a097a (patch)
tree9de7280fbc8d26324e497a71b51bb794f578922d /net-irc
parentstable on ppc, as it is a dependency for net-mail/exim-4.24-r3 (diff)
downloadhistorical-4c1607d29ed216566f42c2b7b9cc62c55a0a097a.tar.gz
historical-4c1607d29ed216566f42c2b7b9cc62c55a0a097a.tar.bz2
historical-4c1607d29ed216566f42c2b7b9cc62c55a0a097a.zip
Version bump, closes #45574.
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/Manifest4
-rw-r--r--net-irc/xchat/files/digest-xchat-2.0.81
-rw-r--r--net-irc/xchat/xchat-2.0.8.ebuild79
4 files changed, 89 insertions, 2 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 17b46cccf7c9..b1efe513287d 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/xchat
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.85 2004/03/13 23:52:30 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.86 2004/03/29 12:31:32 zul Exp $
+
+*xchat-2.0.8 (29 Mar 2004)
+
+ 29 Mar 2004; Chuck Short <zul@gentoo.org> xchat-2.0.8.ebuild:
+ Version bump, closes #45574.
13 Mar 2004; Stephen P. Becker <geoman@gentoo.org> xchat-2.0.7.ebuild:
Added ~mips keyword.
diff --git a/net-irc/xchat/Manifest b/net-irc/xchat/Manifest
index dea3e25fee84..28ee316b8f81 100644
--- a/net-irc/xchat/Manifest
+++ b/net-irc/xchat/Manifest
@@ -1,11 +1,13 @@
MD5 3c00efd4e318063b3406138eeb1be17d xchat-2.0.1.ebuild 1946
MD5 4413eef7d08114ed31069a3d548d7ec5 xchat-2.0.6-r1.ebuild 2389
+MD5 f10959baccdc0f5d02aac5a9e93a0233 xchat-2.0.8.ebuild 1997
MD5 dd7301da7d85bb9a2a559e0a2731d7c1 xchat-1.8.11.ebuild 2217
MD5 989a31481fadba4d9b79fa433134a0a7 xchat-2.0.7.ebuild 1996
-MD5 fe9760700e0df3600fbddcd0b0685866 ChangeLog 11929
+MD5 7fe2b517b3fda6aa80b4824573ef2839 ChangeLog 12050
MD5 fb5772136a872c08434566d4f0bcdc7f metadata.xml 179
MD5 1ee812a2b3e28e3866413e75a80ff983 files/digest-xchat-2.0.1 64
MD5 15dadb9b77f7536f6c7769689fc883c9 files/digest-xchat-2.0.7 64
+MD5 aac7b6be8968c5e6e1bdf580546a18fd files/digest-xchat-2.0.8 64
MD5 a8f607d224408d4a27777d2ffce8beac files/xc1811fixststint.diff 422
MD5 e2b99b2d2dfc54ba96e560c0ed8392df files/digest-xchat-1.8.11 65
MD5 1c19b8dfe0dfe3574cb74726f3f04466 files/digest-xchat-2.0.6-r1 64
diff --git a/net-irc/xchat/files/digest-xchat-2.0.8 b/net-irc/xchat/files/digest-xchat-2.0.8
new file mode 100644
index 000000000000..5873ee762edd
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-2.0.8
@@ -0,0 +1 @@
+MD5 64cd419e7bb14e36e658b09726d3411f xchat-2.0.8.tar.bz2 997439
diff --git a/net-irc/xchat/xchat-2.0.8.ebuild b/net-irc/xchat/xchat-2.0.8.ebuild
new file mode 100644
index 000000000000..8cd2f7f7076d
--- /dev/null
+++ b/net-irc/xchat/xchat-2.0.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-2.0.8.ebuild,v 1.1 2004/03/29 12:31:32 zul Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Graphical IRC client"
+SRC_URI="http://www.xchat.org/files/source/2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~x86 ~sparc ~hppa ~ppc ~alpha ~amd64 ~ia64 ~mips"
+IUSE="perl tcltk python ssl mmx ipv6 nls"
+# Local use flag for the text frontend (bug #26427)
+IUSE="${IUSE} xchattext xchatnogtk"
+
+# Added for to fix a sparc seg fault issue by Jason Wever <weeve@gentoo.org>
+if [ ${ARCH} = "sparc" ]
+then
+ replace-flags "-O3" "-O2"
+fi
+
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ !xchatnogtk? ( >=x11-libs/gtk+-2.0.3 )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ python? ( dev-lang/python )
+ tcltk? ( dev-lang/tcl )
+ nls? ( sys-devel/gettext )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+src_compile() {
+
+ # xchat's configure script uses sys.path to find library path
+ # instead of python-config (#25943)
+ unset PYTHONPATH
+
+ # test for local usage of xchatnogtk
+ local gtkconf
+ use xchatnogtk \
+ && gtkconf="--disable-gtkfe" \
+ || gtkconf="--enable-gtkfe"
+
+ econf \
+ ${gtkconf} \
+ `use_enable ssl openssl` \
+ `use_enable perl` \
+ `use_enable python` \
+ `use_enable tcltk tcl` \
+ `use_enable mmx` \
+ `use_enable ipv6` \
+ `use_enable nls` \
+ `use_enable xchattext textfe` \
+ --program-suffix=-2 \
+ || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+
+}
+
+src_install() {
+
+ # some magic to create a menu entry for xchat 2
+ mv xchat.desktop xchat.desktop.old
+ sed -e "s:Exec=xchat:Exec=xchat-2:" -e "s:Name=XChat IRC:Name=XChat 2 IRC:" xchat.desktop.old > xchat.desktop
+
+ einstall install || die "Install failed"
+
+ # install plugin development header
+ insinto /usr/include/xchat
+ doins src/common/xchat-plugin.h
+
+ dodoc AUTHORS COPYING ChangeLog README*
+
+}