summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-02-19 23:40:57 +0000
committerSven Wegener <swegener@gentoo.org>2005-02-19 23:40:57 +0000
commitf5696f01c212e6b7b5486ddf870dd3ff12fa02c2 (patch)
tree834c192e6867cdd9014ca74bca348e34684321a6 /net-irc
parentNew ebuild by me .. thanks to cYmen in #gentoo-laptop for testing. (diff)
downloadhistorical-f5696f01c212e6b7b5486ddf870dd3ff12fa02c2.tar.gz
historical-f5696f01c212e6b7b5486ddf870dd3ff12fa02c2.tar.bz2
historical-f5696f01c212e6b7b5486ddf870dd3ff12fa02c2.zip
Added a patch that fixes wrong return value checking. Closes bug #82546.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchatosd/ChangeLog9
-rw-r--r--net-irc/xchatosd/Manifest13
-rw-r--r--net-irc/xchatosd/files/5.17-return-values.patch38
-rw-r--r--net-irc/xchatosd/files/digest-xchatosd-5.17-r1 (renamed from net-irc/xchatosd/files/digest-xchatosd-5.17)0
-rw-r--r--net-irc/xchatosd/xchatosd-5.17-r1.ebuild (renamed from net-irc/xchatosd/xchatosd-5.17.ebuild)3
5 files changed, 55 insertions, 8 deletions
diff --git a/net-irc/xchatosd/ChangeLog b/net-irc/xchatosd/ChangeLog
index 4b677a7946b2..928c6eefcff8 100644
--- a/net-irc/xchatosd/ChangeLog
+++ b/net-irc/xchatosd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-irc/xchatosd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.8 2005/02/17 02:54:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/ChangeLog,v 1.9 2005/02/19 23:40:57 swegener Exp $
+
+*xchatosd-5.17-r1 (20 Feb 2005)
+
+ 20 Feb 2005; Sven Wegener <swegener@gentoo.org>
+ +files/5.17-return-values.patch, +xchatosd-5.17-r1.ebuild,
+ -xchatosd-5.17.ebuild:
+ Added a patch that fixes wrong return value checking. Closes bug #82546.
*xchatosd-5.17 (17 Feb 2005)
diff --git a/net-irc/xchatosd/Manifest b/net-irc/xchatosd/Manifest
index 9e6f370a6892..61ba57eb914d 100644
--- a/net-irc/xchatosd/Manifest
+++ b/net-irc/xchatosd/Manifest
@@ -1,18 +1,19 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 e3524a27e36ba37f1d2c64c4b0af6164 xchatosd-5.17.ebuild 1183
MD5 bee7f395b77d83073fca6a7001c85d69 xchatosd-5.12.ebuild 1093
-MD5 8d7de871f633df0d4798edcbff96d6cb ChangeLog 1188
+MD5 406c48eb39c5277cbddbd4e7bb8de50c ChangeLog 1433
MD5 44c39c6ad372a8e5a5e7ee3311f703a7 metadata.xml 160
+MD5 a8e9c89d570fd0e6b4c4bd0d8b21030a xchatosd-5.17-r1.ebuild 1232
MD5 73a892b3dd95b4ea0441cb8a92829f5a files/5.17-iconv-fix.patch 369
+MD5 556374cc39115a0d31091bdde6b5d15f files/5.17-return-values.patch 1437
+MD5 4ab5968709df638e1ecc7a143d927cfa files/digest-xchatosd-5.17-r1 64
MD5 81c1e430042db312cd8ebfcde85c3a25 files/digest-xchatosd-5.12 63
-MD5 4ab5968709df638e1ecc7a143d927cfa files/digest-xchatosd-5.17 64
MD5 aa8f7d8a41446470ada6599787802bd1 files/5.12-return-values.patch 1486
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCFAdcI1lqEGTUzyQRAhNdAKChSNP3GgImXyWl8sTyCFjuHhDmoACbBlU8
-0mwdMm2fwmMTJcf0Gw5v0wQ=
-=OQVb
+iD8DBQFCF86RI1lqEGTUzyQRAhnAAJsHBSvhmEaqNR+RCrIgRmSbd0CVSwCbBqTK
+P4WZ6Pu3zYU1fYK/ssBMJ6Q=
+=vx1D
-----END PGP SIGNATURE-----
diff --git a/net-irc/xchatosd/files/5.17-return-values.patch b/net-irc/xchatosd/files/5.17-return-values.patch
new file mode 100644
index 000000000000..a45de146bb8a
--- /dev/null
+++ b/net-irc/xchatosd/files/5.17-return-values.patch
@@ -0,0 +1,38 @@
+--- xchatosd.cpp.orig 2005-02-20 00:35:28.056851489 +0100
++++ xchatosd.cpp 2005-02-20 00:36:19.240761787 +0100
+@@ -79,16 +79,25 @@
+ return -1;
+ }
+ int status = 0;
+- status += osd->setPos(config.getValue("pos"));
+- status += osd->setVOffset(config.getiValue("voffset"));
+- status += osd->setHOffset(config.getiValue("hoffset"));
+- status += osd->setAlign(config.getValue("align"));
+- status += osd->setSOffset(config.getiValue("shadow"));
+- status += osd->setTimeout(config.getiValue("timeout"));
+- status += osd->setFont(config.getValue("font"));
+- status += osd->setColor(config.getValue("color"));
+- status += osd->display(MSG_Hello);
+- return status;
++ status = osd->setPos(config.getValue("pos"));
++ if (-1 == status) return -1;
++ status = osd->setVOffset(config.getiValue("voffset"));
++ if (-1 == status) return -1;
++ status = osd->setHOffset(config.getiValue("hoffset"));
++ if (-1 == status) return -1;
++ status = osd->setAlign(config.getValue("align"));
++ if (-1 == status) return -1;
++ status = osd->setSOffset(config.getiValue("shadow"));
++ if (-1 == status) return -1;
++ status = osd->setTimeout(config.getiValue("timeout"));
++ if (-1 == status) return -1;
++ status = osd->setFont(config.getValue("font"));
++ if (-1 == status) return -1;
++ status = osd->setColor(config.getValue("color"));
++ if (-1 == status) return -1;
++ status = osd->display(MSG_Hello);
++ if (-1 == status) return -1;
++ return 0;
+ }
+
+ #ifdef ICONV_LIB
diff --git a/net-irc/xchatosd/files/digest-xchatosd-5.17 b/net-irc/xchatosd/files/digest-xchatosd-5.17-r1
index 24ccca38e0fd..24ccca38e0fd 100644
--- a/net-irc/xchatosd/files/digest-xchatosd-5.17
+++ b/net-irc/xchatosd/files/digest-xchatosd-5.17-r1
diff --git a/net-irc/xchatosd/xchatosd-5.17.ebuild b/net-irc/xchatosd/xchatosd-5.17-r1.ebuild
index bb3fbc0150a4..9f874d1820b0 100644
--- a/net-irc/xchatosd/xchatosd-5.17.ebuild
+++ b/net-irc/xchatosd/xchatosd-5.17-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.17.ebuild,v 1.1 2005/02/17 02:54:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchatosd/xchatosd-5.17-r1.ebuild,v 1.1 2005/02/19 23:40:57 swegener Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -22,6 +22,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PV}-iconv-fix.patch
+ epatch ${FILESDIR}/${PV}-return-values.patch
# We have our own include file in /usr/include/xchat
einfo "Updating xchat-plugin.h from /usr/include/xchat/xchat-plugin.h"