summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-07-08 15:46:46 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-07-08 15:46:46 +0000
commit51aea9ef24c53395f0ff63beafe9be59e81ab763 (patch)
treea61245ca9281c7f07e73370e5cb161f543b3a630 /net-libs/libpri
parentVersion bump: This release reverts the patch introduced in 0.14.8 changing th... (diff)
downloadhistorical-51aea9ef24c53395f0ff63beafe9be59e81ab763.tar.gz
historical-51aea9ef24c53395f0ff63beafe9be59e81ab763.tar.bz2
historical-51aea9ef24c53395f0ff63beafe9be59e81ab763.zip
Bump to final 1.4.12 release; patches reworked by Erik Wallin from pushtalk.se in bug #374363.
Package-Manager: portage-2.1.10.4/cvs/Linux x86_64
Diffstat (limited to 'net-libs/libpri')
-rw-r--r--net-libs/libpri/ChangeLog9
-rw-r--r--net-libs/libpri/files/libpri-1.4.12-released-respect-cflags.patch37
-rw-r--r--net-libs/libpri/libpri-1.4.12.ebuild32
3 files changed, 77 insertions, 1 deletions
diff --git a/net-libs/libpri/ChangeLog b/net-libs/libpri/ChangeLog
index 81102de68cba..14bf1587e809 100644
--- a/net-libs/libpri/ChangeLog
+++ b/net-libs/libpri/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libpri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.89 2011/05/17 08:11:22 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.90 2011/07/08 15:46:46 chainsaw Exp $
+
+*libpri-1.4.12 (08 Jul 2011)
+
+ 08 Jul 2011; Tony Vroon <chainsaw@gentoo.org> +libpri-1.4.12.ebuild,
+ +files/libpri-1.4.12-released-respect-cflags.patch:
+ Bump to final 1.4.12 release; patches reworked by Erik Wallin from
+ pushtalk.se in bug #374363.
*libpri-1.4.12_beta3 (17 May 2011)
diff --git a/net-libs/libpri/files/libpri-1.4.12-released-respect-cflags.patch b/net-libs/libpri/files/libpri-1.4.12-released-respect-cflags.patch
new file mode 100644
index 000000000000..560bd34bcff0
--- /dev/null
+++ b/net-libs/libpri/files/libpri-1.4.12-released-respect-cflags.patch
@@ -0,0 +1,37 @@
+--- libpri-1.4.12/Makefile.orig 2011-07-07 16:18:34.185504616 +0200
++++ libpri-1.4.12/Makefile 2011-07-07 16:32:09.095312715 +0200
+@@ -90,7 +90,7 @@
+ rose_qsig_mwi.lo \
+ rose_qsig_name.lo \
+ version.lo
+-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
+ INSTALL_PREFIX=$(DESTDIR)
+ INSTALL_BASE=/usr
+ LIBDIR=$(INSTALL_PREFIX)$(INSTALL_BASE)/lib
+@@ -124,20 +124,12 @@
+
+ PRIVERSION:=$(shell GREP=$(GREP) AWK=$(AWK) build_tools/make_version .)
+
+-#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
+-#This works for even old (2.96) versions of gcc and provides a small boost either way.
+-#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesnt support it.
+-ifeq ($(PROC),sparc64)
+-PROC=ultrasparc
+-LIBPRI_OPT = -mtune=$(PROC) -O3 -pipe -fomit-frame-pointer -mcpu=v8
++ifneq ($(CODE_COVERAGE),)
++ LIBPRI_OPT=
++ COVERAGE_CFLAGS=-ftest-coverage -fprofile-arcs
++ COVERAGE_LDFLAGS=-ftest-coverage -fprofile-arcs
+ else
+- ifneq ($(CODE_COVERAGE),)
+- LIBPRI_OPT=
+- COVERAGE_CFLAGS=-ftest-coverage -fprofile-arcs
+- COVERAGE_LDFLAGS=-ftest-coverage -fprofile-arcs
+- else
+- LIBPRI_OPT=-O2
+- endif
++ LIBPRI_OPT=
+ endif
+
+ ifeq ($(CPUARCH),i686)
diff --git a/net-libs/libpri/libpri-1.4.12.ebuild b/net-libs/libpri/libpri-1.4.12.ebuild
new file mode 100644
index 000000000000..e4471e1b112b
--- /dev/null
+++ b/net-libs/libpri/libpri-1.4.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.4.12.ebuild,v 1.1 2011/07/08 15:46:46 chainsaw Exp $
+
+EAPI="3"
+
+inherit base
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.12-multilib.patch"
+ "${FILESDIR}/${PN}-1.4.12-released-respect-cflags.patch"
+ "${FILESDIR}/${PN}-1.4.12-respect-ldflags.patch"
+)
+
+src_install() {
+ emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install \
+ || die "emake install failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}