summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-03 16:09:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-03 16:09:22 +0000
commit25537a3cf497895c11d1a41348538b450cbe379b (patch)
treef33830719018292fe63c6507449c5a75db439865 /net-mail/checkpassword
parentcleanup (diff)
downloadhistorical-25537a3cf497895c11d1a41348538b450cbe379b.tar.gz
historical-25537a3cf497895c11d1a41348538b450cbe379b.tar.bz2
historical-25537a3cf497895c11d1a41348538b450cbe379b.zip
head -1 patch
Diffstat (limited to 'net-mail/checkpassword')
-rw-r--r--net-mail/checkpassword/ChangeLog5
-rw-r--r--net-mail/checkpassword/checkpassword-0.90-r1.ebuild20
-rw-r--r--net-mail/checkpassword/files/0.90-head-1.patch39
3 files changed, 54 insertions, 10 deletions
diff --git a/net-mail/checkpassword/ChangeLog b/net-mail/checkpassword/ChangeLog
index fcf8b9722903..561c9022e3cc 100644
--- a/net-mail/checkpassword/ChangeLog
+++ b/net-mail/checkpassword/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-mail/checkpassword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.8 2003/05/14 04:39:41 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/ChangeLog,v 1.9 2003/09/03 16:09:22 vapier Exp $
*checkpassword-0.90-r1 (05 Mar 2003)
+ 03 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add head -1 patch.
+
13 May 2003; Robin Johnson <robbat2@gentoo.org> checkpassword-0.90-r1.ebuild:
Fixed DESCRIPTION and HOMEPAGE, added more docs to install list.
Fix gcc/$CC bug, make sure CFLAGS are used as well.
diff --git a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
index 55b69c18e83a..a59dbbe95bd0 100644
--- a/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
+++ b/net-mail/checkpassword/checkpassword-0.90-r1.ebuild
@@ -1,34 +1,36 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.4 2003/05/14 04:39:41 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/checkpassword/checkpassword-0.90-r1.ebuild,v 1.5 2003/09/03 16:09:22 vapier Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="A uniform password checking interface for root applications"
-SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
HOMEPAGE="http://cr.yp.to/checkpwd.html"
+SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha ~mips ~hppa ~arm"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-errno.patch
-}
+ epatch ${FILESDIR}/${PV}-head-1.patch
-src_compile() {
# the -s is from the original build
LDFLAGS="${LDFLAGS} -s"
use pic && CFLAGS="${CFLAGS} -fPIC"
use static && LDFLAGS="${LDFLAGS} -static"
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(gcc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(gcc-getCC) ${LDFLAGS}" > conf-ld
+}
+
+src_compile() {
make || die "Error in make"
}
-src_install() {
+src_install() {
into /
dobin checkpassword
dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
diff --git a/net-mail/checkpassword/files/0.90-head-1.patch b/net-mail/checkpassword/files/0.90-head-1.patch
new file mode 100644
index 000000000000..08e54297de4e
--- /dev/null
+++ b/net-mail/checkpassword/files/0.90-head-1.patch
@@ -0,0 +1,39 @@
+diff -ur checkpassword-0.90.orig/Makefile checkpassword-0.90/Makefile
+--- checkpassword-0.90.orig/Makefile 2003-09-03 12:06:23.225291952 -0400
++++ checkpassword-0.90/Makefile 2003-09-03 12:06:29.578326144 -0400
+@@ -22,7 +22,7 @@
+
+ auto_home.c: \
+ auto-str conf-home
+- ./auto-str auto_home `head -1 conf-home` > auto_home.c
++ ./auto-str auto_home `head -n 1 conf-home` > auto_home.c
+
+ auto_home.o: \
+ compile auto_home.c
+@@ -91,7 +91,7 @@
+ choose: \
+ warn-auto.sh choose.sh conf-home
+ cat warn-auto.sh choose.sh \
+- | sed s}HOME}"`head -1 conf-home`"}g \
++ | sed s}HOME}"`head -n 1 conf-home`"}g \
+ > choose
+ chmod 755 choose
+
+@@ -166,7 +166,7 @@
+ warn-auto.sh conf-ld
+ ( cat warn-auto.sh; \
+ echo 'main="$$1"; shift'; \
+- echo exec "`head -1 conf-ld`" \
++ echo exec "`head -n 1 conf-ld`" \
+ '-o "$$main" "$$main".o $${1+"$$@"}' \
+ ) > load
+ chmod 755 load
+diff -ur checkpassword-0.90.orig/print-cc.sh checkpassword-0.90/print-cc.sh
+--- checkpassword-0.90.orig/print-cc.sh 2003-09-03 12:06:23.227291648 -0400
++++ checkpassword-0.90/print-cc.sh 2003-09-03 12:06:34.308607032 -0400
+@@ -1,4 +1,4 @@
+-cc="`head -1 conf-cc`"
++cc="`head -n 1 conf-cc`"
+ systype="`cat systype`"
+
+ cat warn-auto.sh