summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-09-26 19:54:12 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-09-26 19:54:12 +0000
commit0776b533233bb92ca40c085db7a7368168ba2c06 (patch)
tree847729488d2062b7fd94211338379a5558090084 /net-mail/mailx
parentdigests (diff)
downloadhistorical-0776b533233bb92ca40c085db7a7368168ba2c06.tar.gz
historical-0776b533233bb92ca40c085db7a7368168ba2c06.tar.bz2
historical-0776b533233bb92ca40c085db7a7368168ba2c06.zip
Added mailx, generally used in scripts
Diffstat (limited to 'net-mail/mailx')
-rw-r--r--net-mail/mailx/files/digest-mailx-8.1.1.111
-rw-r--r--net-mail/mailx/mailx-8.1.1.11.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/net-mail/mailx/files/digest-mailx-8.1.1.11 b/net-mail/mailx/files/digest-mailx-8.1.1.11
new file mode 100644
index 000000000000..ea1fc0142797
--- /dev/null
+++ b/net-mail/mailx/files/digest-mailx-8.1.1.11
@@ -0,0 +1 @@
+MD5 c779002cb043b57fd5198ec2032cacb0 mailx_8.1.1.orig.tar.gz
diff --git a/net-mail/mailx/mailx-8.1.1.11.ebuild b/net-mail/mailx/mailx-8.1.1.11.ebuild
new file mode 100644
index 000000000000..6933d5369060
--- /dev/null
+++ b/net-mail/mailx/mailx-8.1.1.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Martin Schlemmer <azarah@saintmail.net>
+
+S=${WORKDIR}/mailx-8.1.1.orig
+DESCRIPTION="The /bin/mail program, which is used to send mail via shell scripts."
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/m/mailx/mailx_8.1.1.orig.tar.gz"
+HOMEPAGE="http://www.debian.org"
+
+DEPEND="virtual/glibc
+ >=net-libs/liblockfile-1.03"
+
+RDEPEND="virtual/glibc
+ >=net-libs/liblockfile-1.03"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1 < ${FILESDIR}/${PF}.diff || die
+ patch -p1 < ${FILESDIR}/${PF}-version.diff || die
+ # It needs to install to /bin/mail (else conflicts with Postfix)
+ # Also man pages go to /usr/share/man for FHS compliancy
+ patch -p0 <${FILESDIR}/${PF}-Makefile.diff || die
+
+}
+
+src_compile() {
+
+ # Can't compile mailx with optimizations
+ _CFLAGS=$(echo $CFLAGS|sed 's/-O.//g')
+
+ make CFLAGS="$_CFLAGS" || die
+
+}
+
+src_install () {
+
+ dodir /bin /usr/share/man/man1 /etc /usr/lib
+ make BINDIR=/bin DESTDIR=${D} install || die
+
+ # Install the docs
+ docinto debian
+ dodoc debian/*
+
+ # Some scripts require /bin/Mail
+ dosym mail /bin/Mail
+ dosym mail.1 /usr/share/man/man1/Mail.1
+
+}
+