summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-14 03:00:48 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-14 03:00:48 +0000
commit32db2f395af7b916cdb3f0f04eeabc7ed325bbee (patch)
tree706cc11eb8f83f0e3cefbb79be5655463bc5d4ec /net-mail/qtools
parentslight fix for $CC vs. gcc. Moved to stable x86 as well. (diff)
downloadhistorical-32db2f395af7b916cdb3f0f04eeabc7ed325bbee.tar.gz
historical-32db2f395af7b916cdb3f0f04eeabc7ed325bbee.tar.bz2
historical-32db2f395af7b916cdb3f0f04eeabc7ed325bbee.zip
slight fix for $CC vs. gcc. Moved to stable x86 as well.
Diffstat (limited to 'net-mail/qtools')
-rw-r--r--net-mail/qtools/Manifest5
-rw-r--r--net-mail/qtools/qtools-0.56.ebuild13
2 files changed, 8 insertions, 10 deletions
diff --git a/net-mail/qtools/Manifest b/net-mail/qtools/Manifest
index 7beca5c6a1d9..86f391ca10f2 100644
--- a/net-mail/qtools/Manifest
+++ b/net-mail/qtools/Manifest
@@ -1,5 +1,4 @@
-MD5 e96978f8d673b00929cf03c4bf108c32 qtools-0.56.ebuild~ 1146
-MD5 8ff9eee42c06c51c3e13eaed7f3ebdd8 ChangeLog 394
-MD5 e96978f8d673b00929cf03c4bf108c32 qtools-0.56.ebuild 1146
+MD5 b0abc4a12cea1999014b4ddeca74c791 ChangeLog 525
+MD5 5e37fbf87c270d02a00b8cd17d1a882c qtools-0.56.ebuild 1166
MD5 d397de4ad57b3e6d89294df49fa4f3b1 files/digest-qtools-0.56 62
MD5 04a4c35d8c9cdf362be4a58d25a9aa4d files/qtools-0.56-errno.patch 291
diff --git a/net-mail/qtools/qtools-0.56.ebuild b/net-mail/qtools/qtools-0.56.ebuild
index 9e223ddc4256..1785fb918195 100644
--- a/net-mail/qtools/qtools-0.56.ebuild
+++ b/net-mail/qtools/qtools-0.56.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/qtools-0.56.ebuild,v 1.1 2003/04/05 23:29:37 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/qtools/qtools-0.56.ebuild,v 1.2 2003/05/14 03:00:45 robbat2 Exp $
inherit eutils
@@ -14,9 +14,9 @@ LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86 ~mips ~arm ~hppa ~alpha ~ppc ~sparc"
-DEPEND=""
+DEPEND="sys-devel/gcc-config"
S=${WORKDIR}/${P}
@@ -27,10 +27,9 @@ src_unpack() {
}
src_compile() {
- LDFLAGS=
- use static && LDFLAGS="-static"
- echo "gcc ${CFLAGS}" > conf-cc
- echo "gcc ${LDFLAGS}" > conf-ld
+ use static && LDFLAGS="${LDFLAGS} -static"
+ echo "${CC} ${CFLAGS}" > conf-cc
+ echo "${CC} ${LDFLAGS}" > conf-ld
echo "/usr" > conf-home
emake || die "emake failed"
}