summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-01-05 19:24:56 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-01-05 19:24:56 +0000
commitb33be9e1c9af994c89bcbdb51f1b81fbb8083a84 (patch)
treeeed8621de331e8cb4e33c417a467523bdec68206 /net-mail/razor
parentadded ppc to KEYWORDS (diff)
downloadhistorical-b33be9e1c9af994c89bcbdb51f1b81fbb8083a84.tar.gz
historical-b33be9e1c9af994c89bcbdb51f1b81fbb8083a84.tar.bz2
historical-b33be9e1c9af994c89bcbdb51f1b81fbb8083a84.zip
patch for even newer version
Diffstat (limited to 'net-mail/razor')
-rw-r--r--net-mail/razor/ChangeLog9
-rw-r--r--net-mail/razor/files/digest-razor-2.201
-rw-r--r--net-mail/razor/files/razor_uninstall.patch49
-rw-r--r--net-mail/razor/razor-2.20.ebuild71
4 files changed, 129 insertions, 1 deletions
diff --git a/net-mail/razor/ChangeLog b/net-mail/razor/ChangeLog
index d0e94b61f1eb..47426cacb02d 100644
--- a/net-mail/razor/ChangeLog
+++ b/net-mail/razor/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for net-mail/razor
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.4 2003/01/05 17:50:26 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/ChangeLog,v 1.5 2003/01/05 19:24:56 mcummings Exp $
+*razor-2.20
+
+ 05 Jan 2003; Michael Cummings <mcummings@gentoo.org>: version bump
+
+ This includes a patch for the razor ebuild (razor wants to clean up old
+ copies of itself during installation)
+
*razor-2.14
05 Jan 2003; Michael Cummings <mcummings@gentoo.org>: version bump
diff --git a/net-mail/razor/files/digest-razor-2.20 b/net-mail/razor/files/digest-razor-2.20
new file mode 100644
index 000000000000..de960e2bdff2
--- /dev/null
+++ b/net-mail/razor/files/digest-razor-2.20
@@ -0,0 +1 @@
+MD5 0c36212f0c40407ce5035d337eac0b79 razor-agents-2.20.tar.gz 75517
diff --git a/net-mail/razor/files/razor_uninstall.patch b/net-mail/razor/files/razor_uninstall.patch
new file mode 100644
index 000000000000..08ff31eb788e
--- /dev/null
+++ b/net-mail/razor/files/razor_uninstall.patch
@@ -0,0 +1,49 @@
+--- ./Makefile 2003-01-05 14:02:33.000000000 -0500
++++ ./Makefile.mpc 2003-01-05 14:01:09.000000000 -0500
+@@ -275,12 +275,13 @@
+ # need any changes to the core distribution and works with older perls
+ EQUALIZE_TIMESTAMP = $(PERLRUN) "-MExtUtils::Command" -e eqtime
+
++# MPC - we disable this because this is what package autocleaning is for :)
+ # Here we warn users that an old packlist file was found somewhere,
+ # and that they should call some uninstall routine
+-WARN_IF_OLD_PACKLIST = $(PERL) -we 'exit unless -f $$ARGV[0];' \
+--e 'print "WARNING: I have found an old package in\n";' \
+--e 'print "\t$$ARGV[0].\n";' \
+--e 'print "Please make sure the two installations are not conflicting\n";'
++#WARN_IF_OLD_PACKLIST = $(PERL) -we 'exit unless -f $$ARGV[0];' \
++#-e 'print "WARNING: I have found an old package in\n";' \
++#-e 'print "\t$$ARGV[0].\n";' \
++#-e 'print "Please make sure the two installations are not conflicting\n";'
+
+ UNINST=0
+ VERBINST=0
+@@ -682,7 +683,7 @@
+
+ # --- MakeMaker install section:
+
+-install :: all pure_install doc_install install_razor_agents
++install :: all pure_install doc_install
+
+ install_perl :: all pure_perl_install doc_perl_install
+
+@@ -710,8 +711,7 @@
+ $(INST_SCRIPT) $(INSTALLSCRIPT) \
+ $(INST_MAN1DIR) $(INSTALLMAN1DIR) \
+ $(INST_MAN5DIR) $(INSTALLMAN5DIR) \
+- $(INST_MAN3DIR) $(INSTALLMAN3DIR)
+- $(WARN_IF_OLD_PACKLIST) \
++ $(INST_MAN3DIR) $(INSTALLMAN3DIR) \
+ $(SITEARCHEXP)/auto/$(FULLEXT)
+
+
+@@ -724,8 +724,7 @@
+ $(INST_BIN) $(INSTALLSITEBIN) \
+ $(INST_SCRIPT) $(INSTALLSCRIPT) \
+ $(INST_MAN1DIR) $(INSTALLSITEMAN1DIR) \
+- $(INST_MAN3DIR) $(INSTALLSITEMAN3DIR)
+- $(WARN_IF_OLD_PACKLIST) \
++ $(INST_MAN3DIR) $(INSTALLSITEMAN3DIR) \
+ $(PERL_ARCHLIB)/auto/$(FULLEXT)
+
+ pure_vendor_install ::
diff --git a/net-mail/razor/razor-2.20.ebuild b/net-mail/razor/razor-2.20.ebuild
new file mode 100644
index 000000000000..c583d7ace5ce
--- /dev/null
+++ b/net-mail/razor/razor-2.20.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/razor/razor-2.20.ebuild,v 1.1 2003/01/05 19:24:56 mcummings Exp $
+
+inherit perl-module
+
+S="${WORKDIR}/razor-agents-${PV}"
+
+DESCRIPTION="Vipul's Razor is a distributed, collaborative spam detection and filtering network"
+HOMEPAGE="http://razor.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/razor/razor-agents-${PV}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+RDEPEND="sys-devel/perl
+ dev-perl/Net-DNS
+ dev-perl/Time-HiRes
+ dev-perl/Digest-SHA1
+ dev-perl/URI
+ dev-perl/Digest-Nilsimsa"
+
+src_install() {
+
+ patch -p1 < ${FILESDIR}/razor_uninstall.patch
+
+ perl-module_src_install
+}
+
+pkg_postinst() {
+
+# insures appropriate symlinks have been created
+ /usr/bin/razor-client
+
+einfo "Run `razor-admin -create' to create a default config file in your"
+einfo "home directory under /home/user/.razor. (Remember to change user to"
+einfo "your username from root before running razor-admin)"
+einfo ""
+einfo "Razor v2 requires reporters to be registered so their reputations can"
+einfo "be computed over time and they can participate in the revocation"
+einfo "mechanism. Registration is done with razor-admin -register. It has to be"
+einfo "manually invoked in either of the following ways:"
+einfo ""
+einfo "To register user foo with `s1kret' as password: "
+einfo ""
+einfo "razor-admin -register -user=foo -pass=s1kr3t"
+einfo ""
+einfo "To register with an email address and have the password assigned:"
+einfo ""
+einfo "razor-admin -register -user=foo@bar.com "
+einfo ""
+einfo "To have both (random) username and password assgined: "
+einfo ""
+einfo "razor-admin -register "
+einfo ""
+einfo "razor-admin -register negotiates a registration with the Nomination Server"
+einfo "and writes the identity information in"
+einfo "/home/user/.razor/identity-username, or /etc/razor/identity-username"
+einfo "when invoked as root."
+einfo ""
+einfo "You can edit razor-agent.conf to change the defaults. Config options"
+einfo "and their values are defined in the razor-agent.conf(5) manpage."
+
+einfo "The next step is to integrate razor-check, razor-report and"
+einfo "razor-revoke in your mail system. If you are running Razor v1, the"
+einfo "change will be transparent, new versions of razor agents will overwrite"
+einfo "the old ones. You would still need to plugin razor-revoke in your MUA,"
+einfo "since it's a new addition in Razor v2. If you are not running Razor v1,"
+einfo "refer to manpages of razor-check(1), razor-report(1), and"
+einfo "razor-revoke(1) for integration instructions."
+}