summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-03-22 04:14:31 +0000
committerAron Griffis <agriffis@gentoo.org>2005-03-22 04:14:31 +0000
commit9c4eb4ea43c7fa442cc0c151c1e0ee619b3a9b0e (patch)
tree95d97d25d03bc6e5b888813d0f1db83850d4bf38 /net-mail/safecat
parentstable lovin (diff)
downloadhistorical-9c4eb4ea43c7fa442cc0c151c1e0ee619b3a9b0e.tar.gz
historical-9c4eb4ea43c7fa442cc0c151c1e0ee619b3a9b0e.tar.bz2
historical-9c4eb4ea43c7fa442cc0c151c1e0ee619b3a9b0e.zip
Use toolchain functions instead of $CC et al
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-mail/safecat')
-rw-r--r--net-mail/safecat/ChangeLog5
-rw-r--r--net-mail/safecat/Manifest4
-rw-r--r--net-mail/safecat/safecat-1.11.ebuild17
3 files changed, 15 insertions, 11 deletions
diff --git a/net-mail/safecat/ChangeLog b/net-mail/safecat/ChangeLog
index a5131df683bc..ff1049057a2c 100644
--- a/net-mail/safecat/ChangeLog
+++ b/net-mail/safecat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/safecat
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.10 2005/03/21 01:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.11 2005/03/22 04:14:31 agriffis Exp $
+
+ 22 Mar 2005; <agriffis@gentoo.org> safecat-1.11.ebuild:
+ Use toolchain functions instead of $CC et al
19 Mar 2005; Aron Griffis <agriffis@gentoo.org> safecat-1.11.ebuild:
Stable on alpha amd64 ia64 x86
diff --git a/net-mail/safecat/Manifest b/net-mail/safecat/Manifest
index 78225bfb56a8..0fa65d47a574 100644
--- a/net-mail/safecat/Manifest
+++ b/net-mail/safecat/Manifest
@@ -1,5 +1,5 @@
-MD5 8ff54c32023b916f7d49cead1dc430a0 safecat-1.11.ebuild 1209
-MD5 0751dca4286a58e316cde04af3f602f5 ChangeLog 1123
+MD5 171a2d6e9a58efb9e12e861aa0d9be0a safecat-1.11.ebuild 1240
+MD5 2c5ea02adc907acb8b1d5fa51ce9c868 ChangeLog 1229
MD5 9d0c568ea32cf6b45797c6e7c82b4a67 metadata.xml 280
MD5 f1a0de11ad74ec86a89591c3d4de8d85 files/safecat-1.11-gentoo.patch 355
MD5 b8802a01bb6d1194118da7bb8f98d3f4 files/digest-safecat-1.11 63
diff --git a/net-mail/safecat/safecat-1.11.ebuild b/net-mail/safecat/safecat-1.11.ebuild
index 678a7b080035..33e036b8fa9a 100644
--- a/net-mail/safecat/safecat-1.11.ebuild
+++ b/net-mail/safecat/safecat-1.11.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.10 2005/03/19 15:25:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.11.ebuild,v 1.11 2005/03/22 04:14:31 agriffis Exp $
-IUSE=""
+inherit fixheadtails eutils toolchain-funcs
-inherit fixheadtails eutils
+IUSE=""
DESCRIPTION="Safecat implements qmail's maildir algorithm, copying standard input safely to a specified directory."
-HOMEPAGE="http://budney.homeunix.net:8080/users/budney/linux/software/${PN}/"
+HOMEPAGE="http://budney.homeunix.net:8080/users/budney/linux/software/safecat/"
SRC_URI="http://budney.homeunix.net:8080/users/budney/linux/software/${PN}/${P}.tar.gz"
DEPEND="virtual/libc
@@ -26,15 +26,16 @@ src_unpack() {
cd ${S}
echo "/usr" > conf-root
- echo "${CC} ${CFLAGS}" > conf-cc
- echo "${CC} ${LDFLAGS}" > conf-ld
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
ht_fix_file Makefile make-compile.sh
-}
-src_compile() {
egrep -v 'man|doc' hier.c > hier.c.new
mv hier.c.new hier.c
+}
+
+src_compile() {
make it man || die
}