summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Bormolini <lordjoe@gentoo.org>2001-09-19 05:55:25 +0000
committerJoe Bormolini <lordjoe@gentoo.org>2001-09-19 05:55:25 +0000
commit7cb45e5f5d43fb4b356c09e7a9e4ae0088a15cfa (patch)
tree214688383fbedaf6cc8218cbe24dcd6f440cb6cc /net-mail/sylpheed
parenta small fix for an orphaned manpage getting installed to a bad spot (diff)
downloadhistorical-7cb45e5f5d43fb4b356c09e7a9e4ae0088a15cfa.tar.gz
historical-7cb45e5f5d43fb4b356c09e7a9e4ae0088a15cfa.tar.bz2
historical-7cb45e5f5d43fb4b356c09e7a9e4ae0088a15cfa.zip
New version... just copied ebuild over, it should work (tm)
Diffstat (limited to 'net-mail/sylpheed')
-rw-r--r--net-mail/sylpheed/files/digest-sylpheed-0.6.21
-rw-r--r--net-mail/sylpheed/sylpheed-0.6.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-mail/sylpheed/files/digest-sylpheed-0.6.2 b/net-mail/sylpheed/files/digest-sylpheed-0.6.2
new file mode 100644
index 000000000000..294a7a1a3407
--- /dev/null
+++ b/net-mail/sylpheed/files/digest-sylpheed-0.6.2
@@ -0,0 +1 @@
+MD5 4f92dce0a085f68391d4a78d0f5cc656 sylpheed-0.6.2.tar.bz2
diff --git a/net-mail/sylpheed/sylpheed-0.6.2.ebuild b/net-mail/sylpheed/sylpheed-0.6.2.ebuild
new file mode 100644
index 000000000000..8280ac4b84c2
--- /dev/null
+++ b/net-mail/sylpheed/sylpheed-0.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed/sylpheed-0.6.2.ebuild,v 1.1 2001/09/19 05:55:25 lordjoe Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="A lightweight email client and newsreader"
+SRC_URI="http://sylpheed.good-day.net/sylpheed/${A}"
+HOMEPAGE="http://sylpheed.good-day.net"
+
+DEPEND=">=x11-libs/gtk+-1.2
+ >=media-libs/compface-1.4
+ gnome? ( >=media-libs/gdk-pixbuf-0.10 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ gpg? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.2 )"
+
+
+RDEPEND=">=x11-libs/gtk+-1.2
+ gnome? ( >=media-libs/gdk-pixbuf-0.10 )
+ ssl? ( dev-libs/openssl )
+ gpg? ( >=app-crypt/gnupg-1.0.6 >=app-crypt/gpgme-0.2.2 )"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use gnome`" ] ; then
+ myconf="--disable-gdk-pixbuf --disable-imlib"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --enable-ssl"
+ fi
+ if [ "`use gpg`" ] ; then
+ myconf="$myconf --enable-gpgme"
+ fi
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} --enable-ipv6 $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr manualdir=${D}/usr/share/doc/${PF}/html install
+ dodoc AUTHORS COPYING ChangeLog* NEWS README* TODO*
+
+}
+