summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-03 04:20:13 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-03 04:20:13 +0000
commitfb31bef3fe8080dee889619bde76fbe692434380 (patch)
treef1717ec5430e9bc9ee251b8239449a604fc43ca9 /net-mail/vpopmail
parentmake 5.2.2-r1 stable (diff)
downloadhistorical-fb31bef3fe8080dee889619bde76fbe692434380.tar.gz
historical-fb31bef3fe8080dee889619bde76fbe692434380.tar.bz2
historical-fb31bef3fe8080dee889619bde76fbe692434380.zip
ver bump
Diffstat (limited to 'net-mail/vpopmail')
-rw-r--r--net-mail/vpopmail/ChangeLog7
-rw-r--r--net-mail/vpopmail/files/digest-vpopmail-5.4.02
-rw-r--r--net-mail/vpopmail/vpopmail-5.4.0.ebuild242
3 files changed, 250 insertions, 1 deletions
diff --git a/net-mail/vpopmail/ChangeLog b/net-mail/vpopmail/ChangeLog
index 3a008a9f544b..61d7b979d033 100644
--- a/net-mail/vpopmail/ChangeLog
+++ b/net-mail/vpopmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/vpopmail
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.29 2004/03/08 22:52:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/ChangeLog,v 1.30 2004/04/03 04:20:12 vapier Exp $
+
+*vpopmail-5.4.0 (02 Apr 2004)
+
+ 02 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #39639.
08 Mar 2004; Robin H. Johnson <robbat2@gentoo.org> vpopmail-5.2.1-r8.ebuild,
vpopmail-5.2.1-r9.ebuild:
diff --git a/net-mail/vpopmail/files/digest-vpopmail-5.4.0 b/net-mail/vpopmail/files/digest-vpopmail-5.4.0
new file mode 100644
index 000000000000..dc0be8292cfc
--- /dev/null
+++ b/net-mail/vpopmail/files/digest-vpopmail-5.4.0
@@ -0,0 +1,2 @@
+MD5 6de751d3794b091a58464fd85f7bc00c vpopmail-5.4.0.tar.gz 418736
+MD5 9d12d36935643050617a76c5104c4d28 vpopmail-5.2.1-mysql.diff 5211
diff --git a/net-mail/vpopmail/vpopmail-5.4.0.ebuild b/net-mail/vpopmail/vpopmail-5.4.0.ebuild
new file mode 100644
index 000000000000..04ada0cbb80e
--- /dev/null
+++ b/net-mail/vpopmail/vpopmail-5.4.0.ebuild
@@ -0,0 +1,242 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/vpopmail/vpopmail-5.4.0.ebuild,v 1.1 2004/04/03 04:20:12 vapier Exp $
+
+inherit eutils gnuconfig fixheadtails
+
+# TODO: all ldap, sybase support
+MY_PV=${PV/_/-}
+MY_P=${PN}-${MY_PV}
+HOMEPAGE="http://www.inter7.com/vpopmail"
+DESCRIPTION="A collection of programs to manage virtual email domains and accounts on your Qmail or Postfix mail servers."
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
+ mysql? ( http://gentoo.twobit.net/misc/${PN}-5.2.1-mysql.diff )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="mysql ipalias clearpasswd"
+
+DEPEND_COMMON="net-mail/qmail
+ mysql? ( >=dev-db/mysql-3.23* )"
+DEPEND="sys-apps/sed
+ sys-apps/ucspi-tcp
+ ${DEPEND_COMMON}"
+RDEPEND="${DEPEND_COMMON}
+ virtual/cron"
+
+S="${WORKDIR}/${MY_P}"
+
+# Define vpopmail home dir in /etc/password if different
+VPOP_DEFAULT_HOME="/var/vpopmail"
+VPOP_HOME="$VPOP_DEFAULT_HOME"
+
+# This makes sure the variable is set, and that it isn't null.
+vpopmail_set_homedir() {
+ VPOP_HOME=`getent passwd vpopmail | cut -d: -f6`
+ if [ -z "$VPOP_HOME" ]; then
+ echo -ne "\a"
+ eerror "vpopmail's home directory is null in passwd data!"
+ eerror "You probably want to check that out."
+ eerror "Continuing with default."
+ VPOP_HOME="${VPOP_DEFAULT_HOME}"
+ else
+ einfo "Setting VPOP_HOME to: $VPOP_HOME"
+ fi
+}
+
+pkg_setup() {
+ enewgroup vpopmail 89
+ enewuser vpopmail 89 /bin/false ${VPOP_DEFAULT_HOME} vpopmail
+ upgradewarning
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${MY_P}.tar.gz
+ cd ${S}
+
+ epatch ${FILESDIR}/vpopmail-5.2.1-showall.patch
+
+ sed -i \
+ 's|Maildir|.maildir|g' \
+ vchkpw.c vconvert.c vdelivermail.c \
+ vpopbull.c vpopmail.c vqmaillocal.c \
+ vuserinfo.c maildirquota.c \
+ || die "failed to change Maildir to .maildir"
+ sed -i \
+ '/printf.*vpopmail/s:vpopmail (:(:' \
+ vdelivermail.c vpopbull.c vqmaillocal.c \
+ || die "failed to remove vpopmail advertisement"
+
+ gnuconfig_update
+ ht_fix_file ${S}/cdb/Makefile
+}
+
+src_compile() {
+ vpopmail_set_homedir
+
+ use ipalias \
+ && myopts="${myopts} --enable-ip-alias-domains=y" \
+ || myopts="${myopts} --enable-ip-alias-domains=n"
+
+ use mysql \
+ && myopts="${myopts} --enable-auth-module=mysql \
+ --enable-libs=/usr/include/mysql \
+ --enable-sqllibdir=/usr/lib/mysql \
+ --enable-mysql-logging=y \
+ --enable-auth-logging=y \
+ --enable-valias=y \
+ --enable-mysql-replication=n \
+ --enable-mysql-limits" \
+ || myopts="${myopts} --enable-mysql=n"
+
+ # Bug 20127
+ use clearpasswd \
+ && myopts="${myopts} --enable-clear-passwd=y" \
+ || myopts="${myopts} --enable-clear-passwd=n"
+
+ econf \
+ ${myopts} \
+ --sbindir=/usr/sbin \
+ --bindir=/usr/bin \
+ --sysconfdir=${VPOP_HOME}/etc \
+ --enable-qmaildir=/var/qmail \
+ --enable-qmail-newu=/var/qmail/bin/qmail-newu \
+ --enable-qmail-inject=/var/qmail/bin/qmail-inject \
+ --enable-qmail-newmrh=/var/qmail/bin/qmail-newmrh \
+ --enable-vpopuser=vpopmail \
+ --enable-many-domains=y \
+ --enable-vpopgroup=vpopmail \
+ --enable-file-locking=y \
+ --enable-file-sync=y \
+ --enable-md5-passwords=y \
+ --enable-logging=y \
+ --enable-log-name=vpopmail \
+ --enable-qmail-ext \
+ --enable-domainquotas \
+ --disable-tcp-rules-prog --disable-tcpserver-file --disable-roaming-users \
+ || die
+
+ # TCPRULES for relaying is now considered obsolete, use relay-ctrl instead
+ #--enable-tcprules-prog=/usr/bin/tcprules --enable-tcpserver-file=/etc/tcp.smtp \
+ #--enable-roaming-users=y --enable-relay-clear-minutes=60 \
+ #--disable-rebuild-tcpserver-file \
+
+ emake || die "Make failed."
+}
+
+src_install() {
+ vpopmail_set_homedir
+
+ make DESTDIR=${D} install || die
+
+ into /var/vpopmail
+ dobin ${FILESDIR}/vpopmail-Maildir-dotmaildir-fix.sh
+ into /usr
+
+ # Install documentation.
+ dodoc AUTHORS ChangeLog FAQ INSTALL README*
+ dodoc doc/doc_html/* doc/man_html/*
+ rm -rf ${D}/${VPOP_HOME}/doc
+ dosym /usr/share/doc/${PF}/ ${VPOP_HOME}/doc
+
+ # Create /etc/vpopmail.conf
+ if use mysql ; then
+ einfo "Installing vpopmail mysql configuration file"
+ dodir /etc
+ #config file position
+ mv ${D}/var/vpopmail/etc/vpopmail.mysql ${D}/etc/vpopmail.conf
+ dosym /etc/vpopmail.conf /var/vpopmail/etc/vpopmail.mysql
+ sed -e '12d' -i ${D}/etc/vpopmail.conf
+ echo '# Read-only DB' >>${D}/etc/vpopmail.conf
+ echo 'localhost|0|vpopmail|secret|vpopmail' >>${D}/etc/vpopmail.conf
+ echo '# Write DB' >>${D}/etc/vpopmail.conf
+ echo 'localhost|0|vpopmail|secret|vpopmail' >>${D}/etc/vpopmail.conf
+ # lock down perms
+ fperms 640 /etc/vpopmail.conf
+ fowners root:vpopmail /etc/vpopmail.conf
+ fi
+
+ # Install a proper cronjob instead of the old nastiness
+ #einfo "Installing cronjob"
+ #dodir /etc/cron.hourly
+ #insinto /etc/cron.hourly
+ #doins ${FILESDIR}/vpopmail.clearopensmtp
+ #fperms +x /etc/cron.hourly/vpopmail.clearopensmtp
+
+ einfo "Installing env.d entry"
+ dodir /etc/env.d
+ insinto /etc/env.d
+ doins ${FILESDIR}/99vpopmail
+
+ # Configure b0rked. We'll do this manually
+ #echo "-I${VPOP_HOME}/include" > ${D}/${VPOP_HOME}/etc/inc_deps
+ #local libs_extra
+ #use mysql && libs_extra="-L/usr/lib/mysql -lmysqlclient -lz" || libs_extra=""
+ #echo "-L${VPOP_HOME}/lib -lvpopmail ${libs_extra}" > ${D}/${VPOP_HOME}/etc/lib_deps
+
+ einfo "Locking down vpopmail permissions"
+ # secure things more, i don't want the vpopmail user being able to write this stuff!
+ chown -R root:root ${D}${VPOP_HOME}/{bin,etc,include}
+}
+
+pkg_preinst() {
+ vpopmail_set_homedir
+
+ # Keep DATA
+ keepdir ${VPOP_HOME}/domains
+
+ # This is a workaround until portage handles binary packages+users better.
+ pkg_setup
+
+ upgradewarning
+}
+
+pkg_postinst() {
+ einfo "Performing post-installation routines for ${P}."
+
+ if use mysql ; then
+ echo
+ einfo "You have 'mysql' turned on in your USE"
+ einfo "Vpopmail needs a VALID MySQL USER. Let's call it 'vpopmail'"
+ einfo "You MUST add it and then specify its passwd in the /etc/vpopmail.conf file"
+ echo
+ einfo "First log into mysql as your mysql root user and pass. Then:"
+ einfo "> create database vpopmail;"
+ einfo "> use mysql;"
+ einfo "> grant select, insert, update, delete, create, drop on vpopmail.* to"
+ einfo " vpopmail@localhost identified by 'your password';"
+ einfo "> flush privileges;"
+ echo
+ einfo "If you have problems with vpopmail not accepting mail properly,"
+ einfo "please ensure that /etc/vpopmail.conf is chmod 640 and"
+ einfo "owned by root:vpopmail"
+ fi
+ # do this for good measure
+ if [ -e /etc/vpopmail.conf ] ; then
+ chmod 640 /etc/vpopmail.conf
+ chown root:vpopmail /etc/vpopmail.conf
+ fi
+
+ upgradewarning
+}
+
+pkg_postrm() {
+ vpopmail_set_homedir
+
+ einfo "The vpopmail DATA will NOT be removed automatically."
+ einfo "You can delete them manually by removing the ${VPOP_HOME} directory."
+}
+
+upgradewarning() {
+ ewarn "Massive important warning if you are upgrading to 5.2.1-r8 or older"
+ ewarn "The internal structure of the mail storage has changed for"
+ ewarn "consistancy with the rest of Gentoo! Please review and utilize the "
+ ewarn "script at /var/vpopmail/bin/vpopmail-Maildir-dotmaildir-fix.sh"
+ ewarn "to upgrade your system! (It can do conversions both ways)."
+ ewarn "You should be able to run it right away without any changes."
+ echo
+ einfo "Use of vpopmail's tcp.smtp[.cdb] is also deprecated now, consider"
+ einfo "using net-mail/relay-ctrl instead."
+}