summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2003-06-28 01:00:36 +0000
committerTodd Berman <tberman@gentoo.org>2003-06-28 01:00:36 +0000
commit991317de24de47c86f94452fbf8c9e607ed0690e (patch)
tree9944ded613cab5d35dd8004ae55a08037e97dd55 /net-mail
parentlots of great fixes from srcerer (an in-training dev) (diff)
downloadhistorical-991317de24de47c86f94452fbf8c9e607ed0690e.tar.gz
historical-991317de24de47c86f94452fbf8c9e607ed0690e.tar.bz2
historical-991317de24de47c86f94452fbf8c9e607ed0690e.zip
lots of great fixes from srcerer (an in-training dev)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/exim/Manifest6
-rw-r--r--net-mail/exim/exim-4.20-r1.ebuild212
-rw-r--r--net-mail/exim/files/digest-exim-4.20-r13
-rw-r--r--net-mail/exim/files/exim-4.20-maildir.patch14
4 files changed, 232 insertions, 3 deletions
diff --git a/net-mail/exim/Manifest b/net-mail/exim/Manifest
index 343feb274415..29fd9b0926f1 100644
--- a/net-mail/exim/Manifest
+++ b/net-mail/exim/Manifest
@@ -1,9 +1,9 @@
-MD5 901455cc138e36462e3c7839b77d18e2 ChangeLog 5266
+MD5 398d2fc4ee1367bd675e2f6b8350c48d ChangeLog 5660
MD5 0940d1b635323dccef779e9c41a78234 exim-4.10.ebuild 6212
MD5 99050d3d99619961c4b5fb54c9662aa6 exim-4.12.ebuild 5434
MD5 1960014d5516aa993f10ff19d0ce7e7c exim-4.14.ebuild 5435
+MD5 a54eb4cb54b7df1baf23f2ea6ec7466d exim-4.20-r1.ebuild 6166
MD5 412d1e8588d5ac36260ad9da692a1cdf exim-4.20.ebuild 5567
-MD5 b7f08e3ee9e7081f1c82e36aa44d628d exim-4.20-r1.ebuild 6168
MD5 68fc403ba2c98ccba281939085cb9052 files/auth_conf.sub 775
MD5 0cb2ffe88c81fd7ac8429b5a19d58b35 files/configure 16346
MD5 34def7b529693beda5b84c422d25a878 files/digest-exim-4.10 128
@@ -16,7 +16,7 @@ MD5 d61c997b7bac3e2730fe705c5d5a035b files/exim.rc6 510
MD5 eb249c90af3ab11e5a4d307e184a75ac files/exiscan.conf 22113
MD5 d230e0fa45f2b65d5bc50c0879c40148 files/pam.d-exim 101
MD5 0883fe67a34142a57e6f39ed9419cbee files/system_filter.exim 8118
-MD5 224405c67a9be298be27d65f64246ab9 files/exim-maildir-4.20-00.patch 390
MD5 04ba8d65b73d23eb58c6d3e4accbed7f files/digest-exim-4.20 198
MD5 5898fa2e00e85c771cffe741f3198c07 files/exiscan-acl-4.20-09.patch 263216
MD5 04ba8d65b73d23eb58c6d3e4accbed7f files/digest-exim-4.20-r1 198
+MD5 622b726ea7b32aae93a8fe9f3c2af9cd files/exim-4.20-maildir.patch 478
diff --git a/net-mail/exim/exim-4.20-r1.ebuild b/net-mail/exim/exim-4.20-r1.ebuild
new file mode 100644
index 000000000000..93d8caee3b8e
--- /dev/null
+++ b/net-mail/exim/exim-4.20-r1.ebuild
@@ -0,0 +1,212 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/exim/exim-4.20-r1.ebuild,v 1.1 2003/06/28 01:00:29 tberman Exp $
+
+IUSE="tcpd ssl postgres mysql ldap pam exiscan exiscan-acl maildir"
+
+EXISCAN_VER=${PV}-26
+EXISCANACL_VER=${PV}-09
+DESCRIPTION="A highly configurable, drop-in replacement for sendmail"
+SRC_URI="ftp://ftp.exim.org/pub/exim/exim4/${P}.tar.gz
+ exiscan? ( http://duncanthrax.net/exiscan/exiscan-${EXISCAN_VER}.tar.gz )
+ exiscan-acl? ( http://duncanthrax.net/exiscan-acl/exiscan-acl-${EXISCANACL_VER}.patch )"
+
+
+HOMEPAGE="http://www.exim.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+PROVIDE="virtual/mta"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ dev-lang/perl
+ >=sys-libs/db-3.2
+ >=dev-libs/libpcre-3.4
+ pam? ( >=sys-libs/pam-0.75 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ mysql? ( >=dev-db/mysql-3.23.28 )
+ postgres? ( >=dev-db/postgresql-7 )"
+
+RDEPEND="${DEPEND}
+ !virtual/mta
+ >=net-mail/mailbase-0.00"
+
+src_unpack() {
+ unpack ${A}
+
+ local myconf
+
+ cd ${S}
+ if use maildir; then
+ einfo "Patching maildir support into exim.conf"
+ epatch ${FILESDIR}/exim-${PV}-maildir.patch
+ fi
+ sed -i "/SYSTEM_ALIASES_FILE/ s'SYSTEM_ALIASES_FILE'/etc/mail/aliases'" ${S}/src/configure.default
+ cp ${S}/src/configure.default ${S}/src/configure.default.orig
+ if use exiscan; then
+ einfo "Patching exiscan support into exim ${PV}.."
+ epatch ${WORKDIR}/exiscan-${EXISCAN_VER}/exiscan-${EXISCAN_VER}.patch
+ fi
+ if use exiscan-acl; then
+ einfo "Patching exican-acl support into exim ${PV}.."
+ epatch ${DISTDIR}/exiscan-acl-${EXISCANACL_VER}.patch
+ fi
+
+ sed -e "48i\CFLAGS=${CFLAGS}" \
+ -e "s:# AUTH_CRAM_MD5=yes:AUTH_CRAM_MD5=yes:" \
+ -e "s:# AUTH_PLAINTEXT=yes:AUTH_PLAINTEXT=yes:" \
+ -e "s:BIN_DIRECTORY=/usr/exim/bin:BIN_DIRECTORY=/usr/sbin:" \
+ -e "s:COMPRESS_COMMAND=/opt/gnu/bin/gzip:COMPRESS_COMMAND=/usr/bin/gzip:" \
+ -e "s:ZCAT_COMMAND=/opt/gnu/bin/zcat:ZCAT_COMMAND=/usr/bin/zcat:" \
+ -e "s:CONFIGURE_FILE=/usr/exim/configure:CONFIGURE_FILE=/etc/exim/exim.conf:" \
+ -e "s:EXIM_MONITOR=eximon.bin:# EXIM_MONITOR=eximon.bin:" \
+ -e "s:# EXIM_PERL=perl.o:EXIM_PERL=perl.o:" \
+ -e "s:# INFO_DIRECTORY=/usr/local/info:INFO_DIRECTORY=/usr/share/info:" \
+ -e "s:# LOG_FILE_PATH=/var/log/exim_%slog:LOG_FILE_PATH=/var/log/exim/exim_%s.log:" \
+ -e "s:# PID_FILE_PATH=/var/lock/exim.pid:PID_FILE_PATH=/var/run/exim.pid:" \
+ -e "s:# SPOOL_DIRECTORY=/var/spool/exim:SPOOL_DIRECTORY=/var/spool/exim:" \
+ -e "s:# SUPPORT_MAILDIR=yes:SUPPORT_MAILDIR=yes:" \
+ -e "s:# SUPPORT_MAILSTOR=yes:SUPPORT_MAILSTORE=yes:" \
+ -e "s:# SUPPORT_MBX=yes:SUPPORT_MBX=yes:" \
+ -e "s:EXIM_USER=:EXIM_USER=mail:" \
+ -e "s:# AUTH_SPA=yes:AUTH_SPA=yes:" \
+ src/EDITME > Local/Makefile
+
+ cd Local
+ if use pam; then
+ sed -i "s:# \(SUPPORT_PAM=yes\):\1:" Makefile
+ myconf="${myconf} -lpam"
+ fi
+ if use tcpd; then
+ sed -i "s:# \(USE_TCP_WRAPPERS=yes\):\1:" Makefile
+ myconf="${myconf} -lwrap"
+ fi
+ if use lmtp; then
+ sed -i "s:# \(TRANSPORT_LMTP=yes\):\1:" Makefile
+ fi
+
+ if [ -n "$myconf" ] ; then
+ echo "EXTRALIBS=${myconf}" >> Makefile
+ fi
+
+ cd ${S}
+ if use ssl; then
+ sed -i \
+ -e "s:# \(SUPPORT_TLS=yes\):\1:" \
+ -e "s:# \(TLS_LIBS=-lssl -lcrypto\):\1:" Local/Makefile
+ fi
+
+ LOOKUP_INCLUDE=
+ LOOKUP_LIBS=
+
+ if use ldap; then
+ sed -i \
+ -e "s:# \(LOOKUP_LDAP=yes\):\1:" \
+ -e "s:# \(LDAP_LIB_TYPE=OPENLDAP2\):\1:" Local/Makefile
+ LOOKUP_INCLUDE="-I/usr/include/ldap"
+ LOOKUP_LIBS="-L/usr/lib -lldap -llber"
+ fi
+
+ if use mysql; then
+ sed -i "s:# LOOKUP_MYSQL=yes:LOOKUP_MYSQL=yes:" Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/mysql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -L/usr/lib -lmysqlclient"
+ fi
+
+ if use postgres; then
+ sed -i "s:# LOOKUP_PGSQL=yes:LOOKUP_PGSQL=yes:" Local/Makefile
+ LOOKUP_INCLUDE="$LOOKUP_INCLUDE -I/usr/include/postgresql"
+ LOOKUP_LIBS="$LOOKUP_LIBS -lpq"
+ fi
+
+ if [ -n "$LOOKUP_INCLUDE" ]; then
+ sed -i "s:# LOOKUP_INCLUDE=-I /usr/local/ldap/include -I /usr/local/mysql/include -I /usr/local/pgsql/include:LOOKUP_INCLUDE=$LOOKUP_INCLUDE:" \
+ Local/Makefile
+ fi
+
+ if [ -n "$LOOKUP_LIBS" ]; then
+ sed -i "s:# LOOKUP_LIBS=-L/usr/local/lib -lldap -llber -lmysqlclient -lpq:LOOKUP_LIBS=$LOOKUP_LIBS:" \
+ Local/Makefile
+ fi
+
+
+ cat Makefile | sed -e 's/^buildname=.*/buildname=exim-gentoo/g' > Makefile.gentoo && mv -f Makefile.gentoo Makefile
+
+ sed -i "s:# LOOKUP_DSEARCH=yes:LOOKUP_DSEARCH=yes:" Local/Makefile
+
+ sed -i "s:# LOOKUP_CDB=yes:LOOKUP_CDB=yes:" Local/Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+
+src_install () {
+
+ cd ${S}/build-exim-gentoo
+ exeinto /usr/sbin
+ doexe exim
+ fperms 4755 /usr/sbin/exim
+
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosym ../sbin/exim /usr/bin/mailq
+ dosym ../sbin/exim /usr/bin/newaliases
+ dosym ../sbin/exim /usr/bin/mail
+ dosym exim /usr/sbin/rsmtp
+ dosym exim /usr/sbin/rmail
+ dosym exim /usr/sbin/sendmail
+ dosym ../sbin/exim /usr/lib/sendmail
+
+ exeinto /usr/sbin
+ for i in exicyclog exim_dbmbuild exim_dumpdb exim_fixdb exim_lock \
+ exim_tidydb exinext exiwhat exigrep eximstats exiqsumm \
+ convert4r3 convert4r4
+ do
+ doexe $i
+ done
+
+ dodoc ${S}/doc/*
+ doman ${S}/doc/exim.8
+
+ # conf files
+ insinto /etc/exim
+ newins ${S}/src/configure.default.orig exim.conf.dist
+ if use exiscan-acl; then
+ newins ${S}/src/configure.default exim.conf.exiscan-acl
+ fi
+ doins ${FILESDIR}/system_filter.exim
+ doins ${FILESDIR}/auth_conf.sub
+ if use exiscan; then
+ newins ${S}/src/configure.default exim.conf.exiscan
+ doins ${FILESDIR}/exiscan.conf
+ fi
+
+ # INSTALL a pam.d file for SMTP AUTH that works with gentoo's pam
+ insinto /etc/pam.d
+ newins ${FILESDIR}/pam.d-exim exim
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/exim.rc6 exim
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/exim.confd exim
+
+ DIROPTIONS="--mode=0750 --owner=mail --group=mail"
+ dodir /var/log/${PN}
+}
+
+
+pkg_postinst() {
+
+ einfo "/etc/exim/system_filter.exim is a sample system_filter."
+ einfo "/etc/exim/auth_conf.sub contains the configuration sub for using smtp auth."
+ einfo "Please create /etc/exim/exim.conf from /etc/exim/exim.conf.dist."
+
+}
+
+
diff --git a/net-mail/exim/files/digest-exim-4.20-r1 b/net-mail/exim/files/digest-exim-4.20-r1
new file mode 100644
index 000000000000..1bf1437b725c
--- /dev/null
+++ b/net-mail/exim/files/digest-exim-4.20-r1
@@ -0,0 +1,3 @@
+MD5 a1f06f1de1ab602a25d78ad2a20819f2 exim-4.20.tar.gz 1549612
+MD5 a18eb772895af7b190d17c5b151d4dd9 exiscan-4.20-26.tar.gz 63663
+MD5 5898fa2e00e85c771cffe741f3198c07 exiscan-acl-4.20-09.patch 263216
diff --git a/net-mail/exim/files/exim-4.20-maildir.patch b/net-mail/exim/files/exim-4.20-maildir.patch
new file mode 100644
index 000000000000..3cb198d545c1
--- /dev/null
+++ b/net-mail/exim/files/exim-4.20-maildir.patch
@@ -0,0 +1,14 @@
+diff -urN ./exim-4.20.orig/src/configure.default exim-4.20/src/configure.default
+--- ./exim-4.20.orig/src/configure.default 2003-06-27 16:48:22.000000000 -0700
++++ exim-4.20/src/configure.default 2003-06-27 16:52:20.000000000 -0700
+@@ -451,7 +451,9 @@
+
+ local_delivery:
+ driver = appendfile
+- file = /var/mail/$local_part
++# file = /var/mail/$local_part
++ directory = /home/$local_part/.maildir
++ maildir_format
+ delivery_date_add
+ envelope_to_add
+ return_path_add