summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2002-11-14 18:23:20 +0000
committerMartin Holzer <mholzer@gentoo.org>2002-11-14 18:23:20 +0000
commitc7b78e38a1d5f0db1e3c2585637c2e49f212616e (patch)
tree301646e6fd1dd49a597074f2932cdf1e120f0162 /net-misc/iperf
parentinitial ebuild (diff)
downloadhistorical-c7b78e38a1d5f0db1e3c2585637c2e49f212616e.tar.gz
historical-c7b78e38a1d5f0db1e3c2585637c2e49f212616e.tar.bz2
historical-c7b78e38a1d5f0db1e3c2585637c2e49f212616e.zip
added new ebuild iperf-1.6.3
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/ChangeLog7
-rw-r--r--net-misc/iperf/files/digest-iperf-1.6.31
-rw-r--r--net-misc/iperf/files/iperf-1.6.3-Makefile-gentoo.diff16
-rw-r--r--net-misc/iperf/iperf-1.6.3.ebuild51
4 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
new file mode 100644
index 000000000000..d8a61f2a7b79
--- /dev/null
+++ b/net-misc/iperf/ChangeLog
@@ -0,0 +1,7 @@
+*iperf-1.6.3 (14 Nov 2002)
+
+ 14 Nov 2002; Martin Holzer <mholzer@gentoo.org> iperf-1.6.3.ebuild
+ ChangeLog files/digest-iperf-1.6.3 files/iperf-1.6.3-Makefile-gentoo.diff :
+
+ Iperf is a tool to measure IP bandwidth using UDP or TCP.
+
diff --git a/net-misc/iperf/files/digest-iperf-1.6.3 b/net-misc/iperf/files/digest-iperf-1.6.3
new file mode 100644
index 000000000000..132951b25192
--- /dev/null
+++ b/net-misc/iperf/files/digest-iperf-1.6.3
@@ -0,0 +1 @@
+MD5 958894904f7abddef9239d2fa12b40da iperf-1.6.3-source.tar.gz 215837
diff --git a/net-misc/iperf/files/iperf-1.6.3-Makefile-gentoo.diff b/net-misc/iperf/files/iperf-1.6.3-Makefile-gentoo.diff
new file mode 100644
index 000000000000..f454823ce7fe
--- /dev/null
+++ b/net-misc/iperf/files/iperf-1.6.3-Makefile-gentoo.diff
@@ -0,0 +1,16 @@
+--- Makefile.org 2002-10-31 13:03:27.000000000 +0100
++++ Makefile 2002-10-31 13:03:51.000000000 +0100
+@@ -62,13 +62,6 @@
+
+ install: $(PROG)
+ @echo
+- @echo "Where should the iperf binary be installed? [/usr/local/bin]"
+- @read INSTALL_DIR; \
+- export INSTALL_DIR; \
+- INSTALL_DIR=`echo $$INSTALL_DIR | perl -p -e 's/~/$$ENV{"HOME"}/'`; \
+- if test -z "$$INSTALL_DIR"; then \
+- INSTALL_DIR=/usr/local/bin; \
+- fi; \
+ echo ; (cd src ; make install); \
+ echo ; (cd jsrc ; make install)
+
diff --git a/net-misc/iperf/iperf-1.6.3.ebuild b/net-misc/iperf/iperf-1.6.3.ebuild
new file mode 100644
index 000000000000..7dbd08d8cc99
--- /dev/null
+++ b/net-misc/iperf/iperf-1.6.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Holzer <mholzer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-1.6.3.ebuild,v 1.1 2002/11/14 18:23:20 mholzer Exp $
+
+# This ebuild was generated by Ebuilder v0.4.
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Iperf is a tool to measure IP bandwidth using UDP or TCP. It allows for tuning various parameters, and reports bandwidth, delay jitter, and packet loss. It supports IPv6 and multicast."
+SRC_URI="http://dast.nlanr.net/Projects/Iperf/${P}-source.tar.gz"
+HOMEPAGE="http://dast.nlanr.net/Projects/Iperf"
+DEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack "${P}-source.tar.gz"
+ cd "${S}"
+ patch -p0 < ${FILESDIR}/${P}-Makefile-gentoo.diff
+}
+
+src_compile() {
+ # emake (previously known as pmake) is a script that calls the
+ # standard GNU make with parallel building options for speedier
+ # builds (especially on SMP systems). Try emake first. It might
+ # not work for some packages, in which case you'll have to resort
+ # to normal "make".
+ cd cfg
+ econf || die
+ cd ..
+ emake || die
+}
+
+src_install () {
+ #make DESTDIR=${D} install || die
+ make INSTALL_DIR=${D}/usr install || die
+ # If the above installs anything outside of DESTDIR, try the following.
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+ #(cd src ; make install)
+ #(cd jsrc ; make install)
+
+ # Install documentation.
+ dodoc INSTALL README VERSION
+}
+