summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-07-07 12:55:05 +0000
committerStuart Herbert <stuart@gentoo.org>2004-07-07 12:55:05 +0000
commit84c861460bc863c10de05870366d65dea23f62b2 (patch)
treec4b4476dd3170e1713667756944de2fac7f37331 /net-misc/nxcomp
parent~alpha keywording, bug #55943. (diff)
downloadhistorical-84c861460bc863c10de05870366d65dea23f62b2.tar.gz
historical-84c861460bc863c10de05870366d65dea23f62b2.tar.bz2
historical-84c861460bc863c10de05870366d65dea23f62b2.zip
NX library now installed into /usr/NX/lib
Diffstat (limited to 'net-misc/nxcomp')
-rw-r--r--net-misc/nxcomp/Manifest8
-rw-r--r--net-misc/nxcomp/files/digest-nxcomp-1.3.2-r11
-rw-r--r--net-misc/nxcomp/nxcomp-1.3.2-r1.ebuild39
3 files changed, 45 insertions, 3 deletions
diff --git a/net-misc/nxcomp/Manifest b/net-misc/nxcomp/Manifest
index 79933fb26232..866804663c22 100644
--- a/net-misc/nxcomp/Manifest
+++ b/net-misc/nxcomp/Manifest
@@ -1,8 +1,10 @@
-MD5 cfd3056a6bffc8a82f721ed61a91ebfd nxcomp-1.3.0.ebuild 950
-MD5 cc46c59f7cb12fb5bb961db242d04fb2 nxcomp-1.3.2.ebuild 937
-MD5 150a12960b0b0b3c6661240ee305246a nxcomp-1.2.2-r1.ebuild 756
MD5 b71accecd91907ba15fcbd99bdf73b19 ChangeLog 1687
MD5 8e92b9291198042d907534cb08b013f8 metadata.xml 361
+MD5 150a12960b0b0b3c6661240ee305246a nxcomp-1.2.2-r1.ebuild 756
+MD5 cfd3056a6bffc8a82f721ed61a91ebfd nxcomp-1.3.0.ebuild 950
+MD5 b4cc70c7b0faf4629131deb377e971cc nxcomp-1.3.2-r1.ebuild 971
+MD5 cc46c59f7cb12fb5bb961db242d04fb2 nxcomp-1.3.2.ebuild 937
MD5 93171603dadf0e06996bd9fd833c5064 files/digest-nxcomp-1.2.2-r1 67
MD5 a766a8d9478498b282f0852b5e38377d files/digest-nxcomp-1.3.0 67
MD5 bbbdf1a4b71647d0606017837bb7fc69 files/digest-nxcomp-1.3.2 66
+MD5 bbbdf1a4b71647d0606017837bb7fc69 files/digest-nxcomp-1.3.2-r1 66
diff --git a/net-misc/nxcomp/files/digest-nxcomp-1.3.2-r1 b/net-misc/nxcomp/files/digest-nxcomp-1.3.2-r1
new file mode 100644
index 000000000000..6753c94d74cd
--- /dev/null
+++ b/net-misc/nxcomp/files/digest-nxcomp-1.3.2-r1
@@ -0,0 +1 @@
+MD5 1790feafa93c3ca58af117ab6f1f5bca nxcomp-1.3.2-4.tar.gz 432456
diff --git a/net-misc/nxcomp/nxcomp-1.3.2-r1.ebuild b/net-misc/nxcomp/nxcomp-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..0e2a4c8b88e5
--- /dev/null
+++ b/net-misc/nxcomp/nxcomp-1.3.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/nxcomp-1.3.2-r1.ebuild,v 1.1 2004/07/07 12:55:05 stuart Exp $
+
+MY_P="${PN}-1.3.2-4"
+DESCRIPTION="X11 protocol compression library"
+HOMEPAGE="http://www.nomachine.com/"
+SRC_URI="http://www.nomachine.com/download/nxsources/nxcomp/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+DEPEND=">=media-libs/jpeg-6b-r3
+>=media-libs/libpng-1.2.5-r4
+>=sys-devel/gcc-3.2.3-r2
+>=sys-libs/glibc-2.3.2-r3
+>=sys-libs/zlib-1.1.4-r2
+virtual/x11"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ ./configure
+ DISTCC_HOSTS="localhost" CCACHE_DISABLE="1" emake || die "compile problem"
+}
+
+src_install() {
+ into /usr/NX
+ dolib libXcomp.so.${PV}
+ into /usr
+ preplib /usr/NX
+
+ dodoc README README-IPAQ LICENSE VERSION
+
+ insinto /usr/NX/include
+ doins NX.h
+}