summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-06 22:16:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-06 22:16:05 +0000
commit1dc362752e02f85eb8688699d590f95b0e22009d (patch)
treea75f37ab3b06dcf05541d5a6e96c2bbaf7a4fbbb /net-misc/openssh
parentcleanup of my own orphaned ones (diff)
downloadhistorical-1dc362752e02f85eb8688699d590f95b0e22009d.tar.gz
historical-1dc362752e02f85eb8688699d590f95b0e22009d.tar.bz2
historical-1dc362752e02f85eb8688699d590f95b0e22009d.zip
old
Diffstat (limited to 'net-misc/openssh')
-rw-r--r--net-misc/openssh/files/digest-openssh-3.9_p1-r24
-rw-r--r--net-misc/openssh/openssh-3.9_p1-r2.ebuild156
2 files changed, 0 insertions, 160 deletions
diff --git a/net-misc/openssh/files/digest-openssh-3.9_p1-r2 b/net-misc/openssh/files/digest-openssh-3.9_p1-r2
deleted file mode 100644
index 9f7213b5b5f5..000000000000
--- a/net-misc/openssh/files/digest-openssh-3.9_p1-r2
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 8e1774d0b52aff08f817f3987442a16e openssh-3.9p1.tar.gz 854027
-MD5 e1be73c425cc6893df83ced51ee1df10 openssh-lpk-3.9p1-0.3.4.patch 44563
-MD5 eedb263c96a1d7bf208eb2ba70c2e238 openssh-3.9p1+x509h.diff.gz 98011
-MD5 b91d73e58e2b72aecb3025ee550411fb openssh-3.9p1-hpn11.diff 13237
diff --git a/net-misc/openssh/openssh-3.9_p1-r2.ebuild b/net-misc/openssh/openssh-3.9_p1-r2.ebuild
deleted file mode 100644
index e8d9cd45f6e1..000000000000
--- a/net-misc/openssh/openssh-3.9_p1-r2.ebuild
+++ /dev/null
@@ -1,156 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-3.9_p1-r2.ebuild,v 1.13 2005/09/06 01:38:55 vapier Exp $
-
-inherit eutils flag-o-matic ccc pam
-
-# Make it more portable between straight releases
-# and _p? releases.
-PARCH=${P/_/}
-
-SFTPLOG_PATCH_VER="1.2"
-X509_PATCH="${PARCH}+x509h.diff.gz"
-SELINUX_PATCH="openssh-3.9_p1-selinux.diff"
-LDAP_PATCH="${PARCH/-/-lpk-}-0.3.4.patch"
-HPN_PATCH="${PARCH}-hpn11.diff"
-
-DESCRIPTION="Port of OpenBSD's free SSH release"
-HOMEPAGE="http://www.openssh.com/"
-SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
- ldap? ( http://www.opendarwin.org/en/projects/openssh-lpk/files/${LDAP_PATCH} )
- X509? ( http://roumenpetrov.info/openssh/x509h/${X509_PATCH} )
- hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} )"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
-IUSE="ipv6 static pam tcpd kerberos skey selinux chroot X509 ldap smartcard sftplogging hpn"
-
-RDEPEND="pam? ( >=sys-libs/pam-0.73 >=sys-apps/shadow-4.0.2-r2 )
- kerberos? ( virtual/krb5 )
- selinux? ( sys-libs/libselinux )
- skey? ( >=app-admin/skey-1.1.5-r1 )
- ldap? ( net-nds/openldap )
- >=dev-libs/openssl-0.9.6d
- >=sys-libs/zlib-1.1.4
- smartcard? ( dev-libs/opensc )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
-DEPEND="${RDEPEND}
- virtual/os-headers
- sys-devel/autoconf"
-PROVIDE="virtual/ssh"
-
-S=${WORKDIR}/${PARCH}
-
-src_unpack() {
- unpack ${PARCH}.tar.gz
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-pamfix.patch.bz2
- #epatch "${FILESDIR}"/${P}-largekey.patch.bz2
- epatch "${FILESDIR}"/${P}-fix_suid.patch.bz2
- epatch "${FILESDIR}"/${P}-infoleak.patch #59361
- epatch "${FILESDIR}"/${P}-terminal_restore.patch.bz2
- epatch "${FILESDIR}"/${P}-configure-openct.patch #78730
- epatch "${FILESDIR}"/${P}-kerberos-detection.patch #80811
-
- use sftplogging && epatch ${FILESDIR}/${P}-sftplogging-1.2-gentoo.patch.bz2
- use skey && epatch ${FILESDIR}/${P}-skey.patch.bz2
- use chroot && epatch ${FILESDIR}/${P}-chroot.patch
- use X509 && epatch ${DISTDIR}/${X509_PATCH}
- use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
- use smartcard && epatch ${FILESDIR}/${P}-opensc.patch.bz2
- if use ldap ; then
- if use X509 || use sftplogging ; then
- ewarn "Sorry, x509/sftplogging and ldap don't get along"
- else
- epatch ${DISTDIR}/${LDAP_PATCH}
- fi
- fi
- use hpn && epatch ${DISTDIR}/${HPN_PATCH}
-
- autoconf || die "autoconf failed"
-}
-
-src_compile() {
- local myconf
-
- addwrite /dev/ptmx
-
- # make sure .sbss is large enough
- use skey && use alpha && append-ldflags -mlarge-data
- if use ldap ; then
- filter-flags -funroll-loops
- append-ldflags -lldap
- append-flags -DWITH_LDAP_PUBKEY
- fi
- use selinux && append-flags "-DWITH_SELINUX"
-
- if use static ; then
- append-ldflags -static
- use pam && ewarn "Disabling pam support becuse of static flag"
- myconf="${myconf} --without-pam"
- else
- myconf="${myconf} $(use_with pam)"
- fi
-
- use ipv6 || myconf="${myconf} --with-ipv4-default"
-
- econf \
- --with-ldflags="${LDFLAGS}" \
- --disable-strip \
- --sysconfdir=/etc/ssh \
- --libexecdir=/usr/$(get_libdir)/misc \
- --datadir=/usr/share/openssh \
- --disable-suid-ssh \
- --with-privsep-path=/var/empty \
- --with-privsep-user=sshd \
- --with-md5-passwords \
- $(use_with kerberos kerberos5 /usr) \
- $(use_with tcpd tcp-wrappers) \
- $(use_with skey) \
- $(use_with smartcard opensc) \
- ${myconf} \
- || die "bad configure"
-
- emake || die "compile problem"
-}
-
-src_install() {
- make install-files DESTDIR="${D}" || die
- fperms 600 /etc/ssh/sshd_config
- dobin contrib/ssh-copy-id
- newinitd "${FILESDIR}"/sshd.rc6 sshd
- keepdir /var/empty
-
- newpamd "${FILESDIR}"/sshd.pam sshd
- dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
- use pam \
- && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
- && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
-
- doman contrib/ssh-copy-id.1
- dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
-}
-
-pkg_postinst() {
- enewgroup sshd 22
- enewuser sshd 22 -1 /var/empty sshd
-
- ewarn "Remember to merge your config files in /etc/ssh/ and then"
- ewarn "restart sshd: '/etc/init.d/sshd restart'."
- ewarn
- einfo "As of version 3.4 the default is to enable the UsePrivelegeSeparation"
- einfo "functionality, but please ensure that you do not explicitly disable"
- einfo "this in your configuration as disabling it opens security holes"
- einfo
- einfo "This revision has removed your sshd user id and replaced it with a"
- einfo "new one with UID 22. If you have any scripts or programs that"
- einfo "that referenced the old UID directly, you will need to update them."
- einfo
- if use pam ; then
- einfo "Please be aware users need a valid shell in /etc/passwd"
- einfo "in order to be allowed to login."
- einfo
- fi
-}