summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-04 09:14:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-04 09:14:53 +0000
commitab70caa9d316906ddafadeed0b50a92976e4f310 (patch)
tree416574562d399ff22e07f71d85e4068b94987fb1 /net-misc/rsync
parentVersion bump for security vulnerability (diff)
downloadhistorical-ab70caa9d316906ddafadeed0b50a92976e4f310.tar.gz
historical-ab70caa9d316906ddafadeed0b50a92976e4f310.tar.bz2
historical-ab70caa9d316906ddafadeed0b50a92976e4f310.zip
Version bump for security vulnerability
Diffstat (limited to 'net-misc/rsync')
-rw-r--r--net-misc/rsync/Manifest4
-rw-r--r--net-misc/rsync/files/digest-rsync-2.5.72
-rw-r--r--net-misc/rsync/rsync-2.5.7.ebuild73
3 files changed, 77 insertions, 2 deletions
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index 883762a91fa3..8cbcccc54d4c 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1,7 +1,7 @@
MD5 05d9684d23790a068ada95d017095078 rsync-2.5.6-r3.ebuild 2007
-MD5 509e55bd827ff684d7c0d6564579e857 rsync-2.5.7.ebuild 2058
+MD5 794977333c4fa10d419cc3d7912cfb44 rsync-2.5.7.ebuild 2225
MD5 eb6f1281e1f06beb50eccdfd904615a8 rsync-2.5.6-r4.ebuild 2044
-MD5 da261c2dea7260af9a71e7cff9b050c5 ChangeLog 4938
+MD5 d4ae4e1c9c0cca260015ed8e487c8d98 ChangeLog 5082
MD5 38f45eaed761df27cfa731ce65763e98 files/rsyncd.conf.d 355
MD5 b87d68fcfff9eb9ae5cdbea3796693c5 files/rsyncd.init.d 423
MD5 65fa0a7432ef5585d43f6c437bbe117a files/digest-rsync-2.5.7 136
diff --git a/net-misc/rsync/files/digest-rsync-2.5.7 b/net-misc/rsync/files/digest-rsync-2.5.7
new file mode 100644
index 000000000000..8d1d108981eb
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.5.7
@@ -0,0 +1,2 @@
+MD5 9b3ec929091d7849f42b973247918a55 rsync-2.5.7.tar.gz 444035
+MD5 a399e227a18ea3f2eb5aa2b401006d2d rsync-2.5.6-proxy-auth-1.patch 4353
diff --git a/net-misc/rsync/rsync-2.5.7.ebuild b/net-misc/rsync/rsync-2.5.7.ebuild
new file mode 100644
index 000000000000..68040f3467ae
--- /dev/null
+++ b/net-misc/rsync/rsync-2.5.7.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.5.7.ebuild,v 1.1 2003/12/04 09:14:51 seemant Exp $
+
+inherit eutils
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz
+ http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ !build? ( >=dev-libs/popt-1.5 )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ epatch ${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch
+
+ # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
+ # configure option doesn't work
+ sed -i 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h
+ # yes, updating the man page is very important.
+ sed -i 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5
+}
+
+src_compile() {
+ [ -n "$(use build)" ] \
+ && POPTSETTING="--with-included-popt" \
+ || POPTSETTING=""
+ [ -z "${CC}" ] && CC=gcc
+ if [ "`${CC} -dumpversion | cut -d. -f1,2`" = "2.95" ] ; then
+ export LDFLAGS="${LDFLAGS} -lpthread"
+ fi
+ econf \
+ ${POPTSETTING} \
+ --with-rsh=ssh \
+ || die
+ use static && export LDFLAGS="${LDFLAGS} -static"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ insinto /etc/conf.d && newins ${FILESDIR}/rsyncd.conf.d rsyncd
+ exeinto /etc/init.d && newexe ${FILESDIR}/rsyncd.init.d rsyncd
+ if [ -z "`use build`" ] ; then
+ dodir /etc/rsync
+ dodoc COPYING NEWS OLDNEWS README TODO tech_report.tex
+ if [ ! -e /etc/rsync/rsyncd.conf ] ; then
+ insinto /etc/rsync
+ doins ${FILESDIR}/rsyncd.conf
+ fi
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsync/rsync.conf and make sure"
+ ewarn "it says: use chroot = yes"
+
+ einfo 'This patch enables usage of user:pass@proxy.foo:port'
+ einfo 'in the RSYNC_PROXY environment variable to support'
+ einfo 'the "Basic" proxy authentication scheme if you are'
+ einfo 'behind a password protected HTTP proxy.'
+}