summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2009-10-21 21:46:11 +0000
committerMike Doty <kingtaco@gentoo.org>2009-10-21 21:46:11 +0000
commit6cffa9b7e12af6666c62f2cea715ef661535616e (patch)
tree3aae3135777c985305d681e177be492673b8ad53 /net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild
parentStabilizing for ppc. (diff)
downloadhistorical-6cffa9b7e12af6666c62f2cea715ef661535616e.tar.gz
historical-6cffa9b7e12af6666c62f2cea715ef661535616e.tar.bz2
historical-6cffa9b7e12af6666c62f2cea715ef661535616e.zip
change rwhoisd homedir to /var/rwhoisd and sample data to /var/rwhoisd/samples
Package-Manager: portage-2.1.7.1/cvs/Linux x86_64
Diffstat (limited to 'net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild')
-rw-r--r--net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild b/net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild
new file mode 100644
index 000000000000..6c2b5b359994
--- /dev/null
+++ b/net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rwhoisd/rwhoisd-1.5.9.5-r1.ebuild,v 1.1 2009/10/21 21:46:11 kingtaco Exp $
+
+EAPI=0
+inherit eutils
+
+DESCRIPTION="ARIN rwhois daemon"
+HOMEPAGE="http://projects.arin.net/rwhois/"
+SRC_URI="http://projects.arin.net/rwhois/ftp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ cd "${S}"
+ epatch "${FILESDIR}"/rwhoisd-destdir-${PV}.patch || die "epatch failed"
+ econf
+ emake -j1
+}
+
+src_install () {
+ emake -j1 install DESTDIR=${D}
+ doinitd "${FILESDIR}"/rwhoisd || die "doinitd failed"
+ newconfd "${FILESDIR}"/rwhoisd.conf rwhoisd || die "newconfd failed"
+}
+
+pkg_setup() {
+ enewgroup rwhoisd
+ enewuser rwhoisd -1 -1 /var/rwhoisd rwhoisd
+}
+
+pkg_postinst () {
+ einfo "Please make sure to set the userid in rwhoisd.conf to rwhoisd."
+ einfo "It is highly inadvisable to run rwhoisd as root."
+}