summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-01-27 16:02:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-01-27 16:02:34 +0000
commit94f682e910b9946f5b1b4a516cf6b4ecd65ce5b7 (patch)
tree14c03bd8a55350998a47f8a35fb086ba9ff2310d /net-misc/stone
parentStable on amd64, bug #204287 (diff)
downloadhistorical-94f682e910b9946f5b1b4a516cf6b4ecd65ce5b7.tar.gz
historical-94f682e910b9946f5b1b4a516cf6b4ecd65ce5b7.tar.bz2
historical-94f682e910b9946f5b1b4a516cf6b4ecd65ce5b7.zip
Version bumped. bug #207577.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-misc/stone')
-rw-r--r--net-misc/stone/ChangeLog7
-rw-r--r--net-misc/stone/files/digest-stone-2.3c3
-rw-r--r--net-misc/stone/stone-2.3c.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/net-misc/stone/ChangeLog b/net-misc/stone/ChangeLog
index 44cf57ec6cb8..bbce3ae27eb3 100644
--- a/net-misc/stone/ChangeLog
+++ b/net-misc/stone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/stone
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/ChangeLog,v 1.13 2008/01/26 17:04:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/ChangeLog,v 1.14 2008/01/27 16:02:33 matsuu Exp $
+
+*stone-2.3c (27 Jan 2008)
+
+ 27 Jan 2008; MATSUU Takuto <matsuu@gentoo.org> +stone-2.3c.ebuild:
+ Version bumped. bug #207577.
26 Jan 2008; Raúl Porcel <armin76@gentoo.org> stone-2.2e.ebuild:
x86 stable
diff --git a/net-misc/stone/files/digest-stone-2.3c b/net-misc/stone/files/digest-stone-2.3c
new file mode 100644
index 000000000000..c26bcbdcd107
--- /dev/null
+++ b/net-misc/stone/files/digest-stone-2.3c
@@ -0,0 +1,3 @@
+MD5 1eb7da00cb1a5ce07d1cac8f60722ecd stone-2.3c.tar.gz 85752
+RMD160 ffa90f48ad57262733a6ff371d84045c3e8cfdc6 stone-2.3c.tar.gz 85752
+SHA256 2ef3f63f1ccdb86f00251ca40cb3f99fefa1cbe21858fbc3af92b5c2b0d8ef3f stone-2.3c.tar.gz 85752
diff --git a/net-misc/stone/stone-2.3c.ebuild b/net-misc/stone/stone-2.3c.ebuild
new file mode 100644
index 000000000000..fdc40e245011
--- /dev/null
+++ b/net-misc/stone/stone-2.3c.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stone/stone-2.3c.ebuild,v 1.1 2008/01/27 16:02:33 matsuu Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple TCP/IP packet repeater"
+HOMEPAGE="http://www.gcd.org/sengoku/stone/"
+SRC_URI="http://www.gcd.org/sengoku/stone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ if use ssl ; then
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ SSL=/usr \
+ linux-ssl || die
+ else
+ emake \
+ CFLAGS="${CFLAGS}" \
+ linux || die
+ fi
+}
+
+src_install() {
+ dobin stone
+ doman stone.1
+ dodoc README*
+}