summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2003-12-26 14:10:55 +0000
committerJason Wever <weeve@gentoo.org>2003-12-26 14:10:55 +0000
commit999211dff5f8810d975aab5369225400725d446c (patch)
tree6c70d7597ffa047176b16ef2ccec5c8a5fa7ce57 /net-misc/unison
parentMarked stable on sparc to fix broken net-misc/unison dependencies. (diff)
downloadhistorical-999211dff5f8810d975aab5369225400725d446c.tar.gz
historical-999211dff5f8810d975aab5369225400725d446c.tar.bz2
historical-999211dff5f8810d975aab5369225400725d446c.zip
Added sed-fu fix to unison to adjust it's Makefile.OCaml for the new tail syntax.
Diffstat (limited to 'net-misc/unison')
-rw-r--r--net-misc/unison/ChangeLog6
-rw-r--r--net-misc/unison/Manifest4
-rw-r--r--net-misc/unison/unison-2.9.1.ebuild10
3 files changed, 16 insertions, 4 deletions
diff --git a/net-misc/unison/ChangeLog b/net-misc/unison/ChangeLog
index 36a19d26d9a5..bdb11cac4634 100644
--- a/net-misc/unison/ChangeLog
+++ b/net-misc/unison/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/unison
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.5 2003/12/23 12:28:10 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/ChangeLog,v 1.6 2003/12/26 14:10:47 weeve Exp $
+
+ 26 Dec 2003; Jason Wever <weeve@gentoo.org> unison-2.9.1.ebuild:
+ Added sed-fu fix to unison to adjust it's Makefile.OCaml for the new tail
+ syntax.
23 Dec 2003; Markus Nigbur <pyrania@gentoo.org> unison-2.9.1.ebuild:
Fixed tarball and digest issues.
diff --git a/net-misc/unison/Manifest b/net-misc/unison/Manifest
index 99d6a29a6efd..26b4fd2f436c 100644
--- a/net-misc/unison/Manifest
+++ b/net-misc/unison/Manifest
@@ -1,3 +1,3 @@
-MD5 51e6242c733f80a3fe338bb575e74836 unison-2.9.1.ebuild 934
-MD5 cbe95579e86b58aed27f1c1d763b72aa ChangeLog 583
+MD5 20cbdb19578d11b94e15f6968879d4f9 ChangeLog 843
+MD5 f6aa5e9dc4d6676dd1e7f03634f106af unison-2.9.1.ebuild 1071
MD5 29b28492666138199820e9df8fcc6a47 files/digest-unison-2.9.1 64
diff --git a/net-misc/unison/unison-2.9.1.ebuild b/net-misc/unison/unison-2.9.1.ebuild
index 619d4777c051..202d1b0d152b 100644
--- a/net-misc/unison/unison-2.9.1.ebuild
+++ b/net-misc/unison/unison-2.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.9.1.ebuild,v 1.7 2003/12/23 12:28:10 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/unison/unison-2.9.1.ebuild,v 1.8 2003/12/26 14:10:47 weeve Exp $
IUSE="gtk"
@@ -18,6 +18,14 @@ SRC_URI="mirror://${P}.tar.gz"
S=${WORKDIR}/${P}
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ # Fix for coreutils change of tail syntax
+ cd ${S}
+ sed -i -e 's/tail -1/tail -n 1/' Makefile.OCaml
+}
+
src_compile() {
local myconf