summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-04 06:57:22 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-04 06:57:22 +0000
commit3f7807774f8bb69b3180ed44b254d644d8afeada (patch)
treef522e8b2a6d4f0085793101ae679b1689ff8f56c /net-misc/xfsamba
parentfix a stupid mistake (diff)
downloadhistorical-3f7807774f8bb69b3180ed44b254d644d8afeada.tar.gz
historical-3f7807774f8bb69b3180ed44b254d644d8afeada.tar.bz2
historical-3f7807774f8bb69b3180ed44b254d644d8afeada.zip
New package. Fixes #3102
Diffstat (limited to 'net-misc/xfsamba')
-rw-r--r--net-misc/xfsamba/ChangeLog16
-rw-r--r--net-misc/xfsamba/files/digest-xfsamba-0.471
-rw-r--r--net-misc/xfsamba/xfsamba-0.47.ebuild32
3 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/xfsamba/ChangeLog b/net-misc/xfsamba/ChangeLog
new file mode 100644
index 000000000000..af78c04fcbb6
--- /dev/null
+++ b/net-misc/xfsamba/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for net-misc/xfsamba
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xfsamba/ChangeLog,v 1.1 2002/06/04 06:57:22 rphillips Exp $
+
+*xfsamba-0.47 (3 June 2002)
+
+ 3 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Ebuild submitted by Dan Naumov <jago@telefragged.com>
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/net-misc/xfsamba/files/digest-xfsamba-0.47 b/net-misc/xfsamba/files/digest-xfsamba-0.47
new file mode 100644
index 000000000000..7a4e9cea3cbe
--- /dev/null
+++ b/net-misc/xfsamba/files/digest-xfsamba-0.47
@@ -0,0 +1 @@
+MD5 b2383527e32ef8a28eec87aee899a300 xfsamba-0.47.tar.gz 1344158
diff --git a/net-misc/xfsamba/xfsamba-0.47.ebuild b/net-misc/xfsamba/xfsamba-0.47.ebuild
new file mode 100644
index 000000000000..070e21f472b5
--- /dev/null
+++ b/net-misc/xfsamba/xfsamba-0.47.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/xfsamba/xfsamba-0.47.ebuild,v 1.1 2002/06/04 06:57:22 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A GUI SMB network navigator"
+SRC_URI="http://xfsamba.sourceforge.net/archive/${P}.tar.gz"
+HOMEPAGE="http://xfsamba.sourceforge.net/"
+LICENSE="GPL-2"
+DEPEND="=dev-libs/glib-1.2*
+ =x11-libs/gtk+-1.2*
+ nls? ( sys-devel/gettext )"
+RDEPEND=">=net-fs/samba-2.2.4"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ ./configure ${myconf} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --disable-gtktest \
+ --disable-glibtest || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+}
+