summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-09-26 18:43:20 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-09-26 18:43:20 +0000
commit0973b8a6e26919149b44c0bf678ea67c12d96d3b (patch)
tree4a8ba360fe46bb245392615412803834877f7bad /net-misc
parentVersion bump. (diff)
downloadhistorical-0973b8a6e26919149b44c0bf678ea67c12d96d3b.tar.gz
historical-0973b8a6e26919149b44c0bf678ea67c12d96d3b.tar.bz2
historical-0973b8a6e26919149b44c0bf678ea67c12d96d3b.zip
fixed makefile to work with DESTDIR to avoid sandbox violations. version bump (#50938)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/blogtk/ChangeLog9
-rw-r--r--net-misc/blogtk/Manifest7
-rw-r--r--net-misc/blogtk/blogtk-1.0.ebuild35
-rw-r--r--net-misc/blogtk/files/blogtk-1.0-destdir.patch28
-rw-r--r--net-misc/blogtk/files/digest-blogtk-1.01
5 files changed, 77 insertions, 3 deletions
diff --git a/net-misc/blogtk/ChangeLog b/net-misc/blogtk/ChangeLog
index f656edf06cec..70ef34c9b89b 100644
--- a/net-misc/blogtk/ChangeLog
+++ b/net-misc/blogtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/blogtk
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/blogtk/ChangeLog,v 1.4 2004/06/24 23:37:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/blogtk/ChangeLog,v 1.5 2004/09/26 18:43:20 liquidx Exp $
+
+*blogtk-1.0 (26 Sep 2004)
+
+ 26 Sep 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/blogtk-1.0-destdir.patch, +blogtk-1.0.ebuild:
+ fixed makefile to work with DESTDIR to avoid sandbox violations. version bump
+ (#50938)
24 Mar 2004; Martin Holzer <mholzer@gentoo.org> blogtk-0.8.ebuild,
blogtk-0.9.ebuild:
diff --git a/net-misc/blogtk/Manifest b/net-misc/blogtk/Manifest
index 3f2ae17406bf..ea5f201f31ae 100644
--- a/net-misc/blogtk/Manifest
+++ b/net-misc/blogtk/Manifest
@@ -1,6 +1,9 @@
-MD5 899ffb6f5722235b6fdd434929ad0703 blogtk-0.9.ebuild 825
+MD5 f88f10e1999a663bc9188647c8a4ca6f ChangeLog 912
MD5 ae0779a1275669593caa912574ff578b blogtk-0.8.ebuild 817
-MD5 70d2669bc65a6262fa260154056c5805 ChangeLog 690
+MD5 899ffb6f5722235b6fdd434929ad0703 blogtk-0.9.ebuild 825
MD5 44295278a53f3f287dbde873a44bde97 metadata.xml 161
+MD5 5fe5d5bc4e12adbc706325947dbb9596 blogtk-1.0.ebuild 814
MD5 43c6f624366818bbedf10aab206fdd58 files/digest-blogtk-0.8 64
MD5 6e64d3305cb3080142ca15b53074ad16 files/digest-blogtk-0.9 64
+MD5 f96e3cc6ede69196d19c7bf411d84065 files/digest-blogtk-1.0 62
+MD5 9c6d63937d69fd3b3cb659ff7f11f70e files/blogtk-1.0-destdir.patch 1029
diff --git a/net-misc/blogtk/blogtk-1.0.ebuild b/net-misc/blogtk/blogtk-1.0.ebuild
new file mode 100644
index 000000000000..aee8166e87d0
--- /dev/null
+++ b/net-misc/blogtk/blogtk-1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/blogtk/blogtk-1.0.ebuild,v 1.1 2004/09/26 18:43:20 liquidx Exp $
+
+inherit eutils
+
+DESCRIPTION="GTK Blog - post entries to your blog"
+HOMEPAGE="http://blogtk.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.bz2"
+RESTRICT="nomirror"
+S="${WORKDIR}/BloGTK-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/pygtk-2.0.0
+ >=gnome-base/gconf-2.2.0
+ >=dev-python/gnome-python-2"
+
+DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-destdir.patch
+}
+
+src_compile() {
+ return
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Unable to compile blogtk"
+}
diff --git a/net-misc/blogtk/files/blogtk-1.0-destdir.patch b/net-misc/blogtk/files/blogtk-1.0-destdir.patch
new file mode 100644
index 000000000000..2f438a6114ca
--- /dev/null
+++ b/net-misc/blogtk/files/blogtk-1.0-destdir.patch
@@ -0,0 +1,28 @@
+--- Makefile 2004-03-16 22:01:09.000000000 +0000
++++ Makefile.new 2004-09-26 19:39:23.000309640 +0100
+@@ -10,11 +10,11 @@
+ # autodetect GNOME prefix, change this if you want it elsewhere
+ PREFIX ?= `pkg-config libgnome-2.0 --variable=prefix || echo /usr`
+
+-LIBDIR = $(PREFIX)/lib/blogtk
+-BINDIR = $(PREFIX)/bin
+-DATADIR = $(PREFIX)/share/blogtk
+-APPLICATIONSDIR = $(PREFIX)/share/applications
+-ICONDIR = $(PREFIX)/share/pixmaps
++LIBDIR = $(DESTDIR)$(PREFIX)/lib/blogtk
++BINDIR = $(DESTDIR)$(PREFIX)/bin
++DATADIR = $(DESTDIR)$(PREFIX)/share/blogtk
++APPLICATIONSDIR = $(DESTDIR)$(PREFIX)/share/applications
++ICONDIR = $(DESTDIR)$(PREFIX)/share/pixmaps
+
+ PYFILES := $(shell $(FIND) . -name "*.py" -print)
+
+@@ -28,7 +28,5 @@
+ $(INSTALL) -m 644 data/blogtk-icon.svgz $(ICONDIR)
+ $(INSTALL) -m 644 data/blogtk.desktop $(APPLICATIONSDIR)
+
+- if test -f /usr/bin/BloGTK; then rm /usr/bin/BloGTK; fi
+-
+- ln -s $(LIBDIR)/BloGTK.py $(BINDIR)/BloGTK
++ ln -sf $(PREFIX)/lib/blogtk/BloGTK.py $(BINDIR)/BloGTK
+ chmod +x $(BINDIR)/BloGTK
diff --git a/net-misc/blogtk/files/digest-blogtk-1.0 b/net-misc/blogtk/files/digest-blogtk-1.0
new file mode 100644
index 000000000000..8bd191fdb70c
--- /dev/null
+++ b/net-misc/blogtk/files/digest-blogtk-1.0
@@ -0,0 +1 @@
+MD5 90d40f7fb7df5636396caedaf34b73da blogtk_1.0.tar.bz2 52265